SOLVED
Home

Windows 10 Enterprise Start Menu in KIOSK mode show the expected tiles but they are not working

%3CLINGO-SUB%20id%3D%22lingo-sub-255135%22%20slang%3D%22en-US%22%3EWindows%2010%20Enterprise%20Start%20Menu%20in%20KIOSK%20mode%20show%20the%20expected%20tiles%20but%20they%20are%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-255135%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20deploying%20Windows%2010%20Enterprise%20devices%20with%20an%20Azure%20AD%20account%20into%20Azure%20AD%20and%20intune.%20Users%20are%20enrolled%20as%20normal%20users%20(no%20admin).%20After%20enrolment%20we%20deploy%20an%20UWP%20app%20to%20the%20device%20and%20apply%20a%20KIOSK%20mode%20profile%20with%20Intune.%20On%20the%20device%20where%20I%20extracted%20the%20orginal%20custom%20start%20Menu%20Layout%20xml%20from%20%2C%20this%20works%20perfectly.%20Device%20runs%20in%20kiosk%20mode%20and%20only%20the%20selected%20apps%20in%20the%20custom%20start%20menu%20can%20be%20started.%20When%20I%20configure%20another%20device%20(same%20formfactor)%20with%20the%20same%20Azure%20AD%20account%20everything%20is%20configured%20as%20expected%20but%20the%20tiles%20of%20the%20selected%20application%20does%20not%20start%20when%20clicked%20%2C%20double%20clicked%20or%20touched.%20The%20Tiles%20are%20there%20%2C%20move%20when%20clicked%20%2C%20but%20start%20nothing.%20No%20errors%20whatsoever.%20Very%20difficult%20to%20troubleshoot%20because%20I%20have%20no%20access%20to%20other%20applications%20and%20when%20I%20remove%20the%20kiosk%20profile%20the%20issue%20is%20gone.%20Any%20ideas%20or%20help%20would%20be%20appreciated.%20Thanks%20P%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-255135%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-362685%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2010%20Enterprise%20Start%20Menu%20in%20KIOSK%20mode%20show%20the%20expected%20tiles%20but%20they%20are%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-362685%22%20slang%3D%22en-US%22%3EHi%20Frank%20%2C%20will%20try%20now%20that%20kiosk%20mode%20was%20released.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298107%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2010%20Enterprise%20Start%20Menu%20in%20KIOSK%20mode%20show%20the%20expected%20tiles%20but%20they%20are%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298107%22%20slang%3D%22en-US%22%3E%3CP%3EYou%20can%20also%20use%20the%20-UseDesktopApplicationID%20switch%20when%20exporting%20the%20layout.%20For%20example%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSTRONG%3E%3CEM%3EExport-StartLayout%20-Path%20'C%3A%5CStartLayout.xml'%20-UseDesktopApplicationID%3C%2FEM%3E%3C%2FSTRONG%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-292293%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2010%20Enterprise%20Start%20Menu%20in%20KIOSK%20mode%20show%20the%20expected%20tiles%20but%20they%20are%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-292293%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20%2C%20I%20will%20give%20it%20a%20GO.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%20%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPeter%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-276339%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2010%20Enterprise%20Start%20Menu%20in%20KIOSK%20mode%20show%20the%20expected%20tiles%20but%20they%20are%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-276339%22%20slang%3D%22en-US%22%3E%3CP%3EI%20can%20confirm%20using%20DesktopApplicationID%60s%20solves%20strange%20issues%20when%20publishing%20a%20startmenu%20using%20Intune%20and%20also%20with%20GPO%60s.%3CBR%20%2F%3EDefinitely%20worth%20trying!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-275848%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2010%20Enterprise%20Start%20Menu%20in%20KIOSK%20mode%20show%20the%20expected%20tiles%20but%20they%20are%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-275848%22%20slang%3D%22en-US%22%3E%3CP%3EI%20know%20what%20you%20are%20dealing%20with%2C%20and%20this%20one%20is%20documented%20poorly.%20It%20is%20not%20terribly%20hard%20to%20fix%20however.%20I%20learned%20all%20of%20this%20while%20working%20with%20a%20really%20helpful%20field%20engineer%20out%20of%20Australia.%20Actually%20he%20was%20Customer%20Experience%20driver%2C%20and%20put%20all%20the%20field%20engineers%20(who%20know%20nothing%20it%20seems)%20to%20shame.%20%3A%3C%2FP%3E%3CP%3EWhen%20you%20export%20the%20start%20layout%20that%20you%20want%2C%20crack%20it%20open%20in%20your%20favorite%20XML%20editor%20%2C%20and%20change%20the%26nbsp%3B%20URL%20for%20the%20application.%20You%20see%2C%20with%20that%20profile%20the%20AMUID%20is%20generated%20based%20on%20the%20Provisioned%20account.%20The%20Azure%20account%20does%20not%20pre-exist%20on%20the%20computer%20so%20it%20has%20to%20be%20provisioned%2C%20This%20means%20hard%20links%20like%20that%20will%20not%20work%20because%20all%20applications%20are%20consumed%20on%20a%20user%20base%20for%20the%20most%20part%2C%20in%20Windows%2010.%20One%20way%20to%20get%20around%20this%20is%20to%20place%20the%20start%20menu%20shortcuts%20in%20%3CSPAN%3E%22%25AllUsersProfile%25%5CMicrosoft%5CWindows%5CStart%20Menu%5CPrograms%5C%3CAPPNAME%3E.lnk%22%3C%2FAPPNAME%3E%3C%2FSPAN%3E%20%3B%20then%20they%20will%20always%20work.I%20recently%20learned%2C%20that%20is%20not%20the%20best%20way%20either.%20I%20had%20the%20links%20showing%20up%20just%20like%20you%20%2C%20but%20not%20working.%20Here%20is%20how%20you%20fix%20that%3A%3CBR%20%2F%3EThe%20Start%20Menu%20XML%2C%20the%20app%20tile%20will%20use%20%3CSTRONG%3EDesktopApplicationLinkPath%3C%2FSTRONG%3E%20for%20the%20reference%20to%20the%20app%2C%20which%20will%20fail%20when%20using%20MDM%20to%20provision%20the%20tile.%26nbsp%3B%26nbsp%3B%20You%20need%20to%20use%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows%2Fconfiguration%2Fstart-layout-xml-desktop%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3EDesktopApplicationID%3C%2FA%3E%3CSTRONG%3E.%3C%2FSTRONG%3E%26nbsp%3BIn%20order%20to%20get%20the%20DesktopApplicationID%2C%3CA%20title%3D%22DesktopApplictionID%22%20href%3D%22https%3A%2F%2Fwww.systemcenterdudes.com%2Fconfigure-start-menu-windows-10-1703-and-above%2F%22%20target%3D%22_self%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Efollow%20this%20link.%26nbsp%3B%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20trick%20that%20NO%20ONE%20I%20KNOW%20knew%20about%20was%20this%20cmdlet%3A%20%3CSTRONG%3EGet-StartApps%3C%2FSTRONG%3E.%20This%20allows%20you%20to%20work%20like%20you%20normally%20do%20and%20design%20a%20start%20menu%2C%20and%20then%20harvest%20the%20correct%20AppID%20GUID%2FURL%20thingy%20after%20you%20Export-StartLayout%2C%20and%20replace%20the%20Path%2C%20with%20the%20ID.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESorry%20im%20so%20verbose.%20It%20is%20an%20easy%20fix%20though.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Peter Wuytack
Occasional Contributor

Hi ,

 

I am deploying Windows 10 Enterprise devices with an Azure AD account into Azure AD and intune. Users are enrolled as normal users (no admin). After enrolment we deploy an UWP app to the device and apply a KIOSK mode profile with Intune. On the device where I extracted the orginal custom start Menu Layout xml from , this works perfectly. Device runs in kiosk mode and only the selected apps in the custom start menu can be started. When I configure another device (same formfactor) with the same Azure AD account everything is configured as expected but the tiles of the selected application does not start when clicked , double clicked or touched. The Tiles are there , move when clicked , but start nothing. No errors whatsoever. Very difficult to troubleshoot because I have no access to other applications and when I remove the kiosk profile the issue is gone. Any ideas or help would be appreciated. Thanks P

5 Replies
Solution

I know what you are dealing with, and this one is documented poorly. It is not terribly hard to fix however. I learned all of this while working with a really helpful field engineer out of Australia. Actually he was Customer Experience driver, and put all the field engineers (who know nothing it seems) to shame. :

When you export the start layout that you want, crack it open in your favorite XML editor , and change the  URL for the application. You see, with that profile the AMUID is generated based on the Provisioned account. The Azure account does not pre-exist on the computer so it has to be provisioned, This means hard links like that will not work because all applications are consumed on a user base for the most part, in Windows 10. One way to get around this is to place the start menu shortcuts in "%AllUsersProfile%\Microsoft\Windows\Start Menu\Programs\<appName>.lnk" ; then they will always work.I recently learned, that is not the best way either. I had the links showing up just like you , but not working. Here is how you fix that:
The Start Menu XML, the app tile will use DesktopApplicationLinkPath for the reference to the app, which will fail when using MDM to provision the tile.   You need to use DesktopApplicationID. In order to get the DesktopApplicationID,follow this link.  

 

The trick that NO ONE I KNOW knew about was this cmdlet: Get-StartApps. This allows you to work like you normally do and design a start menu, and then harvest the correct AppID GUID/URL thingy after you Export-StartLayout, and replace the Path, with the ID.

 

Sorry im so verbose. It is an easy fix though.

 

 

 

I can confirm using DesktopApplicationID`s solves strange issues when publishing a startmenu using Intune and also with GPO`s.
Definitely worth trying!

Highlighted

Thanks , I will give it a GO.

 

Regards ,

 

Peter

You can also use the -UseDesktopApplicationID switch when exporting the layout. For example:

 

Export-StartLayout -Path 'C:\StartLayout.xml' -UseDesktopApplicationID

Hi Frank , will try now that kiosk mode was released.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies