Home

Can't Register devices in the iOS Comp Portal App

%3CLINGO-SUB%20id%3D%22lingo-sub-758377%22%20slang%3D%22en-US%22%3ECan't%20Register%20devices%20in%20the%20iOS%20Comp%20Portal%20App%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-758377%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20currently%20are%20facing%20issues%20in%20registering%20a%20device%20via%20the%20Comp%20Portal%20App%20on%20iOS.%20The%20same%20process%20however%20on%20our%20Android%20Devices%20seems%20to%20be%20working%20fine.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20getting%20the%20error%3A%20%22We%20can't%20register%20this%20device%20now.%20Try%20again%20later%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20some%20configuration%20we%20changed%20that%20would%20cause%20this%20behavior.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-758377%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%20Device%20Management%20(MDM)%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-758405%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20Register%20devices%20in%20the%20iOS%20Comp%20Portal%20App%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-758405%22%20slang%3D%22en-US%22%3EHave%20you%20blocked%20personal%20iOS%20devices%20on%20your%20tenant%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-762785%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20Register%20devices%20in%20the%20iOS%20Comp%20Portal%20App%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-762785%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F377477%22%20target%3D%22_blank%22%3E%40ShreyasHA%3C%2FA%3E%26nbsp%3Byou%20can%20always%20check%20enrollment%20errors%20for%20more%20details.%20Easiest%20way%20si%20through%20%22Troubleshooting%22%20section%20in%20Intune%20portal.%20Just%20select%20user%20you%20used%20for%20enrollment%20and%20it%20should%20show%20you%20errors.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-763846%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20Register%20devices%20in%20the%20iOS%20Comp%20Portal%20App%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-763846%22%20slang%3D%22en-US%22%3EIt%20might%20not%20be%20the%20same%20problem%2C%20but%20I%20was%20receiving%20the%20same%20error%20recently%20when%20enrolling%20iOS%20devices.%3CBR%20%2F%3EIt%20turns%20out%20the%20user%20account%20hit%20the%20device%20limit%20in%20Azure%20AD.%20I%20found%20out%20that%20devices%20in%20Azure%20AD%20aren't%20the%20same%20as%20devices%20in%20Intune.%20Same%20with%20the%20device%20limits.%3CBR%20%2F%3ETry%20checking%20the%20device%20limits%20you%20have%20in%20Azure%20AD%20and%20also%20any%20devices%20in%20Azure%20AD%20for%20the%20users%20with%20the%20problem.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-885495%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20Register%20devices%20in%20the%20iOS%20Comp%20Portal%20App%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-885495%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F376614%22%20target%3D%22_blank%22%3E%40FredContrata112%3C%2FA%3E%26nbsp%3BThank%20you%2C%20this%20solved%20my%20issue.%20I%20had%20to%20remove%20devices%20from%20both%20intune%20and%20Azure%20AD%3C%2FP%3E%3C%2FLINGO-BODY%3E
ShreyasHA
Occasional Visitor

We currently are facing issues in registering a device via the Comp Portal App on iOS. The same process however on our Android Devices seems to be working fine. 

 

We are getting the error: "We can't register this device now. Try again later"

 

Is there some configuration we changed that would cause this behavior.

4 Replies
Have you blocked personal iOS devices on your tenant?

@ShreyasHA you can always check enrollment errors for more details. Easiest way si through "Troubleshooting" section in Intune portal. Just select user you used for enrollment and it should show you errors.

It might not be the same problem, but I was receiving the same error recently when enrolling iOS devices.
It turns out the user account hit the device limit in Azure AD. I found out that devices in Azure AD aren't the same as devices in Intune. Same with the device limits.
Try checking the device limits you have in Azure AD and also any devices in Azure AD for the users with the problem.

@FredContrata112 Thank you, this solved my issue. I had to remove devices from both intune and Azure AD

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
38 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies