CSP Remediation failed

%3CLINGO-SUB%20id%3D%22lingo-sub-747570%22%20slang%3D%22en-US%22%3ECSP%20Remediation%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-747570%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ei'm%20currently%20facing%20a%20problem%20with%20a%20CSP%3A%3C%2FP%3E%3CP%3EI%20want%20to%20set%20the%20Timezone%20via%20CSP%20to%20my%20intune%20managed%20devices.%3C%2FP%3E%3CP%3ESo%20i%20created%20a%20custom%20profile%20like%20that%3A%3C%2FP%3E%3CP%3EOMA-URI%3A%26nbsp%3B%3C%2FP%3E%3CP%3E.%2FDevice%2FVendor%2FMSFT%2FPolicy%2FConfig%2FTimeLanguageSettings%2FConfigureTimeZone%3C%2FP%3E%3CP%3EData%20type%3A%20String%3C%2FP%3E%3CP%3EValue%3A%20i%20tried%26nbsp%3B%22W.%20Europe%20Standard%20Time%22%20(with%20and%20without%20quotation%20marks)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20already%20had%20a%20look%20at%20the%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows%2Fclient-management%2Fmdm%2Fpolicy-csp-timelanguagesettings%23timelanguagesettings-configuretimezone%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3ECSP%20Reference%20for%20this.%3C%2FA%3E%3C%2FP%3E%3CP%3ESo%20this%20should%20work%2C%20isn't%20it%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20that%20i%20received%20in%20eventlog%20the%20following%20error%3A%3C%2FP%3E%3CP%3E%22system%20cannot%20find%20the%20file%20specified%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20that%20i%20tried%20the%20OMA-URI%20without%20%22Device%2F%3C%2FP%3E%3CP%3E(.%2FVendor%2FMSFT%2FPolicy%2FConfig%2FTimeLanguageSettings%2FConfigureTimeZone)%3C%2FP%3E%3CP%3EAfterwards%20i%20got%20another%20error%20event%3A%3C%2FP%3E%3CP%3E%22An%20invalid%20Field%20name%20was%20used%20in%20the%20query%20string%22%200x80040204%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEdit%3A%3C%2FP%3E%3CP%3EAfter%20about%20half%20an%20hour%20it%20was%20working...%20%3AD%3C%2Fimg%3E%20Azure...%20%3AD%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20in%20advance!%3C%2FP%3E%3CP%3EPatrick%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-747570%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECSP%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%20Device%20Management%20(MDM)%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-815237%22%20slang%3D%22en-US%22%3ERe%3A%20CSP%20Remediation%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-815237%22%20slang%3D%22en-US%22%3EI%20have%20this%20same%20issue%2C%20would%20love%20to%20know%20where%20it's%20coming%20from...%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-831407%22%20slang%3D%22en-US%22%3ERe%3A%20CSP%20Remediation%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-831407%22%20slang%3D%22en-US%22%3EI%20had%20just%20finished%20wrestling%20with%20this%20myself.%20I%20had%20to%20remove%20the%20%2Fdevice%20from%20my%20string%20and%20remove%20the%20quotes%20around%20my%20timezone.%20After%20I%20did%20that%2C%20it%20worked%20right%20away.%20String%20that%20worked%3A%20.%2FVendor%2FMSFT%2FPolicy%2FConfig%2FTimeLanguageSettings%2FConfigureTimeZone%20Value%20that%20worked%3A%20Eastern%20Standard%20Time%20Thanks%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F275685%22%20target%3D%22_blank%22%3E%40PatrickF11%3C%2FA%3Efor%20the%20info%20which%20helped%20me%20fix%20my%20issue%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-831521%22%20slang%3D%22en-US%22%3ERe%3A%20CSP%20Remediation%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-831521%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F401140%22%20target%3D%22_blank%22%3E%40Shanekd%3C%2FA%3EI'm%20glad%20to%20hear%20I%20could%20help.%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Frequent Contributor

Hi,

 

i'm currently facing a problem with a CSP:

I want to set the Timezone via CSP to my intune managed devices.

So i created a custom profile like that:

OMA-URI: 

./Device/Vendor/MSFT/Policy/Config/TimeLanguageSettings/ConfigureTimeZone

Data type: String

Value: i tried "W. Europe Standard Time" (with and without quotation marks)

 

I already had a look at the CSP Reference for this.

So this should work, isn't it?

 

After that i received in eventlog the following error:

"system cannot find the file specified"

 

After that i tried the OMA-URI without "Device/

(./Vendor/MSFT/Policy/Config/TimeLanguageSettings/ConfigureTimeZone)

Afterwards i got another error event:

"An invalid Field name was used in the query string" 0x80040204

 

Edit:

After about half an hour it was working... :D Azure... :D

 

Thank you in advance!

Patrick :)

3 Replies
I have this same issue, would love to know where it's coming from...
I had just finished wrestling with this myself. I had to remove the /device from my string and remove the quotes around my timezone. After I did that, it worked right away. String that worked: ./Vendor/MSFT/Policy/Config/TimeLanguageSettings/ConfigureTimeZone Value that worked: Eastern Standard Time Thanks @PatrickF11 for the info which helped me fix my issue

@ShanekdI'm glad to hear I could help. :)

Related Conversations
Extentions Synchronization
ChirmyRam in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies