SOLVED
Home

Autopilot Hardware Hash changed

%3CLINGO-SUB%20id%3D%22lingo-sub-507258%22%20slang%3D%22en-US%22%3EAutopilot%20Hardware%20Hash%20changed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-507258%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20folks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%E2%80%99ve%20done%20some%20testing%20on%20autopilot%20now%20with%20two%20different%20Lenovo%20models%2C%20a%20L380%20Yoga%20and%20L390%20Yoga.%3C%2FP%3E%3CP%3EWhat%20really%20confuses%20me%20is%20the%20fact%20that%20everytime%20I%20do%20a%20clean%20install%20of%20Windows%2010%20(from%20an%20iso%20file)%20the%20hardware%20hash%20is%20changing.%20Is%20this%20really%20a%20normal%20behaviour%3F%20I%20thought%20the%20hardware%20hash%20is%20calculated%20just%20based%20on%20hardware%20configurations%2C%20but%20it%20seems%20that%20something%20else%20is%20part%20of%20that%20calculation.%20Can%20someone%20help%20me%20out%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-507258%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%20Device%20Management%20(MDM)%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-518174%22%20slang%3D%22en-US%22%3ERe%3A%20Autopilot%20Hardware%20Hash%20changed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-518174%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F281588%22%20target%3D%22_blank%22%3E%40gerlach_6300%3C%2FA%3E%26nbsp%3BHey%2C%20do%20you%20do%20anything%20with%20the%20TPM%20settings%20in%20the%20BIOS%20during%20your%20deployment%3F%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-523291%22%20slang%3D%22en-US%22%3ERe%3A%20Autopilot%20Hardware%20Hash%20changed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-523291%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F206210%22%20target%3D%22_blank%22%3E%40Coert%20Kastelein%3C%2FA%3E%26nbsp%3BI%20tried%20different%20methods%20during%20deployment%26nbsp%3B(i.%20a%20clearing%20the%20TPM%20via%20BIOS)%5Eand%20it%20doesn't%20matter.%20The%20hash%20value%20in%20the%20generated%20.csv%20is%20always%20different.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESomeone%20told%20me%20that%20there%20is%20also%20a%20timestamp%20part%20of%20the%20hardware%20hash%20in%20the%20.csv%20and%20because%20of%20that%20the%20hash%20is%20always%20different.%20But%20this%20actually%26nbsp%3Bmakes%20no%20sense%20to%20me%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-553180%22%20slang%3D%22en-US%22%3ERe%3A%20Autopilot%20Hardware%20Hash%20changed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-553180%22%20slang%3D%22en-US%22%3E%3CP%3EOk%2C%20I%20found%20the%20answer%20here%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows%2Fdeployment%2Fwindows-autopilot%2Fadd-devices%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows%2Fdeployment%2Fwindows-autopilot%2Fadd-devices%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CBLOCKQUOTE%3E%3CP%3ENote%20that%20the%20hardware%20hash%20also%20contains%20details%20about%20when%20it%20was%20generated%2C%20so%20it%20will%20change%20each%20time%20it%20is%20generated%3C%2FP%3E%3C%2FBLOCKQUOTE%3E%3C%2FLINGO-BODY%3E
gerlach_6300
New Contributor

Hi folks!

 

I’ve done some testing on autopilot now with two different Lenovo models, a L380 Yoga and L390 Yoga.

What really confuses me is the fact that everytime I do a clean install of Windows 10 (from an iso file) the hardware hash is changing. Is this really a normal behaviour? I thought the hardware hash is calculated just based on hardware configurations, but it seems that something else is part of that calculation. Can someone help me out?

 

 

3 Replies
Highlighted

@gerlach_6300 Hey, do you do anything with the TPM settings in the BIOS during your deployment?

@Coert Kastelein I tried different methods during deployment (i. a clearing the TPM via BIOS)^and it doesn't matter. The hash value in the generated .csv is always different.

 

Someone told me that there is also a timestamp part of the hardware hash in the .csv and because of that the hash is always different. But this actually makes no sense to me

 

Solution

Ok, I found the answer here: https://docs.microsoft.com/en-us/windows/deployment/windows-autopilot/add-devices

 

Note that the hardware hash also contains details about when it was generated, so it will change each time it is generated

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies