Home

AutoPilot silent encryption Surface Pro 6 failing

%3CLINGO-SUB%20id%3D%22lingo-sub-678371%22%20slang%3D%22en-US%22%3EAutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-678371%22%20slang%3D%22en-US%22%3EHi%2C%20has%20anyone%20had%20any%20joy%20enrolling%20Surface%20Pros%20with%20Autopilot%20enabling%20bitlocker%20silently%3F%3CBR%20%2F%3EI%20have%20the%20enrolment%20profile%20as%20the%20enrolee%20as%20a%20non-admin%20and%20bitlocker%20encryption%20allowed%20by%20non-admins.%3CBR%20%2F%3EI%20have%20%E2%80%98allow%20TPM%E2%80%99%20and%20%E2%80%98allow%20TPM%20and%20PIN%E2%80%99%20(and%20have%20tried%20various%20different%20combinations)%20configured%20as%20we%20want%20to%20use%20a%20PIN%20on%20boot.%3CBR%20%2F%3EWhen%20it%20goes%20through%20the%20enrol%20it%20completes%20and%20loads%20Windows%2C%20and%20bitlocker%20is%20off.%20When%20I%20try%20to%20enable%20manually%20it%20fails%20due%20to%20group%20policy%20issue.%20The%20Event%20viewer%20says%20%E2%80%98cannot%20silently%20encrypt%20due%20to%20the%20lack%20of%20keyboard%E2%80%99.%20I%20have%20tried%20with%20keyboard%20disconnected%2C%20connected%2C%20external%20keyboard%20via%20Surface%20docker...%3CBR%20%2F%3EAm%20I%20missing%20something%20obvious%3F%20I%20can%E2%80%99t%20find%20any%20documentation%20or%20articles%20that%20offer%20any%20solutions...%3CBR%20%2F%3EThanks%20in%20advance.%3CBR%20%2F%3ENeil%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-678371%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Ebitlocker%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%20Device%20Management%20(MDM)%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-679449%22%20slang%3D%22en-US%22%3ERe%3A%20AutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-679449%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F346060%22%20target%3D%22_blank%22%3E%40neilcarden%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3EWhich%20version%20of%20Windows%2010%20are%20you%20using%2C%20and%20if%20installed%20from%20media%2C%20which%20media%20are%20you%20using%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-679456%22%20slang%3D%22en-US%22%3ERe%3A%20AutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-679456%22%20slang%3D%22en-US%22%3EIt%20varies...%20have%20tried%20Pro%20and%20Enterprise%20both%201803%20and%201809.%20Also%20tried%20a%20Surface%20straight%20out%20of%20the%20box%20and%20OS%20installed%20from%20USB%20media...%20and%20lots%20of%20resets!!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-680045%22%20slang%3D%22en-US%22%3ERe%3A%20AutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-680045%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F346060%22%20target%3D%22_blank%22%3E%40neilcarden%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3ESounds%20strange%20-%20I%20do%20not%20have%20access%20to%20a%20Surface%20Pro%206%2C%20so%20I%20am%20not%20able%20to%20replicate.%20However%20I%20am%20aware%20of%20an%20issue%20with%20the%201809%20RTM%20media%20was%20causing%20the%20disk%20layout%20to%20be%20wrongly%20configured%20causing%20BitLocker%20to%20fail%20encryption%20as%20part%20of%20the%20AAD%20join.%20The%20issue%20is%20fixed%20with%20the%20most%20recent%20Windows%2010%201809%20ISO%20(January%202019).%20Any%20chance%20you%20are%20reusing%20the%20disk%20layout%20from%20a%20Windows%2010%201809%20RTM%20version%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E--Jesper%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-680060%22%20slang%3D%22en-US%22%3ERe%3A%20AutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-680060%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F79091%22%20target%3D%22_blank%22%3E%40Jesper%20Nielsen%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%20I%20will%20try%20and%20find%20out.%20I%20may%20try%20it%20with%201903%2C%20then%20at%20least%20that%20rules%20out%20AutoPilot%2FInTune%20config%20if%20it%20works...%3C%2FP%3E%3CP%3EThanks%20for%20the%20responses%20so%20far.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-695318%22%20slang%3D%22en-US%22%3ERe%3A%20AutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-695318%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20I%20tried%20with%20a%20fresh%201903%20version%20and%20getting%20this%20issue%20in%20event%20viewer%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%22Failed%20to%20automatically%20enable%20device%20encryption.%3C%2FP%3E%3CP%3EError%20message%3A%20Group%20policy%20does%20not%20permit%20the%20use%20of%20TPM-only%20at%20startup.%20Please%20choose%20a%20different%20bitlocker%20option.%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20thing%20is%20its%20not%20set%20to%20TPM-only%2C%20its%20set%20to%20Startup%20PIN%20with%20TPM.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-768160%22%20slang%3D%22en-US%22%3ERe%3A%20AutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-768160%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F346060%22%20target%3D%22_blank%22%3E%40neilcarden%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20having%20this%20exact%20same%20error%20when%20trying%20to%20Autopilot%20with%20a%20standard%20user%20using%20a%20PIN.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20you%20ever%20come%20across%20a%20resolution%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-770421%22%20slang%3D%22en-US%22%3ERe%3A%20AutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-770421%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F380284%22%20target%3D%22_blank%22%3E%40jarrydanderson%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo!%20To%20be%20honest%20I%20have%20been%20busy%20with%20other%20things%2C%20but%20I%20hope%20to%20go%20back%20to%20it...%20Very%20frustrating.%20Do%20you%20get%20an%20error%20in%20the%20event%20logs%20about%20not%20finding%20a%20keyboard%20when%20it%20tries%20to%20encrypt%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-770453%22%20slang%3D%22en-US%22%3ERe%3A%20AutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-770453%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F346060%22%20target%3D%22_blank%22%3E%40neilcarden%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHonestly%2C%20Intune%20has%20been%20an%20absolute%20disaster%20to%20implement.%20Something%20will%20work%20one%20time%20and%20then%20never%20again%20even%20though%20settings%20haven't%20changed.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20don't%20get%20a%20finding%20keyboard%20error%20probably%20because%20I'm%20not%20using%20Surface.%20I%20get%20the%20following%2C%20or%20combinations%20of%20the%20following%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EMDM%20ConfigurationManager%3A%20Command%20failure%20status.%20Configuraton%20Source%20ID%3A%20(6AAEC661-2BD6-4F50-A880-0A4634592183)%2C%20Enrollment%20Type%3A%20(MDMDeviceWithAAD)%2C%20CSP%20Name%3A%20(BitLocker)%2C%20Command%20Type%3A%20(Clear%3A%20first%20phase%20of%20Delete)%2C%20Result%3A%20(.%2FDevice%2FVendor%2FMSFT%2FBitLocker%2FSystemDrivesRequireStartupAuthentication).%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EGroup%20policy%20does%20not%20permit%20the%20use%20of%20TPM-only%20at%20startup.%20Please%20choose%20a%20different%20BitLocker%20startup%20option..%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CUL%3E%3CLI%3EEvent%20ID%20404%3A%3C%2FLI%3E%3CUL%3E%3CLI%3EMDM%20ConfigurationManager%3A%20Command%20failure%20status.%20Configuration%20Source%20ID%3A%20(6AAEC661-2BD6-4F50-A880-0A4634592183)%2C%20Enrollment%20Name%3A%20(MDMDeviceWithAAD)%2C%20Provider%20Name%3A%20(Policy)%2C%20Command%20Type%3A%20(Add%3A%20from%20Replace%20or%20Add)%2C%20CSP%20URI%3A%20(.%2FVendor%2FMSFT%2FPolicy%2FConfig%2FSecurity%2FRequireDeviceEncryption)%2C%20Result%3A%20(The%20operating%20system%20drive%20is%20not%20protected%20by%20BitLocker%20Drive%20Encryption.).%3C%2FLI%3E%3C%2FUL%3E%3CLI%3EEvent%20ID%20809%3A%3C%2FLI%3E%3CUL%3E%3CLI%3E%26nbsp%3BMDM%20PolicyManager%3A%20Set%20policy%20int%2C%20Policy%3A%20(RequireDeviceEncryption)%2C%20Area%3A%20(Security)%2C%20EnrollmentID%20requesting%20set%3A%20(6AAEC661-2BD6-4F50-A880-0A4634592183)%2C%20Current%20User%3A%20(Device)%2C%20Int%3A%20(0x1)%2C%20Enrollment%20Type%3A%20(0x6)%2C%20Scope%3A%20(0x0)%2C%20Result%3A(0x80310020)%20The%20operating%20system%20drive%20is%20not%20protected%20by%20BitLocker%20Drive%20Encryption..%3C%2FLI%3E%3C%2FUL%3E%3CLI%3EEvent%20ID%20820%3A%26nbsp%3B%3C%2FLI%3E%3CUL%3E%3CLI%3EMDM%20PolicyManager%3A%20Set%20policy%20precheck%20precheck%20call.%20Policy%3A%20(Security)%2C%20Area%3A%20(RequireDeviceEncryption)%2C%20int%20value%3A%20(0x1)%20Result%3A(0x80310020)%20The%20operating%20system%20drive%20is%20not%20protected%20by%20BitLocker%20Drive%20Encryption..%3C%2FLI%3E%3C%2FUL%3E%3C%2FUL%3E%3C%2FUL%3E%3CP%3E%3CSPAN%3ECannot%20use%20secure%20boot%20for%20integrity%20because%20the%20uefi%20variable%20pk%20is%20not%20present%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-770481%22%20slang%3D%22en-US%22%3ERe%3A%20AutoPilot%20silent%20encryption%20Surface%20Pro%206%20failing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-770481%22%20slang%3D%22en-US%22%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F380284%22%20target%3D%22_blank%22%3E%40jarrydanderson%3C%2FA%3E%3CBR%20%2F%3EI%20must%20admit%20until%20I%20started%20testing%20AutoPilot%20I%20didnt%20really%20have%20any%20issues.%20Very%20new%20organisation%2C%20no%20on-prem%20infrastructure%20so%20to%20speak%2C%20pure%20AAD%20joined%20devices%20all%20of%20which%20Surface%20Pro%E2%80%99s.%3CBR%20%2F%3Elast%20time%20I%20tested%20it%20I%20added%20a%20PS%20script%20that%20changed%20some%20reg%20entries%20and%20then%20just%20enabled%20the%20BitLocker%20manually%20once%20it%20had%20enrolled.%20We%20set%20up%20devices%20for%20users%20so%20this%20wasn%E2%80%99t%20a%20massive%20problem%20(for%20us)%20just%20very%20annoying%20as%20there%E2%80%99s%20only%20me%20in%20the%20team%20and%20it%20was%20taking%20me%20away%20from%20my%20other%20jobs%20that%20needed%20doing.%20I%20will%20revisit%20though%20as%20I%20do%20need%20to%20setup%20a%20lot%20of%20devices.%3C%2FLINGO-BODY%3E
neilcarden
Occasional Contributor
Hi, has anyone had any joy enrolling Surface Pros with Autopilot enabling bitlocker silently?
I have the enrolment profile as the enrolee as a non-admin and bitlocker encryption allowed by non-admins.
I have ‘allow TPM’ and ‘allow TPM and PIN’ (and have tried various different combinations) configured as we want to use a PIN on boot.
When it goes through the enrol it completes and loads Windows, and bitlocker is off. When I try to enable manually it fails due to group policy issue. The Event viewer says ‘cannot silently encrypt due to the lack of keyboard’. I have tried with keyboard disconnected, connected, external keyboard via Surface docker...
Am I missing something obvious? I can’t find any documentation or articles that offer any solutions...
Thanks in advance.
Neil
9 Replies

Hi @neilcarden,

Which version of Windows 10 are you using, and if installed from media, which media are you using?

It varies... have tried Pro and Enterprise both 1803 and 1809. Also tried a Surface straight out of the box and OS installed from USB media... and lots of resets!!

Hi @neilcarden,

Sounds strange - I do not have access to a Surface Pro 6, so I am not able to replicate. However I am aware of an issue with the 1809 RTM media was causing the disk layout to be wrongly configured causing BitLocker to fail encryption as part of the AAD join. The issue is fixed with the most recent Windows 10 1809 ISO (January 2019). Any chance you are reusing the disk layout from a Windows 10 1809 RTM version?

 

--Jesper

 

@Jesper Nielsen 

Hi, I will try and find out. I may try it with 1903, then at least that rules out AutoPilot/InTune config if it works...

Thanks for the responses so far.

So I tried with a fresh 1903 version and getting this issue in event viewer:

 

"Failed to automatically enable device encryption.

Error message: Group policy does not permit the use of TPM-only at startup. Please choose a different bitlocker option."

 

The thing is its not set to TPM-only, its set to Startup PIN with TPM.

@neilcarden 

 

I'm having this exact same error when trying to Autopilot with a standard user using a PIN. 

 

Did you ever come across a resolution?

@jarrydanderson 

 

No! To be honest I have been busy with other things, but I hope to go back to it... Very frustrating. Do you get an error in the event logs about not finding a keyboard when it tries to encrypt?

@neilcarden 

 

Honestly, Intune has been an absolute disaster to implement. Something will work one time and then never again even though settings haven't changed. 

 

I don't get a finding keyboard error probably because I'm not using Surface. I get the following, or combinations of the following:

 

MDM ConfigurationManager: Command failure status. Configuraton Source ID: (6AAEC661-2BD6-4F50-A880-0A4634592183), Enrollment Type: (MDMDeviceWithAAD), CSP Name: (BitLocker), Command Type: (Clear: first phase of Delete), Result: (./Device/Vendor/MSFT/BitLocker/SystemDrivesRequireStartupAuthentication).

 

Group policy does not permit the use of TPM-only at startup. Please choose a different BitLocker startup option..

 

    • Event ID 404:
      • MDM ConfigurationManager: Command failure status. Configuration Source ID: (6AAEC661-2BD6-4F50-A880-0A4634592183), Enrollment Name: (MDMDeviceWithAAD), Provider Name: (Policy), Command Type: (Add: from Replace or Add), CSP URI: (./Vendor/MSFT/Policy/Config/Security/RequireDeviceEncryption), Result: (The operating system drive is not protected by BitLocker Drive Encryption.).
    • Event ID 809:
      •  MDM PolicyManager: Set policy int, Policy: (RequireDeviceEncryption), Area: (Security), EnrollmentID requesting set: (6AAEC661-2BD6-4F50-A880-0A4634592183), Current User: (Device), Int: (0x1), Enrollment Type: (0x6), Scope: (0x0), Result:(0x80310020) The operating system drive is not protected by BitLocker Drive Encryption..
    • Event ID 820: 
      • MDM PolicyManager: Set policy precheck precheck call. Policy: (Security), Area: (RequireDeviceEncryption), int value: (0x1) Result:(0x80310020) The operating system drive is not protected by BitLocker Drive Encryption..

Cannot use secure boot for integrity because the uefi variable pk is not present

 

 

@jarrydanderson
I must admit until I started testing AutoPilot I didnt really have any issues. Very new organisation, no on-prem infrastructure so to speak, pure AAD joined devices all of which Surface Pro’s.
last time I tested it I added a PS script that changed some reg entries and then just enabled the BitLocker manually once it had enrolled. We set up devices for users so this wasn’t a massive problem (for us) just very annoying as there’s only me in the team and it was taking me away from my other jobs that needed doing. I will revisit though as I do need to setup a lot of devices.
Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
38 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies