SOLVED
Home

Cannot install a new Light Gateway: TaskCanceledException

%3CLINGO-SUB%20id%3D%22lingo-sub-291091%22%20slang%3D%22en-US%22%3ECannot%20install%20a%20new%20Light%20Gateway%3A%20TaskCanceledException%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-291091%22%20slang%3D%22en-US%22%3E%3CP%3EI%20get%20the%20following%20error%20when%20I%20try%20to%20install%20a%20Light%20Gateway%20on%20a%20new%20Domain%20Controller%3A%3C%2FP%3E%3CPRE%3E%5B11B4%3A0ACC%5D%5B2018-11-26T11%3A47%3A17%5Di000%3A%202018-11-26%2011%3A47%3A17.0800%204532%205%20Debug%20%5B%5C%5B%5DDeploymentModel%5B%5C%5D%5D%20%5B%5C%5B%5DDeploymentAction%3DInstall%5B%5C%5D%5D%3CBR%20%2F%3E%5B11B4%3A0ACC%5D%5B2018-11-26T11%3A47%3A17%5Di000%3A%202018-11-26%2011%3A47%3A17.2377%204532%205%20Debug%20%5B%5C%5B%5DDeploymentModel%5B%5C%5D%5D%20%5B%5C%5B%5DIsAfterRestartAndConfigured%3DFalse%5B%5C%5D%5D%3CBR%20%2F%3E%5B11B4%3A0F30%5D%5B2018-11-26T11%3A49%3A02%5Di000%3A%202018-11-26%2011%3A49%3A02.5491%204532%2011%20Error%20%5B%5C%5B%5DTaskAwaiter%5B%5C%5D%5D%20System.Threading.Tasks.TaskCanceledException%3A%20A%20task%20was%20canceled.%3CBR%20%2F%3E%20at%20async%20Microsoft.Tri.Infrastructure.Extensions.HttpClientExtension.GetAsync%5B%5C%5B%5D%5B%5C%5D%5D(%3F)%3CBR%20%2F%3E%20at%20async%20Microsoft.Tri.Common.Management.ManagementClient.%26lt%3B%26gt%3Bc__DisplayClass9_0.%3CGETSTATUSASYNC%3Eb__0(%3F)%3CBR%20%2F%3E%20at%20async%20Microsoft.Tri.Infrastructure.Extensions.HttpClientExtension.RequestAsync%5B%5C%5B%5D%5B%5C%5D%5D(%3F)%3CBR%20%2F%3E%20at%20async%20Microsoft.Tri.Common.Management.ManagementClient.GetStatusAsync(%3F)%3CBR%20%2F%3E%5B11B4%3A0F30%5D%5B2018-11-26T11%3A49%3A02%5Di000%3A%202018-11-26%2011%3A49%3A02.5491%204532%2011%20Error%20%5B%5C%5B%5DDeploymentModel%5B%5C%5D%5D%20Failed%20management%20authentication%20%5B%5C%5B%5DCurrentlyLoggedOnUser%3Dmydomain%5CmyuseridStatus%3DFailed%20Exception%3DSystem.Threading.Tasks.TaskCanceledException%3A%20A%20task%20was%20canceled.%3CBR%20%2F%3E%20at%20System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task%20task)%3CBR%20%2F%3E%20at%20System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task%20task)%3CBR%20%2F%3E%20at%20Microsoft.Tri.Infrastructure.Extensions.HttpClientExtension.%3CGETASYNC%3Ed__0%601.MoveNext()%3CBR%20%2F%3E---%20End%20of%20stack%20trace%20from%20previous%20location%20where%20exception%20was%20thrown%20---%3CBR%20%2F%3E%20at%20System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task%20task)%3CBR%20%2F%3E%20at%20System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task%20task)%3CBR%20%2F%3E%20at%20Microsoft.Tri.Common.Management.ManagementClient.%26lt%3B%26gt%3Bc__DisplayClass9_0.%26lt%3B%3CGETSTATUSASYNC%3Eb__0%26gt%3Bd.MoveNext()%3CBR%20%2F%3E---%20End%20of%20stack%20trace%20from%20previous%20location%20where%20exception%20was%20thrown%20---%3CBR%20%2F%3E%20at%20System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task%20task)%3CBR%20%2F%3E%20at%20System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task%20task)%3CBR%20%2F%3E%20at%20Microsoft.Tri.Infrastructure.Extensions.HttpClientExtension.%3CREQUESTASYNC%3Ed__4%601.MoveNext()%3CBR%20%2F%3E---%20End%20of%20stack%20trace%20from%20previous%20location%20where%20exception%20was%20thrown%20---%3CBR%20%2F%3E%20at%20System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task%20task)%3CBR%20%2F%3E%20at%20System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task%20task)%3CBR%20%2F%3E%20at%20Microsoft.Tri.Common.Management.ManagementClient.%3CGETSTATUSASYNC%3Ed__9.MoveNext()%5B%5C%5D%5D%3CBR%20%2F%3E%5B11B4%3A0ACC%5D%5B2018-11-26T11%3A49%3A02%5Di000%3A%202018-11-26%2011%3A49%3A02.5491%204532%205%20Debug%20%5B%5C%5B%5DGatewayBootstrapperApplication%5B%5C%5D%5D%20Engine.Quit%20%5B%5C%5B%5DdeploymentResultStatus%3D1602%20isRestartRequired%3DFalse%5B%5C%5D%5D%3CBR%20%2F%3E%5B11B4%3A16F4%5D%5B2018-11-26T11%3A49%3A02%5Di500%3A%20Shutting%20down%2C%20exit%20code%3A%200x642%3C%2FGETSTATUSASYNC%3E%3C%2FREQUESTASYNC%3E%3C%2FGETSTATUSASYNC%3E%3C%2FGETASYNC%3E%3C%2FGETSTATUSASYNC%3E%3C%2FPRE%3E%3CP%3EMy%20setup%20is%3A%3C%2FP%3E%3COL%3E%3CLI%3ECenter%20server%20(v%3CSPAN%3E1.9.7312.32791)%26nbsp%3B%3C%2FSPAN%3Econfigured%20using%203rd%20Party%20certificate%3C%2FLI%3E%3CLI%3E2x%20Domain%20Controllers%3C%2FLI%3E%3CLI%3EGroup%20Policy%20containing%20the%203rd%20Party%20certificate%20public%20key%20%2B%20certificate%20chain%2C%20attached%20to%20the%20Domain%20Controllers%3C%2FLI%3E%3C%2FOL%3E%3CP%3EI%20had%202%20Domain%20Controllers%20with%20the%20LGateway%20on%20for%20a%20year%2C%20and%20I've%20recently%20replaced%20one%20of%20the%20DCs%20with%20a%20new%20one.%20On%20the%20new%20one%2C%20I%20can't%20get%20the%20LGateway%20install%20to%20complete%2C%20I%20get%20the%20above%20error.%20They%20are%20both%20in%20the%20standard%20%22Domain%20Controllers%22%20OU%2C%20and%20have%20the%20same%20GPOs%20applied.%20The%20DCs%20have%20persisted%20through%20a%20few%20Center%20upgrades%20a%20few%20months%20ago%20from%20v1.8%20to%20the%20latest%20v1.9.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20reach%20the%20Center%20console%20from%20my%20new%20DC%2C%20and%20I%20can%20see%20all%20the%20config%20and%20timeline%20etc.%20To%20run%20the%20LGateway%20install%2C%20I%20have%20some%20Powershell%20that%20downloads%20it%20straight%20from%20the%20Center%20server%20to%20ensure%20I%20always%20get%20the%20latest%20version%3A%3C%2FP%3E%3CPRE%3E%24dlfile%20%3D%20%22https%3A%2F%2F%24%7Bapp_url%7D%2Fapi%2Fmanagement%2FsoftwareUpdates%2Fgateways%2FdeploymentPackage%22%3CBR%20%2F%3E%24creds%20%3D%20Get-Credential%20-Credential%20%24env%3AUSERNAME%3CBR%20%2F%3E%24wc%20%3D%20New-Object%20System.Net.Webclient%3CBR%20%2F%3E%24wc.Credentials%20%3D%20New-Object%20System.Net.NetworkCredential(%24env%3AUSERNAME%2C%20%24creds.Password)%3CBR%20%2F%3E%24wc.DownloadFile(%24dlfile%2C%24destfile)%3CBR%20%2F%3EUnblock-File%20-Path%20%24destfile%3C%2FPRE%3E%3CP%3EThis%20downloads%20the%20Gateway%20Setup%20zip%20file%20just%20fine%2C%20proving%20connectivity.%20My%20domain%20admin%20user%20ID%20is%20in%20the%20%22Microsoft%20Advanced%20Threat%20Analytics%20Administrators%22%20group%20on%20the%20Center%20server%2C%20and%20this%20is%20the%20same%20ID%20that%20I'm%20logged%20onto%20the%20DC%20with.%20If%20I%20don't%20provide%20credentials%2C%20I%20get%20a%20HTTP%20401%20as%20expected.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20remove%20the%20GPO%20containing%20the%203rd%20Party%20cert%20from%20the%20new%20DC%2C%20I%20get%20the%20%22Failed%20to%20validate%20certificate%22%20error%20in%20the%20install%20log%20(and%20it%20lists%20my%20Center%20cert%20details).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20checked%20the%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fadvanced-threat-analytics%2Ftroubleshooting-ata-known-errors%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3ETroubleshooting%20page%3C%2FA%3E%20and%20that%20indicates%20that%20the%26nbsp%3B%3CSPAN%3EATA%20Lightweight%20Gateway%20could%20not%20successfully%20authenticate%20against%20the%20ATA%20Center%2C%20but%20there's%20no%20advice%20for%20what%20to%20do%20if%20you%20can%20access%20the%20Center%20console%20from%20the%20DC%20you're%20installing%20on.%20My%20existing%20DC%20is%20working%20perfectly%20with%20the%20Center%20server%20and%20is%20listed%20in%20the%20%22Gateways%22%20page%20as%20it%20has%20always%20been.%20I've%20checked%20the%203rd%20Party%20certificate%20installed%20in%20the%20GPO%20and%20the%20thumbprint%2C%20and%20the%20thumbprints%20in%20all%20the%20chain%2C%20match%20between%20the%20Center%20server%2C%20the%20working%20DC%2C%20and%20the%20non-working%20DC.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20wondering%20if%20the%20working%20DC%20has%20some%20remnants%20of%20the%20previous%20Gateway%20config%20installed%20which%20is%20causing%20it%20to%20work%2C%20because%20I%20know%20the%20cert%20requirements%20and%20processes%20have%20changed%20from%20our%20initial%20install%20of%201.7%20last%20year%20to%20the%20current%20install.%20It%20might%20be%20that%20just%20installing%20the%20public%20Center%20cert%20%2B%20chain%20isn't%20enough%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EWhat%20else%20can%20I%20check%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-291091%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdvanced%20Threat%20Analytics%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-291137%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20install%20a%20new%20Light%20Gateway%3A%20TaskCanceledException%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-291137%22%20slang%3D%22en-US%22%3E%3CP%3EYes%2C%20that%20makes%20sense.%20The%20DC%20that%20was%20working%20was%20already%20registered%20months%20before%20when%20the%20proxy%20GPO%20was%20added%2C%20so%20it%20wasn't%20affected.%20It's%20only%20when%20registering%20a%20new%20LGateway%20service%20on%20a%20new%20DC%20that%20we%20would%20see%20the%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20again.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-291126%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20install%20a%20new%20Light%20Gateway%3A%20TaskCanceledException%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-291126%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20makes%20sense.%3C%2FP%3E%0A%3CP%3Ethe%20initial%20registration%20will%20try%20to%20use%20negotiate%20authentication%2C%20using%20proxy%20settings%20from%20the%20current%20user.%3C%2FP%3E%0A%3CP%3EThe%20service%20run%20is%20using%20certificate%20authentication%2C%20and%20proxy%20settings%20from%20local%20service.%3C%2FP%3E%0A%3CP%3Ethe%20policy%20might%20have%20been%20applied%20after%20the%20previous%20GWs%20were%20already%20installed%2C%20so%20it%20did%20not%20break%20them.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-291119%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20install%20a%20new%20Light%20Gateway%3A%20TaskCanceledException%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-291119%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20found%20the%20issue%2C%20although%20it's%20a%20weird%20one.%20We%20have%20a%20GPO%20which%20does%20stuff%20with%20the%20proxy%20settings%2C%20which%20seems%20to%20interfere%20with%20the%20LGateway%20registration%20task.%20The%20GPO%20is%20also%20applied%20to%20the%20other%20DC%2C%20which%20is%20sat%20happily%20connected%20to%20the%20Center%2C%20so%20it%20appears%20that%20our%20settings%20were%20only%20causing%20issues%20for%20the%20Registration%20of%20the%20new%20LGateway%2C%20not%20for%20the%20normal%20Running%20operations.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20suggestions.%20If%20you%20need%20any%20more%20info%20for%20development%20or%20for%20your%20docs%2C%20let%20me%20know%20and%20I%20can%20supply.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-291106%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20install%20a%20new%20Light%20Gateway%3A%20TaskCanceledException%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-291106%22%20slang%3D%22en-US%22%3E%3CP%3Etry%20to%20capture%20a%20netmon%203.4%20trace%20while%20you%20run%20the%20deployment%2C%20and%20look%20in%20the%20trace%20to%20see%20what%20was%20broken%20exactly%20in%20the%20process%2C%20if%20there%20was%20really%20an%20authentication%20issue%2C%20or%20some%20other%20issue%20that%20blocked%20communication.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAlso%2C%20try%20to%20browse%20the%20console%20from%20the%20machine%20using%20Internet%20Explorer%2C%20are%20there%20any%20warnings%20or%20errors%20that%20IE%20displays%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20still%20no%20luck%2C%20contact%20support%20for%20more%20in%20depth%20research.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-291105%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20install%20a%20new%20Light%20Gateway%3A%20TaskCanceledException%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-291105%22%20slang%3D%22en-US%22%3EIt's%20not%20in%20the%20GW%20screen%20in%20the%20Console%20UI%20at%20all.%3CBR%20%2F%3E%3CBR%20%2F%3EThere's%20no%20obvious%20difference%20between%20the%20new%20machine%20and%20the%20working%20one%2C%20they're%20both%20in%20the%20same%20OU%20and%20were%20built%20using%20the%20same%20automation.%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20Center%20is%20domain-joined.%3CBR%20%2F%3E%3CBR%20%2F%3EI'm%20using%20the%20same%20user%20for%20deployment%20as%20the%20one%20I%20authenticate%20with%20on%20this%20machine%20to%20the%20Console%20UI.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-291102%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20install%20a%20new%20Light%20Gateway%3A%20TaskCanceledException%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-291102%22%20slang%3D%22en-US%22%3E%3CP%3EIf%20the%20console%20UI%20already%20lists%20this%20GW%20in%20configuration%2C%20try%20to%20delete%20it%20from%20there%20first.%3C%2FP%3E%0A%3CP%3EIf%20it%20still%20does%20not%20work%2C%20most%20likely%20there%20is%20a%20problem%20with%20with%26nbsp%3Bauthentication%2C%3C%2FP%3E%0A%3CP%3EIs%20there%20anything%20different%20on%20this%20machine%20compared%20to%20the%20other%20machines%20in%20regards%20to%20kerberos%2Fntlm%20policy%3F%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIs%20the%20center%20domain%20joined%3F%3C%2FP%3E%0A%3CP%3EAre%20you%20using%20the%20same%20user%20for%20deployment%20as%20the%20one%20you%20are%20using%20to%20authenticate%20to%20the%20console%20UI%20from%20this%20machine%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
R B
Occasional Contributor

I get the following error when I try to install a Light Gateway on a new Domain Controller:

[11B4:0ACC][2018-11-26T11:47:17]i000: 2018-11-26 11:47:17.0800 4532 5 Debug [\[]DeploymentModel[\]] [\[]DeploymentAction=Install[\]]
[11B4:0ACC][2018-11-26T11:47:17]i000: 2018-11-26 11:47:17.2377 4532 5 Debug [\[]DeploymentModel[\]] [\[]IsAfterRestartAndConfigured=False[\]]
[11B4:0F30][2018-11-26T11:49:02]i000: 2018-11-26 11:49:02.5491 4532 11 Error [\[]TaskAwaiter[\]] System.Threading.Tasks.TaskCanceledException: A task was canceled.
at async Microsoft.Tri.Infrastructure.Extensions.HttpClientExtension.GetAsync[\[][\]](?)
at async Microsoft.Tri.Common.Management.ManagementClient.<>c__DisplayClass9_0.<GetStatusAsync>b__0(?)
at async Microsoft.Tri.Infrastructure.Extensions.HttpClientExtension.RequestAsync[\[][\]](?)
at async Microsoft.Tri.Common.Management.ManagementClient.GetStatusAsync(?)
[11B4:0F30][2018-11-26T11:49:02]i000: 2018-11-26 11:49:02.5491 4532 11 Error [\[]DeploymentModel[\]] Failed management authentication [\[]CurrentlyLoggedOnUser=mydomain\myuseridStatus=Failed Exception=System.Threading.Tasks.TaskCanceledException: A task was canceled.
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Microsoft.Tri.Infrastructure.Extensions.HttpClientExtension.<GetAsync>d__0`1.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Microsoft.Tri.Common.Management.ManagementClient.<>c__DisplayClass9_0.<<GetStatusAsync>b__0>d.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Microsoft.Tri.Infrastructure.Extensions.HttpClientExtension.<RequestAsync>d__4`1.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Microsoft.Tri.Common.Management.ManagementClient.<GetStatusAsync>d__9.MoveNext()[\]]
[11B4:0ACC][2018-11-26T11:49:02]i000: 2018-11-26 11:49:02.5491 4532 5 Debug [\[]GatewayBootstrapperApplication[\]] Engine.Quit [\[]deploymentResultStatus=1602 isRestartRequired=False[\]]
[11B4:16F4][2018-11-26T11:49:02]i500: Shutting down, exit code: 0x642

My setup is:

  1. Center server (v1.9.7312.32791) configured using 3rd Party certificate
  2. 2x Domain Controllers
  3. Group Policy containing the 3rd Party certificate public key + certificate chain, attached to the Domain Controllers

I had 2 Domain Controllers with the LGateway on for a year, and I've recently replaced one of the DCs with a new one. On the new one, I can't get the LGateway install to complete, I get the above error. They are both in the standard "Domain Controllers" OU, and have the same GPOs applied. The DCs have persisted through a few Center upgrades a few months ago from v1.8 to the latest v1.9.

 

I can reach the Center console from my new DC, and I can see all the config and timeline etc. To run the LGateway install, I have some Powershell that downloads it straight from the Center server to ensure I always get the latest version:

$dlfile = "https://${app_url}/api/management/softwareUpdates/gateways/deploymentPackage"
$creds = Get-Credential -Credential $env:USERNAME
$wc = New-Object System.Net.Webclient
$wc.Credentials = New-Object System.Net.NetworkCredential($env:USERNAME, $creds.Password)
$wc.DownloadFile($dlfile,$destfile)
Unblock-File -Path $destfile

This downloads the Gateway Setup zip file just fine, proving connectivity. My domain admin user ID is in the "Microsoft Advanced Threat Analytics Administrators" group on the Center server, and this is the same ID that I'm logged onto the DC with. If I don't provide credentials, I get a HTTP 401 as expected.

 

If I remove the GPO containing the 3rd Party cert from the new DC, I get the "Failed to validate certificate" error in the install log (and it lists my Center cert details).

 

I've checked the Troubleshooting page and that indicates that the ATA Lightweight Gateway could not successfully authenticate against the ATA Center, but there's no advice for what to do if you can access the Center console from the DC you're installing on. My existing DC is working perfectly with the Center server and is listed in the "Gateways" page as it has always been. I've checked the 3rd Party certificate installed in the GPO and the thumbprint, and the thumbprints in all the chain, match between the Center server, the working DC, and the non-working DC.

 

I'm wondering if the working DC has some remnants of the previous Gateway config installed which is causing it to work, because I know the cert requirements and processes have changed from our initial install of 1.7 last year to the current install. It might be that just installing the public Center cert + chain isn't enough?

 

What else can I check?

6 Replies

If the console UI already lists this GW in configuration, try to delete it from there first.

If it still does not work, most likely there is a problem with with authentication,

Is there anything different on this machine compared to the other machines in regards to kerberos/ntlm policy? 

Is the center domain joined?

Are you using the same user for deployment as the one you are using to authenticate to the console UI from this machine?

It's not in the GW screen in the Console UI at all.

There's no obvious difference between the new machine and the working one, they're both in the same OU and were built using the same automation.

The Center is domain-joined.

I'm using the same user for deployment as the one I authenticate with on this machine to the Console UI.

try to capture a netmon 3.4 trace while you run the deployment, and look in the trace to see what was broken exactly in the process, if there was really an authentication issue, or some other issue that blocked communication.

 

Also, try to browse the console from the machine using Internet Explorer, are there any warnings or errors that IE displays?

 

If still no luck, contact support for more in depth research. 

Highlighted

We found the issue, although it's a weird one. We have a GPO which does stuff with the proxy settings, which seems to interfere with the LGateway registration task. The GPO is also applied to the other DC, which is sat happily connected to the Center, so it appears that our settings were only causing issues for the Registration of the new LGateway, not for the normal Running operations.

 

Thanks for the suggestions. If you need any more info for development or for your docs, let me know and I can supply.

Solution

This makes sense.

the initial registration will try to use negotiate authentication, using proxy settings from the current user.

The service run is using certificate authentication, and proxy settings from local service.

the policy might have been applied after the previous GWs were already installed, so it did not break them.

Yes, that makes sense. The DC that was working was already registered months before when the proxy GPO was added, so it wasn't affected. It's only when registering a new LGateway service on a new DC that we would see the issue.

 

Thanks again.

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Extentions Synchronization
ChirmyRam in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies