ATA Sizing Tool "Missing OS Data"

Johann Terc
Occasional Contributor

I ran the ATA Sizing tool against our DCs. Upon viewing the results, in the "Lightweight Gateway Supported" column I see the following message "Missing OS Data" for two of the DCs. We are running a relatively new server OS on our DCs. Any clue what is happening? 

8 Replies

Got this comment from the engineer who developed the tool:

 

Most likely the WMI queries against these DCs are failing.

Did the tool log anything like “ATTENTION: Not all selected DCs can be reached for WMI queries”?

 

The Sizing Tool needs to be able to fetch the OS version of the DC to determine the Lightweight Gateway requirements.

If this is the case, this is typically one of three issues:

  1. WMI service not running on the DC
  2. Firewall blocking WMI on the DC (Firewall WMI-In)
  3. Insufficient Remote WMI permissions.  I assume this isn’t the problem if the other DCs worked (presumably domain admin)

 

In such a case the Sizing Tool typically guides the user to first get the following command to work before running the sizing tool again

Get-WmiObject -Class Win32_Processor -ComputerName DCNAME

Hello Eli thanks for the response. I ran the powershell command (elevated as DA) against my DCs and it failed on some and worked on others. The ones that failed returned the following message:

Get-WmiObject : Invalid query "select * from Win32_Processor"
At line:1 char:1
+ Get-WmiObject -Class Win32_Processor -ComputerName DALAD03
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidArgument: (:) [Get-WmiObject], ManagementException
+ FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

Run the following command locally on DALAD03

Get-WmiObject -Class Win32_Processor

 

If it works, you need to check Firewall settings.

If it doesn’t work, you need to check if the WMI service is running.

Odd things happening...It works but also gives some sort of Quota Violation error message (see below). I verified that the Windows Management Instrumentation service is running on this DC. Then minutes later I ran it again and it didn't even work at all - it then gave me the error message I posted in the post before.  

 

PS C:\Users\da_user3> Get-WmiObject -Class Win32_Processor -ComputerName dalad03


Caption : AMD64 Family 16 Model 9 Stepping 1
DeviceID : CPU0
Manufacturer : AuthenticAMD
MaxClockSpeed : 2200
Name : AMD Opteron(tm) Processor 6174
SocketDesignation : CPU socket #0

Get-WmiObject : Quota violation
At line:1 char:1
+ Get-WmiObject -Class Win32_Processor -ComputerName dalad03
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (:) [Get-WmiObject], ManagementException
+ FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

Oh and I forgot to mention that the Windows Management Instrumentation service is in fact running along with the Windows Remote Management (WS-Management) service is running as well. 

Seen something similar before.

IT means you have a process (or more than 1) that is using WMI queries extensively.

You need to figure out who it is, which WMI provider is causing this.

 

Another option is to increase the quota, but if there is a problem, it might just take more time to fill the quota.

 

Hello again Eli. So is there a tool or something with procmon I need to run on my domain controller to view WMI utilization? 

If I remember correctly, there is a way to tell windows to audit in the event log WMI usage.

This is turned off by default.

Sorry, I don't remember the exact details on how to turn this on.

I suggest opening a support ticket with a platform engineer assigned to the case with WMI expertise who might help trace it.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies