Home

External website set as "StartPage" does not work

%3CLINGO-SUB%20id%3D%22lingo-sub-299002%22%20slang%3D%22en-US%22%3EExternal%20website%20set%20as%20%22StartPage%22%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-299002%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20create%20a%20simple%20(empty%20for%20this%20test)%20msix%20package%20that%20has%20as%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fuwp%2Fschemas%2Fappxpackage%2Fuapmanifestschema%2Felement-application%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Estartpage%3C%2FA%3E%20an%20external%20website%2C%20doesn't%20matter%20which%20one.%20In%20this%20case%20I%20am%20simply%20pointing%20to%20our%20website%2C%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fwww.advancedinstaller.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.advancedinstaller.com%2F%3C%2FA%3E.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20when%20I%20launch%20the%20app%2C%26nbsp%3Bno%20website%20content%20loads.%20I%20would%20expect%20some%20problems%20with%20CSS%20or%20JS%20rendering%2C%20but%20at%20least%20the%20raw%20HTML%20should%20be%20loaded.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20just%20see%20a%26nbsp%3Bblank%20screen%2C%20no%20matter%20if%20the%20package%20is%20built%20with%20Advanced%20Installer%20or%20the%20MSIX%20Packaging%20Tool.%20(%3CEM%3EI%20attached%20a%20test%20package%20built%20with%20Advanced%20Installer%2C%20first%20unzip%20it%2C%20don't%20just%20change%20the%20extension%3C%2FEM%3E).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAre%20we%20doing%20something%20wrong%3F%20Or%20missing%20something%20else%3F%3CBR%20%2F%3E%3CBR%20%2F%3EA%20customer%20sent%20us%20a%20similar%20package%20and%20we%20are%20trying%20to%20figure%20out%20what%20is%20the%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3EWe%20know%20of%20a%20previous%20problem%20where%20local%20HTML%20files%20from%20the%20install%20folder%20of%20the%20msix%2Fappx%20package%20were%20not%20loaded%20because%20of%20their%20encoding%20(if%20I%20remember%20right%20UTF-8%20was%20required%20for%20the%20files%20to%20render%20correctly).%20Is%20this%20the%20same%20problem%20here%3F%20or%20something%20related%20to%20it.%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-324983%22%20slang%3D%22en-US%22%3ERe%3A%20External%20website%20set%20as%20%22StartPage%22%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-324983%22%20slang%3D%22en-US%22%3EHi%20Steve%2C%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%20for%20the%20follow%20up.%3CBR%20%2F%3E%3CBR%20%2F%3EFrom%20what%20I%20can%20see%20it%20is%20a%20separate%20window%20(controlled%20by%20the%20app)%2C%20not%20by%20any%20of%20the%20the%20browsers%20I%20have%20installed%20on%20my%20machine.%3CBR%20%2F%3E%3CBR%20%2F%3EHave%20you%20tried%20the%20package%20I%20attached%20as%20a%20sample%3F%20Does%20it%20work%20for%20you%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-324738%22%20slang%3D%22en-US%22%3ERe%3A%20External%20website%20set%20as%20%22StartPage%22%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-324738%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20the%20app%20runs%20natively%2C%20does%20the%20app%20load%20in%20a%20window%20controlled%20by%20the%20app%20or%20by%20a%20browser%20window.%20If%20it%20is%20a%20browser%20window%2C%20is%20it%20a%20specific%20browser%20window%20(i.e.%20IE)%20or%20is%20whatever%20the%20default%20browser%20is%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Bogdan Mitrache
Contributor

Hi,

 

I've create a simple (empty for this test) msix package that has as startpage an external website, doesn't matter which one. In this case I am simply pointing to our website, https://www.advancedinstaller.com/.

 

However, when I launch the app, no website content loads. I would expect some problems with CSS or JS rendering, but at least the raw HTML should be loaded.

 

We just see a blank screen, no matter if the package is built with Advanced Installer or the MSIX Packaging Tool. (I attached a test package built with Advanced Installer, first unzip it, don't just change the extension).

 

Are we doing something wrong? Or missing something else?

A customer sent us a similar package and we are trying to figure out what is the problem.

 

We know of a previous problem where local HTML files from the install folder of the msix/appx package were not loaded because of their encoding (if I remember right UTF-8 was required for the files to render correctly). Is this the same problem here? or something related to it.

2 Replies

When the app runs natively, does the app load in a window controlled by the app or by a browser window. If it is a browser window, is it a specific browser window (i.e. IE) or is whatever the default browser is?

Hi Steve,

Thanks for the follow up.

From what I can see it is a separate window (controlled by the app), not by any of the the browsers I have installed on my machine.

Have you tried the package I attached as a sample? Does it work for you?
Related Conversations