Home

Factory reset Vision AI Developer kit does not work

%3CLINGO-SUB%20id%3D%22lingo-sub-823930%22%20slang%3D%22en-US%22%3EFactory%20reset%20Vision%20AI%20Developer%20kit%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-823930%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20am%20trying%20to%20do%20factory%20reset%20of%20vision-ai-developer-kit.%20But%20clicking%20twice%20on%20power%20button%20does%20not%20work!%3C%2FP%3E%3CP%3EInitially%20I%20tried%20connecting%20the%20device%20to%20wifi%20and%20I%20am%20trying%20to%20reset%20my%20wifi%20settings%20now.%20The%20camera%20always%20gets%20connected%20to%20wifi%20(green%20led%20lights%20on)%20but%20no%20IoT%20connectivity.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20tried%20%60%3C%2FSPAN%3E%3CA%20href%3D%22http%3A%2F%2Fxx.xx.xx.xx%3A3000%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttp%3A%2F%2FXX.XX.XX.XX%3A3000%60%3C%2FA%3E%3CSPAN%3E%26nbsp%3Bto%20see%20the%20stream%20but%20not%20able%20to%20connect.%20I%20tried%20pinging%20but%20I%20get%20to%20see%26nbsp%3B%3C%2FSPAN%3ERequest%20timed%20out.%3CSPAN%3E%26nbsp%3Bas%20response.%26nbsp%3BAlso%20via%20vls%20player%20with%20rtsp%20(%60rtsp%3A%2F%2FXX.XX.XX.XX%3A8900%2Flive%60)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20with%20adb%20but%20still%20not%20able%20to%20connect%20with%20the%20device%20adb%20connect%20%60XX.XX.XX.XX%3A3000%20%60%20cannot%20connect%20to%20%60XX.XX.XX%3A3000%60%20A%20connection%20attempt%20failed%20because%20the%20connected%20party%20did%20not%20properly%20respond%20after%20a%20period%20of%20time%2C%20or%20established%20connection%20failed%20because%20connected%20host%20has%20failed%20to%20respond.%20(10060)%3C%2FP%3E%3CP%3ECan%20someone%20please%20let%20me%20know%20how%20to%20do%20proceed%20or%20do%20factory%20reset%3F%20Thanks.%3C%2FP%3E%3CP%3EAny%20help%20would%20be%20really%20helpful%20in%20setting%20up%20this%20kit%20quickly.%20Thanks.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%3C%2FP%3E%3CP%3ELavi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-827584%22%20slang%3D%22en-US%22%3ERe%3A%20Factory%20reset%20Vision%20AI%20Developer%20kit%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-827584%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F398825%22%20target%3D%22_blank%22%3E%40Lavi2019%3C%2FA%3E%26nbsp%3BTo%20factory%20reset%20the%20Vision%20AI%20Dev%20Kit%2C%20hold%20the%20button%20on%20the%20back%20of%20the%20device%20down%20for%2012%20seconds%20or%20longer.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-828055%22%20slang%3D%22en-US%22%3ERe%3A%20Factory%20reset%20Vision%20AI%20Developer%20kit%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-828055%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F398825%22%20target%3D%22_blank%22%3E%40Lavi2019%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EYou%20can%20press%20the%20power%20button%20for%205%20seconds%20(give%20or%20take)%20and%20get%20the%20device%20back%20to%20AP%20mode%20meaning%20that%20then%20you%20can%20login%20to%20devices's%20WiFi.%20When%20the%20device%20is%20in%20AP%20mode%20it's%20flashing%20the%20colors.%20It%20opens%26nbsp%3B%3CA%20href%3D%22http%3A%2F%2Fsetupaicamera.ms%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Fsetupaicamera.ms%3C%2FA%3E%26nbsp%3Bpage.%20As%20you%20have%20done%20the%20initial%20setup%20already%20it%20provides%20you%20with%20two%20options%201)%20Reset%20the%20device%20and%20run%20out-of-box%20experience%20again%202)%20just%20reconfigure%20the%20WiFi.%20Note%20that%20there%20is%20a%20known%20issue%20with%20device%20colors%20not%20always%20being%20correct%20when%20resetting%20the%20device%20(%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2Fmicrosoft%2Fvision-ai-developer-kit%2Fissues%2F234%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2Fmicrosoft%2Fvision-ai-developer-kit%2Fissues%2F234%3C%2FA%3E)%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20streaming%20should%20work%20as%20long%20as%20your%20laptop%20is%20connected%20to%20the%20same%20network%20than%20the%20camera%20(I%20have%20seen%20it%20work%20also%20with%20your%20laptop%20still%20being%20connected%20to%20the%20camera).%20In%20case%20it%20doesn't%20you%20can%20start%20troubleshooting%20with%20adb%20and%20first%20check%20that%20the%20streaming%20module%20is%20running%20by%20doing%20%22adb%20shell%20docker%20ps%22.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EHere%20is%20a%20little%20bit%20more%20information%20regarding%20streaming%20with%20media%20player%3A%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fazure.github.io%2FVision-AI-DevKit-Pages%2Fdocs%2FRTSP_stream%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fazure.github.io%2FVision-AI-DevKit-Pages%2Fdocs%2FRTSP_stream%2F%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-857567%22%20slang%3D%22en-US%22%3ERe%3A%20Factory%20reset%20Vision%20AI%20Developer%20kit%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-857567%22%20slang%3D%22en-US%22%3EI%20cannot%20get%20the%20device%20to%20reset%20even%20using%20these%20instructions.%20The%20device%20is%20now%20just%20blinking%20red%2C%20intermittently%2C%20not%20consistently.%20I've%20tried%20to%20factory%20reset%2C%20and%20the%20steps%20above%20and%20cannot%20get%20back%20into%20wifi%20mode%20to%20access%20tools.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-862259%22%20slang%3D%22en-US%22%3ERe%3A%20Factory%20reset%20Vision%20AI%20Developer%20kit%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-862259%22%20slang%3D%22en-US%22%3EHi%2C%20are%20you%20still%20running%20into%20this%20issue%3F%3C%2FLINGO-BODY%3E
Highlighted
Lavi2019
Visitor

Hi,

I am trying to do factory reset of vision-ai-developer-kit. But clicking twice on power button does not work!

Initially I tried connecting the device to wifi and I am trying to reset my wifi settings now. The camera always gets connected to wifi (green led lights on) but no IoT connectivity. 

 

I tried `http://XX.XX.XX.XX:3000` to see the stream but not able to connect. I tried pinging but I get to see Request timed out. as response. Also via vls player with rtsp (`rtsp://XX.XX.XX.XX:8900/live`)

 

I tried with adb but still not able to connect with the device adb connect `XX.XX.XX.XX:3000 ` cannot connect to `XX.XX.XX:3000` A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (10060)

Can someone please let me know how to do proceed or do factory reset? Thanks.

Any help would be really helpful in setting up this kit quickly. Thanks.

 

Regards

Lavi

 

4 Replies

@Lavi2019 To factory reset the Vision AI Dev Kit, hold the button on the back of the device down for 12 seconds or longer. 

@Lavi2019 

 

You can press the power button for 5 seconds (give or take) and get the device back to AP mode meaning that then you can login to devices's WiFi. When the device is in AP mode it's flashing the colors. It opens http://setupaicamera.ms page. As you have done the initial setup already it provides you with two options 1) Reset the device and run out-of-box experience again 2) just reconfigure the WiFi. Note that there is a known issue with device colors not always being correct when resetting the device (https://github.com/microsoft/vision-ai-developer-kit/issues/234)

 

The streaming should work as long as your laptop is connected to the same network than the camera (I have seen it work also with your laptop still being connected to the camera). In case it doesn't you can start troubleshooting with adb and first check that the streaming module is running by doing "adb shell docker ps".

 

Here is a little bit more information regarding streaming with media player:

https://azure.github.io/Vision-AI-DevKit-Pages/docs/RTSP_stream/

I cannot get the device to reset even using these instructions. The device is now just blinking red, intermittently, not consistently. I've tried to factory reset, and the steps above and cannot get back into wifi mode to access tools.
Hi, are you still running into this issue?
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies