Home

Connecting Physical Device to IoT Central

%3CLINGO-SUB%20id%3D%22lingo-sub-717042%22%20slang%3D%22en-US%22%3EConnecting%20Physical%20Device%20to%20IoT%20Central%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-717042%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20am%20trying%20to%20connect%20Raspberry%20Pi%203%20to%20IoT%20Central%20using%20C%20language%2C%20however%20I%20am%20not%20able%20to%20see%20the%20telemetry%20data%20coming%20from%20device%20to%20IoT%20Central.%3C%2FP%3E%3CP%3EI%20then%20tested%20the%20same%20C%20code%20with%20a%20newly%20created%20IoT%20Hub%20and%20connected%20the%20raspberry%20pi.%20The%20IoT%20Hub%20is%20receiving%20the%20telemetry%20information%20successfully.%20So%20it%20means%20that%20the%20C%20code%20is%20working%20fine%20on%20device.%20It's%20just%20that%20my%20device%20is%20not%20able%20to%20send%20messages%20to%20IoT%20Central.%20Please%20note%20that%20I%20am%20using%20the%20correct%20Connection%20String%20in%20the%20C%20code%20to%20connect%20with%20the%20IoT%20Central.%3C%2FP%3E%3CP%3EHas%20anyone%20encountered%20this%20and%20any%20direction%20to%20fix%20it.%3C%2FP%3E%3CP%3ERegards%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-729230%22%20slang%3D%22en-US%22%3ERe%3A%20Connecting%20Physical%20Device%20to%20IoT%20Central%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-729230%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F342249%22%20target%3D%22_blank%22%3E%40Ahmad-KAISPE%3C%2FA%3E%26nbsp%3BBeyond%20the%20app%20itself%20you%20are%20developing%2C%20there%20are%20several%20things%20I%20recommend%20you%20look%20into.%20Networking%20issues%20like%20MQTT%20or%20AMQP%20ports%20being%20closed%2C%20System%20time%20not%20setup%20properly%20(which%20will%20prevent%20TLS%20connection%20establishment)...%3C%2FP%3E%0A%3CP%3ECheckout%20the%20troubleshooting%20guide%20here%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2FAzure%2Fazure-iot-sdk-node%2Fwiki%2FTroubleshooting-Guide-Devices%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2FAzure%2Fazure-iot-sdk-node%2Fwiki%2FTroubleshooting-Guide-Devices%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-741817%22%20slang%3D%22en-US%22%3ERe%3A%20Connecting%20Physical%20Device%20to%20IoT%20Central%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-741817%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Olivier%2C%3C%2FP%3E%3CP%3EThank%20you%20so%20much%20for%20the%20response.%20I%20will%20take%20a%20look%20at%20it%20and%20get%20back%20to%20you.%3C%2FP%3E%3CP%3ERegards%3C%2FP%3E%3C%2FLINGO-BODY%3E
Ahmad-KAISPE
Occasional Contributor

Hi,

I am trying to connect Raspberry Pi 3 to IoT Central using C language, however I am not able to see the telemetry data coming from device to IoT Central.

I then tested the same C code with a newly created IoT Hub and connected the raspberry pi. The IoT Hub is receiving the telemetry information successfully. So it means that the C code is working fine on device. It's just that my device is not able to send messages to IoT Central. Please note that I am using the correct Connection String in the C code to connect with the IoT Central.

Has anyone encountered this and any direction to fix it.

Regards

2 Replies

@Ahmad-KAISPE Beyond the app itself you are developing, there are several things I recommend you look into. Networking issues like MQTT or AMQP ports being closed, System time not setup properly (which will prevent TLS connection establishment)...

Checkout the troubleshooting guide here: https://github.com/Azure/azure-iot-sdk-node/wiki/Troubleshooting-Guide-Devices

 

Hi Olivier,

Thank you so much for the response. I will take a look at it and get back to you.

Regards

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
38 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies