Home

By Scott Duffey | Sr. PM, Intune

In early versions of Windows 10 1903 (builds older than 18362.145), there was a known issue several of you found where online licensed Microsoft Store for Business (MSfB) apps deployed through Intune failed to install. If these apps were named as part of the Enrollment Status Page (ESP) configuration to  “Block device use until these required apps are installed if they are assigned to the user/device” then this might have caused a timeout to the ESP and impacted device setup.

 

The fix for this issue has now shipped. There’s several options now to resolve or workaround this issue, including:

  1. Update all Windows 10 1903 devices with the Windows 10 May update (2019-05 Cumulative Update (KB4497935)) https://www.catalog.update.microsoft.com/Search.aspx?q=KB4497935. This update includes a fix to the StoreInstall CSP where the issue is resolved.
  2. Deploy the offline licensed version of MSfB apps.
  3. Remove online licensed MSfB apps as blocking in the Enrollment Status Page profile.
7 Comments
New Contributor

So lets say we have an autopilot deployment that gets stuck here. 

What is the recovery process? 

 

Will removing the blocking of the ESP allow it to proceed with a reboot?

 

I have a few stations stuck .. 

 

When I get the user (no local admin) to the Settings -> Account - > Work Settings -> Info

 

"Device sync status

Last Attempted Sync:

The sync could not be initiated (0x80190190)

"

 

 

I am going to try a local non-mdm reset (company portal, manually installed doesn't think the device is enrolled)

 

 

Microsoft

@Consult-a null  I believe the best way to fix the stuck machines is to deploy the KB and reboot the machines.

 

 

Microsoft

Some more guidance that might help you in testing the update:

You can download the KB4497935 patch and copy the msu file to the USB. When you get to the Region page in OOBE, press Shift + F10 to open command prompt. Go to the usb and run the msu file. This will install the patch and reboot. Once rebooted it will go back to the region page and you can continue the installation as normal.

Regular Visitor

Hi @Scott Duffey 

We really liked this announcement, but after testing we have to state that this is only true for the "generic" store apps (e.g. Company Portal, OneNote). It is still the case that the deployment process halts with our own LOB store apps in 1903, which we require to deploy in the AutoPilot process as well. Is that already known at Microsoft and are you working on this as well? 

Microsoft

Hi @Thomas Haller Are you saying that you have some online licensed MSFB apps that are still not being delivered after applying the update and that the common theme with the failed apps is that they were developed in-house and submitted to the store via the dev center?

 

Im not aware of any issues with that scenario. As I understand the fix to the CSP, how the app got to the store shouldn’t make any difference.

I’d make sure that the your app can be installed manually on 1903, if that doesn’t work manually then there might be something wrong with the app. If that works but still fails via Intune/Store CSP please raise a support call with us and we can follow up.

 

New Contributor

I had 2 test devices that were running 1903 (Build 18362.30 - clean install from Media Creation Tool).

But Shift + F10 wasn't working, I got the pop-up asking for credentials and after entering, the command prompt just didn't show.

 

What did work for me was "ctrl+shift+esc" -> File -> New Task -> cmd
and then

 

wusa.exe D:\windows10.0-kb4497935-x64_e1e15758afc9d32ca57779428d145cfba3a12e4b.msu

D:\ = location of my USB device

 

 

@Scott DuffeyAny idea when a new build (>= .145) is released to the media creation tool or VLSC? When checking the properties from MediaCreationTool1903.exe under details, the version shows 10.0.18362.1.

So I downloaded the .ISO file again and checked the install.esd (or install.wim) to get the specific build number but it was still the same .30 version.

Isn't there a better way to check the version without downloading the ISO over and over again? 

Same with the Volume Licensing Service Center only shows version number 1903 not build number.

Another option is slipstreaming the msu into Windows but a full download of a Windows 10 1903 build 18362.145 or higher would just be so much easier.

 

Jelle

Microsoft