First published on TechNet on May 15, 2018
Hi Everyone,

In the next month or so, we're going to be releasing some features that will make understanding and troubleshooting Intune App instatllation issues much easier.

The feature will display installation issues per device, and will display an end-to-end history of the app right up to the point of the install failure.

But when we report a failure with a red cross, how do you - the Intune administrator - solve the problem being reported?

To help, I’ve put together a list of common error codes, some info on potential root causes and the next steps in troubleshooting them. All of the error codes are client side errors (ie, iOS/Android/Windows returning an error), so information can sometimes be limited but I’ve done my best to work out common causes and solutions.

I'd love to see this list crowd sourced too though, so please list error codes you've experience and their cause/solution in the comments below.

I hope you find this list helpful!

Matt Shadbolt
Senior Program Manager | Microsoft Intune



0x87D1041C - The application was not detected after installation completed successfully

This error typically occurs when a user uninstalls an app manually after Intune successfully installed the app. It can also be caused by issues with the apps manifest if it’s a LOB app. It can also be caused when an app is self-updating and that update is newer than the one published by the Intune admin. For example, say the Intune admin downloads and deploys a 3rd party app such as Google chrome. After the app is installed on an end user's device, the next time the user runs the app, it detects a newer version from the app store and prompts the user to update the app. If the user accepts and installs the app, the version on the device is newer than the one you published, so you will see this error.

Next Steps: If the issue only occurs on a single device, ask the user to trigger a fresh install via the Company Portal. If the issue occurs on multiple devices for a LOB app, ensure your app manifest has been configured correctly to successfully detect the app install. If the self-updating app is an MSI, you can check the option "ignore app version" with the app configuration and you will not get this error. If the app is not an MSI, just keep the app published up-to-date.


0x800B0101 - A required certificate is not within its validity period when verifying against the current system clock or the timestamp in the signed file

This error may occur if your deploying Line-of-Business (LOB) apps of the Appx type and the client does not have the required certificates installed.
Next Steps: Confirm that all of the required certificates for the Appx package are installed on the client.

0x80073CFF - Deployment of package failed because no valid license or sideloading policy could be applied. A developer license or enterprise sideloading configuration may be required

This error may occur if you’re deploying Line-of-Business (LOB) apps of the Appx type and the app is incorrectly signed. You may get this error if the package is not:


Signed with a Microsoft signature and deployed as a deep link from the Windows Store or Signed with a trusted signature and installed on a computer with a Windows Store developer license with the AllowAllTrustedApps policy enabled or Signed with a trusted signature and installed on a computer with a Windows Sideloading license with the AllowAllTrustedApps policy enabled

Next Steps: Speak with your App Development team and have them check the configuration of the Appx package to ensure it’s licensed/sideloaded correctly.

0x80073CF3 - The package failed update, dependency, or conflict validation

This error may occur if you’re deploying Line-of-Business (LOB) apps of the Appx type. It may be caused by the package already being installed on the target system, a package dependency not being found, or the package does not support the correct processor architecture.

Next Steps: If the error occurs on many devices, speak with your App Development team to check the app dependencies are correct and the architecture requirements have been configured correctly on the app. If the error occurs on a single device, check to see the app hasn’t previously been installed and check the AppXDeployment-Server log on the client for more information.

0x87D15607 - Could not validate app ID

This error directly translates to the iOS MDM error 12023 - The iTunes Store ID of the application could not be validated.

Next Steps: Confirm that the iOS Store deep-link deployment is correct, and the app ID is available in the devices region. Further troubleshooting can be performed by using XCode to gather device logs.

0x87D15630 - License not found

This error directly translates to the iOS MDM error 12064 – License not found. It is most likely due to an error with an Apple VPP deployed app.

Next Steps: Check that the Apple VPP app is configured and deployed correctly. Check that there are sufficient install licenses available, and that the app is available in your organizations Apple VPP portal.

0x80073D06 - The package couldn't be installed because a newer version of this package is already installed

This error may occur if you’re deploying Line-of-Business (LOB) apps of the Appx type and may be caused by a newer version of the Appx package being present on the machine.

Next Steps: If the error occurs on many devices, ensure the newest Appx version is being deployed. If the error occurs on a single machine, check to see what version of the package is already installed and resolve the conflict.

0x87D15609 - App already installed

This error may occur if a user has manually installed a LOB app prior to receiving it via Intune MDM.

Next Steps: Manually remove the duplicate app from the device and allow Intune to re-sync and deploy the app.

0x81030137 - Package is not valid or not applicable for application update

This error may occur if you’re deploying a new version of Line-of-business (LOB) app of the Appx type. The error may be caused by misconfiguration on the package, whereby a version upgrade is unsuccessful.

Next Steps: Speak with your App Development team and have them test app upgrades outside of MDM.

0x87D15631 - Payload issue, check payload

This error may occur if there is a problem with the app source.

Next Steps: If the issue occurs for a single device, attempt re-installation. If the issue occurs for all devices, attempt to re-upload the app to Intune and retest. If the issue continues to occur, speak with your App Development team to troubleshoot the app package.

0x800B0109 - Certificate chain led to untrusted root certificate

This error may occur if you’re deploying Line-of-Business (LOB) apps of the Appx type, and there is an issue with the certificates in the certificate chain used to sign the package.

Next Steps: If the issue only occurs on a single machine, check to see that the certificates are configured correctly and trusted through the entire chain on the local machine. If the issue occurs on all devices, speak with your App Development team and have them check the certificate validity on the package source.

0x80070643 - Fatal error during installation

This generic error is specific to MSI app installations via MDM. It translates to a generic MSI 1603 error and does not contain any further information to help troubleshoot.

1603 errors are common in the packaging community and may be caused by many factors.

Next Steps: Visit this link to understand more about the 1603 error.

0x87D13B7C - Vpp user, device or license not found

This error may occur when deploying VPP apps and there is an issue with license assignment.

Next Steps: Ensure the VPP app your deploying has sufficient licenses available.

0x87D13B64 - The app installation has failed

This error directly translates to the iOS MDM error ManagedAppStatus returned Failed being reported by the device. The error usually means the app has been installed previously and for some reason the iOS MDM agent (controlled by Intune in this instance) cannot take over management of the app.

Next Steps: Remove the app on the device and install it again via Intune.

0x87D13B66 - The app is managed, but has expired or been removed by the user

This error directly translates to the iOS MDM error ManagedButUninstalled being returned by the device. This can potentially be caused by:


  • The app manifest has expired
  • The app is not detected correctly
  • The device is iOS 9.2.2 which contains a platform bug
  • The end user uninstalled the app after successful uninstall before app detection completed

Next Steps: If the issue is happening for many devices for the same app, check with your App Development team to confirm the manifest is correct. If the issue is happening for a single device, ensure the device is up to date and attempt re-install.

0x87D13B60 - The app is scheduled for installation, but needs a redemption code to complete the transaction

This error directly translates to the iOS MDM error ManagedAppStatus returned NeedsRedemption being returned by the device.

This error is generally caused if an end user clicks “cancel” for the install prompt on their iOS device.

Next Steps: Advise the end user to re-install the app, and this time allow the app install to occur.

0x87D13B63 - The user rejected the offer to update the app

This error directly translates to the iOS MDM error ManagedAppStatus returned UserRejected being returned by the device.

This error is generally caused if an end user clicks “cancel” for the install prompt on their iOS device.

Next Steps: Advise the end user to re-install the app, and this time allow the app install to occur.

0x87D1077C - The app license failed to install

The error typically occurs when an Offline Microsoft Store for Business app is attempting installation and the license assignment fails.

Next Steps: If this occurs once off, attempt installation again. If it happens more than once, please raise a support case with Intune support.

0x87D13B7D - VPP unknown error occurred

This error may occur when attempting to deploy VPP apps. It is most likely an error occurring within Intune.

Next Steps: If this occurs once off, attempt installation again. If it happens more than once, please raise a support case with Intune support.

Updated 10/19/2018 - moved 0x87D1041C to the top of the list; that one's the most frequent error. Also added additional example for when that error can be seen.

Occasional Visitor

Hi there,


I had a question, if an app runs into an error during the OOBE enrollment, is there a way to immediately bring up an error on the users computer or stop the set up as soon as an app runs into an issue.


At the moment I see that two apps have run into errors in Intune but on the computer it has just been stuck on the device setup portion of the enrollment for an hour now saying "Apps (1 of 3 installed)" 

I just got a code 0x87D1313D that is not in your list. What does it mean? I got it tying to install a VPP iOS app.


I'm curious what the 0x87D1313D code means to. Same issue here

Occasional Visitor

We are also getting this same error: 0x87D1313D on various failed app installs.

Occasional Visitor

We are also getting 0x87D1313D on random IOS devices.  The only resolution we have found is to wipe the devices to get the apps to install.


Troubleshooted this error with Microsoft support. Our VPP token was expired. After renewing it, the error disappeared and our applications are installing fine now.

Occasional Visitor

We have many 0x87D1313D error as well. Seems there is no official solution or even acknowledgment for it! Would really appreciate if Microsoft can say something about it.Capture - Copy.PNG

Frequent Visitor

I have found something that works for us

Back story: We had another MDM running our VPP and have moved over to Intune, we were half running both at the same time so one of these steps might help anyone.

First thing I did was revoke all VPP licenses under the 'Client apps - iOS VPP tokens' tab, (This wont be needed if you didn't have another MDM running your VPP)

Thinking that the old MDM had reserved some of the licenses or that there was a license association linked to the failing ipads/itunes account.

I really should have done that step when we removed our old MDM.

That seemed to kick in a few of the failed apps on the iPads after a sync or 2.

We've then found a few more failing apps and using the 'Revoke Licenses' button in the individual ipads and some syncing (leaving it for about 30 minutes helped too) the apps kicked in.

I can't say this is a true fix or a work around it just seemed to work for us on the 5 ipads I've done it to.




Frequent Visitor

Same issue and error here across multiple apps - all VPP.


We're in the midst of piloting Intune as a replacement for another MDM, and this issue and it's lack of remediation steps has basically stopped all progress on migration.


We only have 4 users on the platform, and all of them have received the 0x87D1313D error for different VPP apps. The nutty part is that sometimes some apps install without issue, other times the same app for a different user in the same profiles\policies gets the error. Occasionally the user attempts to install later and it works, sometimes not. This affects apps assigned as required and "available with device enrollment".  I have a case open, however the engineer assigned doesn't appear to know what is going on either...


I tried the license revocation steps above (revoked by user and by app) - resync'd, and retried to install, but did not work for me. I'll keep trying.

Occasional Visitor

Another one that's not in the list - curious to hear what it's all about :


0x87D30065 - Failed to retrieve content information.

Regular Visitor

I have another one not in the list: 0x87D1041E


Any input on what this might be?  We are stumped!

New Contributor

I am also receiving 0x87D1041E for a very basic O365 package deployment via Intune.  This is clearly an Intune error (0x87D...) but I'm just not able to determine what the root cause is.  Looking for guidance.

Occasional Visitor

I am also getting 0x87D1041E. The package I am trying to install is Office 365 Suite x64 (windows 10) with all applications included, except OneDrive (groove), Teams, Project and Visio. Update channel is set to monthly (latest). 

Occasional Contributor

Same error 0x87D1041E here. We have a installer for O365 ProPlus that installs correctly. We have 2 sepparate installers for Project and Visio that crash with this specific error.

New Contributor

It may be related to the Project/Visio or having multiple O365 deployments targeting the same user/device.  At least that's what I've gathered thus far.  I, too, have O365, O365+Visio, O365+Project, and O365+Visio+Project packages.  I've tried with XML as well, but same issue.

Occasional Contributor

Took a look at it today again... Still having the issue of error 0x87D1041E. Tried several options to get Visio and Project installed. None of which worked. When I use Intunes build in options (by using XML or by selecting the apps) both ways reply with error 0x87D1041E.


When I use the XML to download the source and install it as a Win32 application I get another error in return: 0x8007426A


I cannot find anything on that last error. The most stupid thing is.... that Win32 installer worked perfectly. Not exactly a clue when it broke but I think that has to be arround the time of the latest intune build or when the new Click to Run installer in Intune was introduced.....


During the time it worked I wrote a small blogpost about it and there are the XML's I used: http://www.robderoos.com/itpro/intune/intune-installing-visio-or-project-seperatly/


I realy don't get it what is wrong..... I will open a call with Microsoft on this matter.

Regular Visitor

We also see the 0x87D1313D on several iPads. Tried to push an application to 288 ipads have 294 VPP lisences, but it still fails to install on about 50 ipads. Any idea what these errocode mean?

Frequent Visitor
Also receiving the same error 0x87D1041E. XML and basic install, all installs. Would appreciate any assistance.

It seems like we have resolved our 0x87D1313D issue by renewing the Apple VPP token (Intune App Protection > iOS VPP tokens > Check status of token). We were not able to deploy apps to new users anymore, with the error message stated above. 


After renewing the token, the error message seems to be gone and apps are installing again. 

Occasional Contributor

Also facing same issue with 0x87D1041E, only try to add visio and project.

Senior Member

Same here, please let me know if someone found a solution.


Trying to deploy only visio to windows machines already having office proplus apps installed.


Thank you

Occasional Contributor

Microsoft took the logging of our tenant and client to troubleshoot the issue. Last Tuesday they told me the call is now under the attention of a senior engineer. Will keep you posted on any updates regarding the 0x87D1041E error issue.

Occasional Visitor

We are getting the code 0x80077562 when trying to push out Office 365 - nothing appears when searching this code.

Office 2016 MSI is currently installed on the machine, however we have the option ticket for Office 365 to remove any currently installed MSI versions of Office.

Occasional Contributor

Just had a call with Microsoft. Somehow the issue with the Win32 application Project, which was throwing an error 0x87D1041E, is solved. The Win32 app Visio however now throws a different error. That one now tells us "Error unzipping downloaded content. (0x87D30067)". The issue with that looks like to be a rights issue. It seems the unzip process wants to start with user credentials. That is still under investigation.


Same seems to be the case for the project installation where we use the build in option and use the XML to install it. That also seems to install fine now. However Visio in that same context is still throwing the same error  0x87D1041E as before.


Investigating further.

Occasional Visitor

Same issue 0x87D1041E. Would be great to see a fix.

Occasional Visitor

We have some better error messages in the works for Office install failures, but I can explain 0x87D1041E. 
0x87D1041E means that there was a conflict between 2 different "instances" of Office, and the one that is showing 0x87D1041E is the loser. We do conflict resolution between different Office installs, so there can be only 1. 
Typically you'll see this if you have one instance of Office assigned as required, and then try and assign a different instance as optional. Most often I've seen this when the required version is "full" Office (ie Word, Excel, PPT, Outlook etc) and the optional instance is just Visio/Project. 

Occasional Contributor

Well I have the issue with an Full office (without Visio and Project). We would like to be able to deploy Visio and Project separatly and that worked until February this year. After that we received errors. Sometimes Visio gets installed, sometimes Project gets installed but never the two together.


Before February this was working using the office deployment tool and a Win32 application but that isn't working anymore.


Is there any possibility to roll out project and visio separatly? (also where visio and project land on the same device). I would love to see more documentation/insight on this.


Support call is still open. No solution yet.

Frequent Visitor

Hi Rob,

I haev the same issue and also opend a case with MS.

Not very helpfull for this case, and it takes time...

Case is open for more than a week now... and friday they've escalated this (they said) but no answers yet...

Will keep everyone updated when I hear anything...

Occasional Visitor

Also having 0x87d30065 error - can anyone shed light on what this is?

Frequent Visitor


MS wants to close the case as when you install all in one package (and first uninstall the office on the device) it works...

But I don't want to close it yet... As it used to work separately (as I can see here in this thread) and I also want it seperatly...

We don't want to go on every device and uninstall office first...

But if some of you can live with that... just make one package with all applications in it and see that there is no office installed on the device yet...

Senior Member



In several occasions I received this error - "The unmonitored process is in progress, however it may timeout (0x87D300C9)".


I tried to find what this could mean, but not a single clue.


Does anyone have had something similar or know anything about it?

New Contributor

Issues I had with 0x87D1041E when deploying office to systems were related to multiple deployments targeting the user and device.  I had device targeted with required, but when user tried to use available app, it puked out 0x87D1041E.  It wasn't consistent, but once I removed all deployments and tried one at a time to the device, things worked as expected.

Occasional Contributor

@nick aquino so just to be clear.... if you publish the applications as required you get the error. But if you set the applications to be available, installation works as expected?