Home

Get-help doesn't work for Exchange Online cmdlets

%3CLINGO-SUB%20id%3D%22lingo-sub-660497%22%20slang%3D%22en-US%22%3EGet-help%20doesn't%20work%20for%20Exchange%20Online%20cmdlets%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-660497%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20all.%20I%20have%20a%20problem%20with%20get-help%20any%20Exchange%20cmdlet%20in%20powershell.%20This%20happens%20both%20when%20connecting%20to%20Exchange%20Online%20using%20basic%20authentication%20(%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fexchange%2Fexchange-online%2Fconnect-to-exchange-online-powershell%2Fconnect-to-exchange-online-powershell%3Fview%3Dexchange-ps%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fexchange%2Fexchange-online%2Fconnect-to-exchange-online-powershell%2Fconnect-to-exchange-online-powershell%3Fview%3Dexchange-ps%3C%2FA%3E)%20and%20the%20Exchange%20Online%20Powershell%20Module%20(%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fexchange%2Fexchange-online%2Fconnect-to-exchange-online-powershell%2Fmfa-connect-to-exchange-online-powershell%3Fview%3Dexchange-ps%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fexchange%2Fexchange-online%2Fconnect-to-exchange-online-powershell%2Fmfa-connect-to-exchange-online-powershell%3Fview%3Dexchange-ps%3C%2FA%3E).%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20been%20in%20touch%20with%20MS%20Support%20who%20says%20that%20this%20is%20by%20design%20for%20the%20Exchange%20Online%20Powershell%20Module.%20That%20sounds%20very%20strange%20to%20me%20as%20get-help%20is%20massively%20useful%2C%20especially%20for%20a%20powershell%20newbie.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3ESystem%20variables%20path%20for%20Powershell%20is%20in%20place%3A%3CBR%20%2F%3E%25SystemRoot%25%5Csystem32%5CWindowsPowerShell%5Cv1.0%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3ESame%20with%20PSmodulepath%3A%3CBR%20%2F%3E%25ProgramFiles%25%5CWindowsPowerShell%5CModules%3CBR%20%2F%3E%25SystemRoot%25%5Csystem32%5CWindowsPowerShell%5Cv1.0%5CModules%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EI%20get%20this%20error%20message%20when%20using%20get-help%20for%20any%20Exchange%20cmdlet.%20All%20other%20cmdlets%20are%20fine.%3CBR%20%2F%3E%3CBR%20%2F%3Eget-help%20%3A%20Exception%20calling%20%22Invoke%22%20with%20%220%22%20argument(s)%3A%20%22Cannot%20find%20path%20''%20because%20it%20does%20not%20exist.%22%20At%20line%3A1%20char%3A1%20%2B%20get-help%20Set-MailboxFolderPermission%20%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%20%2B%20CategoryInfo%20%3A%20NotSpecified%3A%20(%3A)%20%5BGet-Help%5D%2C%20MethodInvocationException%20%2B%20FullyQualifiedErrorId%20%3A%20CmdletInvocationException%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20experienced%20anything%20similar%3F%20Suggestions%20how%20to%20fix%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-660497%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-661257%22%20slang%3D%22en-US%22%3ERe%3A%20Get-help%20doesn't%20work%20for%20Exchange%20Online%20cmdlets%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-661257%22%20slang%3D%22en-US%22%3E%3CP%3EIt's%20most%20certainly%20not%20by%20design%2C%20but%20it%20doesn't%20look%20like%20it's%20getting%20fixed%20either.%20I've%20reported%20it%20maybe%20an%20year%20ago%2C%20several%20times%20after%20that%2C%20no%20progress%20at%20all.%20I%20guess%20it's%20time%20to%20pester%20them%20again%20%3A)%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-664516%22%20slang%3D%22en-US%22%3ERe%3A%20Get-help%20doesn't%20work%20for%20Exchange%20Online%20cmdlets%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-664516%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%3A%20Please%20pester%20%3B-)%26nbsp%3B%20I've%20escalated%20the%20support%20incident%2C%20but%20if%20this%20error%20started%20a%20year%20ago%20I%20won't%20hold%20my%20breath.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-665132%22%20slang%3D%22en-US%22%3ERe%3A%20Get-help%20doesn't%20work%20for%20Exchange%20Online%20cmdlets%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-665132%22%20slang%3D%22en-US%22%3E%3CP%3EWell%20they%20did%20fix%20a%20similar%20issue%20in%20other%20parts%20of%20the%20service%2C%20but%20it%20seems%20like%20it's%20taking%20a%20loooong%20time%20for%20the%20fix%20to%20get%20to%20the%20Exchange%20folks.%20Anyway%2C%20they%20are%20looking%20into%20it%20now.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
TrondM
New Contributor

Hello all. I have a problem with get-help any Exchange cmdlet in powershell. This happens both when connecting to Exchange Online using basic authentication (https://docs.microsoft.com/en-us/powershell/exchange/exchange-online/connect-to-exchange-online-powe...) and the Exchange Online Powershell Module (https://docs.microsoft.com/en-us/powershell/exchange/exchange-online/connect-to-exchange-online-powe...).

I've been in touch with MS Support who says that this is by design for the Exchange Online Powershell Module. That sounds very strange to me as get-help is massively useful, especially for a powershell newbie.

System variables path for Powershell is in place:
%SystemRoot%\system32\WindowsPowerShell\v1.0

Same with PSmodulepath:
%ProgramFiles%\WindowsPowerShell\Modules
%SystemRoot%\system32\WindowsPowerShell\v1.0\Modules


I get this error message when using get-help for any Exchange cmdlet. All other cmdlets are fine.

get-help : Exception calling "Invoke" with "0" argument(s): "Cannot find path '' because it does not exist." At line:1 char:1 + get-help Set-MailboxFolderPermission + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Get-Help], MethodInvocationException + FullyQualifiedErrorId : CmdletInvocationException

 

Anyone experienced anything similar? Suggestions how to fix?

3 Replies

It's most certainly not by design, but it doesn't look like it's getting fixed either. I've reported it maybe an year ago, several times after that, no progress at all. I guess it's time to pester them again :)

@Vasil Michev: Please pester ;-)  I've escalated the support incident, but if this error started a year ago I won't hold my breath.

Well they did fix a similar issue in other parts of the service, but it seems like it's taking a loooong time for the fix to get to the Exchange folks. Anyway, they are looking into it now.

Related Conversations
Power Query Source from Relative Paths
Magnus Vegem Dahle in Excel on
10 Replies
Teams and Power Query Excel file
Mark_Adams in Microsoft Teams on
6 Replies
Reading .csv stored in Azure Blob Storage from Excel
Federico Fontana in Excel on
1 Replies
MS Teams for Virtual classroom
Tanya Arora in Driving Adoption on
9 Replies
Skype for Business to Teams Adoption Strategy
Tanya Arora in Driving Adoption on
3 Replies