Home

The Exchange team is announcing the availability of the following updates:

Exchange Server 2010 Service Pack 3 Update Rollup 5 resolves customer reported issues and includes previously released security bulletins for Exchange Server 2010 Service Pack 3. A complete list of the issues resolved in this rollup is available in KB2917508.

Exchange Server 2007 Service Pack 3 Update Rollup 13 provides recent DST changes and adds the ability to publish a 2007 Edge Server from Exchange Server 2013. Update Rollup 13 also contains all previously released security bulletins and fixes and updates for Exchange Server 2007 Service Pack 3. More information on this rollup is available in KB2917522.

Neither release is classified as a security release but customers are encouraged to deploy these updates to their environment once proper validation has been completed.

Note: KB articles may not be fully available at the time of publishing of this post.

The Exchange Team

66 Comments
Not applicable
I applied RU5 to my Exchange 2010 SP3 system on Saturday. I had no issues with the actual installation.

Yesterday, some of my more savvy users reported that the advanced search feature in Outlook 2010 no longer worked properly. An ordinary search for “Smith, Joe” works fine, but of course brings back every message referencing “Joe Smith” including those where the name is in the body of the message. However, when an advanced search for FROM:Smith is performed, the results stop on Friday, the day before I applied the update. Nothing received after that appears in the advanced results, only in the basic results.

Is anyone else seeing this? Any ideas on how to fix it? I only updated one of my database servers, so my temporary solution was to move all the databases to a different database server (at RU4) and now the search works. The two database servers are identical in every way, including installed Microsoft updates, except for RU5.

Thanks for any help.
Not applicable
It would have been nice if the Internet Explorer 11 compatibility fix could have been included in the Exchange 2007 update. I know Exchange 2007 is now beyond mainstream support, but since non-security updates are clearly still being released, something that would improve usability on systems running IE11 would have been appreciated by those of us still stuck on 2007 with client systems running the new browser.

Since users can only add entire domains to Compatibility View via the IE GUI, it also affects some of our other web-based apps, which break since they aren't designed to work with the old version of IE that is emulated. Adding the specific OWA sub-domain via group policy is not an option in our environment, nor is documenting the local group policy setting and expecting end-users to be able to do that on their own.

I would ask that Microsoft reconsider this since Exchange 2010 and 2013 were supplied with a server-side fix and 2007 will realistically be in use in many places for years to come.
Not applicable
Thank you for your input, Jason. We often seem to be "lucky" this way. I am going to look into various possibilities. It was just very coincidental - applied the update and advanced search stopped working right.

I did some more testing here and I see that we do get results in advanced search - but no results after the update. Any results are messages received before the update. So if "Smith, Joe" sent me two messages, one on Friday the 28th before the update, and one on Saturday March 1 after the update, if I search on FROM:SMITH advanced search only displays the one from Friday. A regular search gives both.

If anyone has any thoughts on how I might fix this, I am open to suggestions. Thanks, Dulce (pcpix)
Not applicable
Hi yes i agree to what #cdugger13 said, its same issue we are facing, Please fix this ASAP, we have number of users facing this issue. Auto-mapped Mailboxes are not working since we updated to rollup 5, Error is, "The set of folders cannot be opened. The attempt to log on to Microsoft Exchange has failed." in outlook client when user tries to access that auto-mapped mailbox.
Not applicable
We're also having the issue for Outlook 2013 Version:15.0.4605.1003
Not applicable
@Malcom - Yes it is supported. See the system requirements for WMF4.0 - http://www.microsoft.com/en-us/download/details.aspx?id=40855.
Not applicable
We will be updating from SP2UR4v2 to SP3UR5 mid-April. Does Microsoft maintain a public list of known issues which are either 1) previously reported and not yet fixed after SP3UR5 and/or 2) new bugs in the SP3UR5? The only known new issue I can find on SP3UR5 is the category view. If there are such lists, where can I view them?
Not applicable
@JB-RI - fixed, thank you!
Not applicable
How about the categories view bugfix? UR5 didnt seem to cover this one. Is this in the works? Thanks

Folder views are not updated when you arrange by categories in Outlook after you apply Exchange Server 2010 Service Pack 3 Update Rollup 3 or Update Rollup 4
http://support.microsoft.com/kb/2925273
Not applicable
@Frank, trust me... you would know you had an IU if you had one. :) An Interim Update is a 'mini' update provided directly to a specific customer for a specific critical issue they may be experiencing if the fix is not yet publically available yet will be in the next public update. You can leave RU4 installed and install RU5 right over it.
Not applicable
@fr, in my lab Exchange 2010 SP3 RU5 is not requiring IE11 compatibility mode to show the Automatic Reply configuration area. I made sure the "use compatibility mode for intranet sites" setting was disabled in IE11 before testing.
Not applicable
Hi, we also have this problem of not opening a shared mailbox in outlook 2007 sp3. So it seems that this problem is more wide spread.
Not applicable
Released: Update Rollup 5 for Exchange 2010 Service Pack 3 and Update Rollup 13 for Exchange 2007 Service Pack 3
thank you
Not applicable
Caution if you still have clients running Outlook 2010RTM or SP1!!!

Has anyone else experienced an issue with Outlook 2010RTM/SP1 and Auto-mapped mailboxes after updating to Update Rollup5? Exact Error is "The set of folders cannot be opened. The attempt to log on to Microsoft Exchange has failed."

Users can no longer open any mailbox that is auto-mapped when using a client version Outlook 2010RTM or SP1. Using Outlook 2007/2013 functions OK. If you have the end-user manually add the mailbox to Open additional mailboxes it will show twice within Outlook, one will open and one will not work.

When I pulled UR5 off the CAS the clients functioned normally again. Opened case with M$ and found there is a compatibility issue with Outlook 2010RTM/SP1 and Update Rollup 5 and the problem was resolved by updating the Outlook 2010 client to SP2.
Not applicable
@cdugger13:
Same problem at Outlook 14.0.7116.5000 (32-bit)
So Outlook 2010 SP2
Not applicable
Any news about Exchange Server 2010 SP4?
Not applicable
Not sure what happened, but I was able to fix the issue with advanced search by running the "ResetSearchIndex.ps1" script on all 34 of my databases. Not ideal, but not the end of the world either. -- Dulce
Not applicable
@John DArcy -- We run Outlook in cached mode; however, we have disabled caching of shared mailbox folders (http://support.microsoft.com/kb/982697). Do you know if the Category View issue will affect the shared mailboxes folders since they are not cached, even though the rest of the mailbox is? We have quite a few users that have these shared mailboxes automapped...

@Brent Alinger [MSFT] -- Can you provide any clarification on the question above.
Not applicable
@ Anonymous - thank you, we are aware that articles are still in the process of settling in the publishing system. Should be resolved soon.
Not applicable
Hello.
Does the RU5 for E2010 SP3 apply on Windows Server 2008 SP2 (not R2)?
The download page http://www.microsoft.com/en-us/download/details.aspx?id=42001 does not mention it within the Supported Operating System. I guess this is just a miswriting.

If not, which policy should be annouced to the customers having no plan to upgrade soon the OS of their Exchange server at the moment:
-stick to RU4?
-which support?

Thanx.
Not applicable
@Rowbby, please check out the update made to the supportability matrix today. If you don't yet see the 2012 R2 line then the content delivery network may still be replicating the change. Exchange 2010 SP3 RU5 or later will be supported with 2012 R2 DCs as well as the 2012 R2 DFL/FFL. http://technet.microsoft.com/en-us/library/ff728623(v=exchg.150).aspx
Not applicable
I appreciate CDugger13's post above. That allowed us to pre-emptively collect the list of users who had access to other mailboxes, cross-reference it to their Outlook 2010 build, and deploy Outlook 2010 SP2 as-needed prior to our SP3 UR5 deployment. No issues reported by those users. I'm personally using Outlook 2013 15.0.4569.1503 and I can still access the same three shared mailboxes I had prior to the SP3 UR5 upgrade.
Not applicable
@Rowbby, you're welcome. I'm personally unaware of any plans for additional changes in that area.
Not applicable
@Siddique - the needful has been done. Note that we know that articles are not showing up for some, working on that.
Not applicable
KB2917508 appears blank when trying to be viewed. Please fix.
Not applicable
Both the links point to the 2007 patch
Not applicable
Great stuff! We're pleased that we can start deploying 2012 R2 Domain controllers in production and then commence our Exchange 2010 -> 2013 migration. Did you find any incompatibilities with 2012 R2 DCs and previous Exchange 2010 updates? I know of at least two companies with this unsupported setup.
Not applicable
Link for Update Rollup 5 for Exchange Server 2010 Service Pack 3 opens up download link of Update Rollup 8 for Exchange Server 2010 Service Pack 2. Please do the needful.
Not applicable
Is the Chile DST change included in 2010 patch or did this miss the window?
Not applicable
The KB article states: Important Remove all interim updates for Exchange Server 2010 SP3 before you apply this update rollup.

What is considered an interim update? Does that mean uninstall RU4 first?
Not applicable
Does UR5 include a fix for IE11 still requiring compatibility view on certain settings pages in OWA such as Automatic Replies?
Not applicable
Will there be an update for Exchange 2010 to support deployments on Windows Server 2012 R2 DCs? Can understand Exchange 2013 compatibility was the higher priority, but as it's still in mainstream support would be good to know if Exchange 2010/Server 2012 R2 is coming or is a firm no.
Not applicable
@Brian: Thanks for the reply. In the supportability matrix for "supported operating system platforms", the only X for Window Server 2012 R2 is Exchange 2013 SP1. I'm interested in Exchange 2010 installations on Server 2012 R2, not just coexistence. The matrix (unless I'm seeing the old one) seems to indicate that combination is still not a possibility. Just wondering if that's final (i.e. support will not come in the future). Thanks!
Not applicable
@Brian: Ok, so officially Exchange 2010 installations on Server 2012 R2 are not and will be never supported? Just looking to get some final clarity as I'll move ahead with Exchange 2013 if it's decided that Exchange 2010 will never be supported on 2012 R2. Thanks again!
Not applicable
@Rowbby - We have no plans to support Windows Server 2012 R2 as the OS used for Exchange Server 2007 or 2010 deployments.
Not applicable
Just installed RU5 in my 2010 SP3 test env. Confirmed that IE11 looks good now. Doesn't require compatibility mode for setting out of office replies. I don't use the test environment for anything much. Our prod env is still on 2010 SP2 RU5v2.
Not applicable
@Brian & @Jason thanks for confirming
Not applicable
While the supportability matrix for Exchange 2010 SP3 UR5 shows that Powershell 4.0 is now supported, there is no other document, including KB2917508, which details it as a new available option. Can we get details on its support and inclusion? As much as I like Powershell, this minor tidbit did not escape me, but I'd really like confirmation that it's not a typo - one tiny checkbox in a supportability matrix is the only place it is mentioned, and not in the KB. Thank you!
Not applicable
when we can expect These UR on WSUS ?
As well will be WMF 4 be released on WSUS later on now ?
Not applicable
I second John DArcy's question. I haven't installed RU 3 or later because of this (and other) issues. It looks like most of the others have been finally ironed out, but this one would generate too many trouble calls.
Not applicable
@John Darcy - We are still working on a fix for the issue identified in KB2925273.

@127 - RU5 will be available via Microsoft Update on March 11th.
Not applicable
We are still waiting for a fix for this really annoying EAS sync bug:
KB2563324
Issue 1.9 - An appointment does not update when you use Outlook in cached mode and room mailbox is an attendee

Please promote [REG:113111310943037] Callback:IPhone Calendar Sync Problem with Outlook

Any news?



Not applicable
Anyone have 2010 SP3 RU5 in production env yet? Any major issues, concerns, etc?
Not applicable
@127 - The Microsoft Update release date has been pushed to 3/22 due to a schedule change.
Not applicable
"Setup Wizard for Update Rollup 5 for Exchange Server 2010 Service Pack 3 (KB2917508) ended prematurely" any ideas?
Not applicable
This may or may not be related to Exchange 2010 SP3 update Rollup 5 - I deployed it on Saturday. No installation problems on Exchange, but now some of my more savvy users are reporting that the advanced search function in Outlook no longer works. In other words, a basic search for mail from Smith, Joe will bring up any mail related to Joe Smith including mail where he is mentioned in the body of the message, etc. An advanced search using the From:Smith function only brings up mail dating back before the update. We are using Outlook 2010.

Is anyone else seeing this? I need to do more research to see if it is related, but it is very coincidental. Any ideas on the best way to fix it?

Thank you!
Not applicable
PCPIX, I'm not seeing that same issue in my 2010 SP3 RU5 test env. I'm using a 2010 Outlook client as well. Normal search works fine. Search Tools > Advanced Find and searching anything returns the results. Tried testing search words in the subject field, FROM:, etc. All seem to be OK.
Not applicable
PCPIX, I sent another email to my test env. and was still able to see it via advanced search (so it was sent after the upgrade). I also tried Outlook in cached and non-cached mode. Still works. Our test env is pretty simple and no where near as complicated as our prod env.
Not applicable
PCPIX: You may want to look at rebuilding your search index to see if that fixes the issue. I'd just perform it on one of your databases and if you see it is resolved, proceed to the rest.
Not applicable
Well I have been unable to get this update to install yet in my environment. Checking the log it indicates a 1023 error with an additional code of 1603. I have searched on this but so far any mentioned fixes have yet to work. I additionally consulted the LOG file and it seems to indicate I need to uninstall an interim update (we currently have Ex 2010 SP3 Rollup 4). Does anybody this I should try uninstalled a previous rollup to get a new rollup to apply?