Home
%3CLINGO-SUB%20id%3D%22lingo-sub-609061%22%20slang%3D%22en-US%22%3EReleased%3A%20February%202019%20Quarterly%20Exchange%20Updates%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-609061%22%20slang%3D%22en-US%22%3E%3CP%3EToday%20we%20are%20announcing%20the%20availability%20of%20quarterly%20servicing%20updates%2C%20cumulative%20and%20update%20rollups%2C%20for%20all%20supported%20versions%20of%20Exchange%20Server.%20Exchange%20Server%202010%2C%202013%2C%202016%20and%202019%20all%20receive%20an%20update%20package.%20These%20updates%20include%20important%20fixes%20to%20address%20vulnerabilities%20being%20discussed%20in%20blogs%20and%20other%20social%20media%20outlets.%20While%20it%20is%20not%20the%20normal%20or%20preferred%20practice%20to%20release%20security%20updates%20in%20a%20cumulative%20update%20package%2C%20the%20nature%20of%20the%20product%20changes%20dictate%20that%20they%20be%20delivered%20this%20way%20as%20they%20include%20changes%20to%20the%20setup%20and%20configuration%20of%20Exchange%20Server.%20Additional%20details%20and%20recommended%20customer%20actions%20follow.%3C%2FP%3E%3CH2%20id%3D%22toc-hId-1759369785%22%20id%3D%22toc-hId-1760056837%22%3EChanges%20to%20Exchange%20Web%20Services%20Push%20Notifications%3C%2FH2%3EAn%20architectural%20change%20to%20Exchange%20Web%20Services%20(EWS)%20Push%20Notifications%20authentication%20is%20included%20in%20all%20packages%20released%20today.%20%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fkb%2F4490060%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EKB4490060%3C%2FA%3E%20outlines%20the%20details%20of%20the%20changes%20made.%20Customers%20who%20rely%20upon%20Push%20Notifications%2C%20should%20understand%20the%20important%20changes%20made.%20We%20have%20evaluated%20the%20changes%20to%20push%20notifications%20against%20many%20commonly%20used%20EWS%20clients%2C%20e.g.%20Outlook%20Mac%2C%20Skype%20for%20Business%20Client%2C%20native%20iOS%20mail%20clients%20and%20observed%20no%20loss%20of%20functionality%20due%20to%20these%20changes.%20EWS%20Pull%20and%20Streaming%20Notifications%20functionality%20are%20unchanged%20by%20today%E2%80%99s%20updates.%20The%20update%20to%20EWS%20Push%20Notifications%20is%20considered%20a%20critical%20security%20update%20and%20customers%20should%20deploy%20the%20update%20as%20soon%20as%20they%20understand%20and%20accept%20any%20potential%20impact.%20The%20change%20in%20Push%20Notification%20authentication%20is%20a%20permanent%20change%20to%20the%20product%20and%20necessary%20to%20protect%20the%20security%20of%20an%20Exchange%20Server.%20After%20applying%20either%20the%20cumulative%20update%20or%20update%20rollup%20to%20a%20server%2C%20customers%20are%20advised%20to%20force%20a%20reset%20of%20the%20Exchange%20servers%E2%80%99%20credentials%20stored%20in%20Active%20Directory.%20This%20can%20be%20accomplished%20using%20the%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fpowershell%2Fmodule%2Fmicrosoft.powershell.management%2Freset-computermachinepassword%3Fview%3Dpowershell-5.1%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EReset-ComputerMachinePassword%3C%2FA%3E%20cmdlet%20in%20PowerShell%205.1%20or%20later.%20If%20PowerShell%20is%20not%20an%20option%2C%20%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F325850%2Fhow-to-use-netdom-exe-to-reset-machine-account-passwords-of-a-windows%232%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3Enetdom%20can%20also%20be%20used%3C%2FA%3E.%20Microsoft%20knows%20of%20no%20instances%20where%20machine%20accounts%20have%20been%20compromised.%20Updating%20a%20machine%20account%20password%20is%20considered%20a%20best%20practice%20to%20ensure%20the%20security%20of%20the%20server%20is%20not%20compromised.%20In%20addition%2C%20customers%20are%20encouraged%20to%20evaluate%20if%20their%20user%20password%20expiration%20policies%20are%20appropriate%20for%20Exchange%20enabled%20accounts.%3CH2%20id%3D%22toc-hId--792787176%22%20id%3D%22toc-hId--792100124%22%3EDecreasing%20Exchange%20Rights%20in%20the%20Active%20Directory%3C%2FH2%3EThe%20Exchange%20team%20has%20determined%20a%20change%20in%20the%20Active%20Directory%20rights%20granted%20to%20Exchange%20Servers%20using%20the%20default%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fexchange%2Fconfigure-exchange-2013-for-shared-permissions-exchange-2013-help%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EShared%20Permissions%20Model%3C%2FA%3E%20is%20in%20order.%20Changes%20in%20the%20latest%20cumulative%20updates%2C%20described%20in%20%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fkb%2F4490059%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EKB4490059%3C%2FA%3E%2C%20reduce%20the%20scope%20of%20objects%20where%20Exchange%20is%20able%20to%20write%20security%20descriptors%20in%20the%20directory.%20In%20order%20to%20apply%20these%20changes%2C%20a%20directory%20admin%20will%20need%20to%20run%20the%20cumulative%20update%20setup%20program%20with%20the%20%2FPrepareAD%20parameter.%20When%20multiple%20Exchange%20versions%20co-exist%20in%20a%20single%20Active%20Directory%20forest%2C%20the%20cumulative%20update%20matching%20the%20latest%20version%20of%20Exchange%20deployed%20should%20be%20used%20to%20run%20%2FPrepareAD.%20Setup%20will%20automatically%20run%20%2FPrepareDomain%20in%20the%20domain%20where%20%2FPrepareAD%20is%20executed.%20Environments%20with%20multiple%20domains%20in%20the%20forest%20will%20need%20to%20run%20the%20cumulative%20update%20setup%20program%20using%20the%20%2FPrepareDomain%20parameter%20in%20all%20domains%20in%20the%20forest.%20These%20steps%20will%20update%20the%20rights%20granted%20to%20Exchange%20Servers%20in%20the%20Active%20Directory%20to%20meet%20the%20new%20permissions%20scope.%20More%20information%20on%20%2FPrepareAD%20and%20%2FPrepareDomain%20is%20available%20at%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2FExchange%2Fplan-and-deploy%2Fprepare-ad-and-domains%3Fview%3Dexchserver-2019%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3Ethis%20link%3C%2FA%3E.%20Customers%20running%20only%20Exchange%20Server%202010%20will%20need%20to%20follow%20the%20instructions%20in%20KB4490059%20to%20update%20their%20environments.%20The%20update%20rollup%20package%20released%20for%202010%20will%20not%20apply%20the%20directory%20changes.%20The%20directory%20updates%20described%20in%20KB4490059%20are%20fully%20compatible%20with%20all%20versions%20of%20Exchange%20Server%20regardless%20of%20cumulative%20update%20or%20update%20rollup%20version%20deployed.%20There%20is%20no%20loss%20of%20product%20functionality%20associated%20with%20these%20updates.%20The%20rights%20granted%20to%20Exchange%20in%20Active%20Directory%20using%20the%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fexchange%2Funderstanding-split-permissions-exchange-2013-help%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EActive%20Directory%20Split%20Permissions%20Model%3C%2FA%3E%20are%20unchanged%20by%20the%20updates%20released%20today.%3CH2%20id%3D%22toc-hId-950023159%22%20id%3D%22toc-hId-950710211%22%3EShared%20Permissions%20vs.%20Split%20Permissions%20Model%3C%2FH2%3EEarly%20advisories%20released%20by%20Microsoft%20related%20to%20this%20vulnerability%20indicated%20that%20Active%20Directory%20Split%20Permissions%20Model%20was%20a%20possible%20mitigation%20to%20Domain%20Admin%20elevation.%20It%20is%20true%20Split%20Permissions%20affords%20additional%20directory%20protection%20over%20the%20Shared%20Permissions%20Model.%20However%2C%20Microsoft%20fully%20supports%20both%20modes%20of%20directory%20operation%20and%20recognizes%20that%20there%20are%20relative%20strengths%20and%20weaknesses%20inherent%20to%20both%20models.%20Before%20implementing%20a%20change%20of%20this%20type%2C%20customers%20should%20fully%20evaluate%20the%20impact%20to%20line%20of%20business%20processes%2C%20security%20and%20operational%20needs.%20The%20changes%20released%20today%20improve%20the%20security%20profile%20of%20the%20Shared%20Permissions%20Model%2C%20while%20retaining%20the%20administrative%20flexibility%20it%20affords.%20The%20combination%20of%20the%20directory%20permission%20changes%20and%20EWS%20security%20change%20provides%20the%20best%20possible%20protection%20against%20possible%20attacks%2C%20meaning%20that%20Active%20Directory%20Split%20Permissions%20are%20not%20required%2C%20but%20still%20optional.%3CH2%20id%3D%22toc-hId--1602133802%22%20id%3D%22toc-hId--1601446750%22%3ERemoving%20Legacy%20Auth%20protocols%20from%20Exchange%20Servers%3C%2FH2%3EThe%20Exchange%20team%20has%20been%20hard%20at%20work%20adding%20a%20feature%20to%20limit%20legacy%20authentication%20mechanisms%20on%20a%20user%20by%20user%20basis.%20In%20Exchange%20Server%202019%20Cumulative%20Update%201%2C%20we%20are%20announcing%20new%20cmdlet%20support%20to%20create%20organization%20policies%20that%20restrict%20legacy%20authentication%20protocols.%20Policies%20can%20be%20defined%20which%20restrict%20legacy%20authentication%20on%20a%20per%20protocol%20and%20user%20by%20user%20basis.%20The%20capabilities%20added%20are%20based%20upon%20the%20same%20functionality%20already%20available%20in%20Office%20365.%20In%20the%20days%20ahead%2C%20we%20will%20release%20additional%20details%20on%20this%20blog%20concerning%20this%20exciting%20new%20feature.%3CH2%20id%3D%22toc-hId-140676533%22%20id%3D%22toc-hId-141363585%22%3ERelease%20Details%3C%2FH2%3EThe%20KB%20articles%20that%20describe%20the%20fixes%20in%20each%20release%20and%20product%20downloads%20are%20available%20as%20follows%3A%3CUL%3E%0A%20%20%3CLI%3EExchange%20Server%202019%20Cumulative%20Update%201%20(%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fkb%2F4471391%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EKB4471391%3C%2FA%3E)%2C%20%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2FLicensing%2Fservicecenter%2Fdefault.aspx%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EVLSC%20Download%3C%2FA%3E%3C%2FLI%3E%0A%20%20%3CLI%3EExchange%20Server%202016%20Cumulative%20Update%2012%20(%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fkb%2F4471392%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EKB4471392%3C%2FA%3E)%2C%20%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fdownloads%2Fdetails.aspx%3FFamilyID%3D755a31f9-6c8a-4895-be34-8b4b697d5d22%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EDownload%3C%2FA%3E%2C%20%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fdownloads%2Fdetails.aspx%3FFamilyID%3Dca5e4ada-ac04-4858-9f19-0a5791e3f913%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EUM%20Lang%20Packs%3C%2FA%3E%3C%2FLI%3E%0A%20%20%3CLI%3EExchange%20Server%202013%20Cumulative%20Update%2022%20(%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fkb%2F4345836%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EKB4345836%3C%2FA%3E)%2C%20%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fdownloads%2Fdetails.aspx%3FFamilyID%3Dab89d7a1-973b-4db3-b55f-ea19015c7a44%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EDownload%3C%2FA%3E%2C%20%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fdownloads%2Fdetails.aspx%3FFamilyID%3D8c8c793a-e7a1-4cfa-a3b2-98eca274a0c0%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EUM%20Lang%20Packs%3C%2FA%3E%3C%2FLI%3E%0A%20%20%3CLI%3EExchange%20Server%202010%20Service%20Pack%203%20Update%20Rollup%2026%20(%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fkb%2F4487052%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EKB4487052%3C%2FA%3E)%2C%20%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fdownloads%2Fdetails.aspx%3FFamilyID%3Db1539a6a-5873-4459-a4a3-d089273d0601%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EDownload%3C%2FA%3E%2C%20also%20available%20on%20Microsoft%20Update%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3CH2%20id%3D%22toc-hId-1883486868%22%20id%3D%22toc-hId-1884173920%22%3EAdditional%20Information%3C%2FH2%3EMicrosoft%20recommends%20all%20customers%20test%20the%20deployment%20of%20any%20update%20in%20their%20lab%20environment%20to%20determine%20the%20proper%20installation%20process%20for%20your%20production%20environment.%20For%20information%20on%20extending%20the%20schema%20and%20configuring%20Active%20Directory%2C%20please%20review%20the%20appropriate%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Fprepare-active-directory-and-domains-exchange-2013-help%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EMicrosoft%20Docs%3C%2FA%3E%20documentation.%20Also%2C%20to%20prevent%20installation%20issues%20you%20should%20ensure%20that%20the%20Windows%20PowerShell%20Script%20Execution%20Policy%20is%20set%20to%20%E2%80%9CUnrestricted%E2%80%9D%20on%20the%20server%20being%20upgraded%20or%20installed.%20To%20verify%20the%20policy%20settings%2C%20run%20the%20Get-ExecutionPolicy%20cmdlet%20from%20PowerShell%20on%20the%20machine%20being%20upgraded.%20If%20the%20policies%20are%20NOT%20set%20to%20Unrestricted%20you%20should%20use%20the%20resolution%20steps%20in%20%3CA%20href%3D%22http%3A%2F%2Fsupport.microsoft.com%2Fkb%2F981474%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EKB981474%3C%2FA%3E%20to%20adjust%20the%20settings.%20%3CB%3EReminder%3A%20%3C%2FB%3ECustomers%20in%20hybrid%20deployments%20where%20Exchange%20is%20deployed%20on-premises%20and%20in%20the%20cloud%2C%20or%20who%20are%20using%20Exchange%20Online%20Archiving%20(EOA)%20with%20their%20on-premises%20Exchange%20deployment%20are%20required%20to%20deploy%20the%20currently%20supported%20cumulative%20update%20for%20the%20product%20version%20in%20use%2C%20e.g.%2C%202013%20Cumulative%20Update%2022%2C%202016%20Cumulative%20Update%2012%20or%2011.%20For%20the%20latest%20information%20on%20Exchange%20Server%20and%20product%20announcements%20please%20see%20%3CA%20href%3D%22https%3A%2F%2Ftechnet.microsoft.com%2Flibrary%2Fjj150540(v%3Dexchg.160).aspx%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EWhat's%20New%20in%20Exchange%20Server%202016%3C%2FA%3E%20and%20%3CA%20href%3D%22https%3A%2F%2Ftechnet.microsoft.com%2Flibrary%2Fjj150489(v%3Dexchg.160).aspx%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EExchange%20Server%202016%20Release%20Notes%3C%2FA%3E.%20You%20can%20also%20find%20updated%20information%20on%20Exchange%20Server%202013%20in%20%3CA%20href%3D%22http%3A%2F%2Ftechnet.microsoft.com%2Flibrary%2Fjj150540(v%3Dexchg.150).aspx%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EWhat%E2%80%99s%20New%20in%20Exchange%20Server%202013%3C%2FA%3E%2C%20%3CA%20href%3D%22http%3A%2F%2Ftechnet.microsoft.com%2Flibrary%2Fjj150489(v%3Dexchg.150).aspx%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3ERelease%20Notes%3C%2FA%3E%20and%20product%20documentation%20available%20on%20Microsoft%20Docs.%20The%20updates%20released%20today%20will%20replace%20the%20quarterly%20servicing%20updates%20originally%20planned%20for%20March.%20The%20next%20planned%20set%20of%20quarterly%20updates%20is%20targeted%20for%20delivery%20in%20June.%20%3CB%3EImportant%3A%3C%2FB%3E%20To%20avoid%20a%20setup%20failure%2C%20it%20is%20necessary%20to%20install%20the%20%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fdownload%2Fdetails.aspx%3Fid%3D30679%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3EVisual%20C%2B%2B%202012%20runtime%3C%2FA%3E%20%3CB%3Ebefore%3C%2FB%3E%20installing%20Cumulative%20Update%2022%20or%20Cumulative%20Update%2012%20on%20Edge%20role%20if%20not%20already%20present.%3CP%20class%3D%22note%22%3ENote%3A%20Documentation%20may%20not%20be%20fully%20available%20at%20the%20time%20this%20post%20is%20published.%3C%2FP%3E%3CSPAN%20class%3D%22author%22%3EThe%20Exchange%20Team%3C%2FSPAN%3E%3C%2FLINGO-BODY%3E

Today we are announcing the availability of quarterly servicing updates, cumulative and update rollups, for all supported versions of Exchange Server. Exchange Server 2010, 2013, 2016 and 2019 all receive an update package. These updates include important fixes to address vulnerabilities being discussed in blogs and other social media outlets. While it is not the normal or preferred practice to release security updates in a cumulative update package, the nature of the product changes dictate that they be delivered this way as they include changes to the setup and configuration of Exchange Server. Additional details and recommended customer actions follow.

Changes to Exchange Web Services Push Notifications

An architectural change to Exchange Web Services (EWS) Push Notifications authentication is included in all packages released today. KB4490060 outlines the details of the changes made. Customers who rely upon Push Notifications, should understand the important changes made. We have evaluated the changes to push notifications against many commonly used EWS clients, e.g. Outlook Mac, Skype for Business Client, native iOS mail clients and observed no loss of functionality due to these changes. EWS Pull and Streaming Notifications functionality are unchanged by today’s updates. The update to EWS Push Notifications is considered a critical security update and customers should deploy the update as soon as they understand and accept any potential impact. The change in Push Notification authentication is a permanent change to the product and necessary to protect the security of an Exchange Server. After applying either the cumulative update or update rollup to a server, customers are advised to force a reset of the Exchange servers’ credentials stored in Active Directory. This can be accomplished using the Reset-ComputerMachinePassword cmdlet in PowerShell 5.1 or later. If PowerShell is not an option, netdom can also be used. Microsoft knows of no instances where machine accounts have been compromised. Updating a machine account password is considered a best practice to ensure the security of the server is not compromised. In addition, customers are encouraged to evaluate if their user password expiration policies are appropriate for Exchange enabled accounts.

Decreasing Exchange Rights in the Active Directory

The Exchange team has determined a change in the Active Directory rights granted to Exchange Servers using the default Shared Permissions Model is in order. Changes in the latest cumulative updates, described in KB4490059, reduce the scope of objects where Exchange is able to write security descriptors in the directory. In order to apply these changes, a directory admin will need to run the cumulative update setup program with the /PrepareAD parameter. When multiple Exchange versions co-exist in a single Active Directory forest, the cumulative update matching the latest version of Exchange deployed should be used to run /PrepareAD. Setup will automatically run /PrepareDomain in the domain where /PrepareAD is executed. Environments with multiple domains in the forest will need to run the cumulative update setup program using the /PrepareDomain parameter in all domains in the forest. These steps will update the rights granted to Exchange Servers in the Active Directory to meet the new permissions scope. More information on /PrepareAD and /PrepareDomain is available at this link. Customers running only Exchange Server 2010 will need to follow the instructions in KB4490059 to update their environments. The update rollup package released for 2010 will not apply the directory changes. The directory updates described in KB4490059 are fully compatible with all versions of Exchange Server regardless of cumulative update or update rollup version deployed. There is no loss of product functionality associated with these updates. The rights granted to Exchange in Active Directory using the Active Directory Split Permissions Model are unchanged by the updates released today.

Shared Permissions vs. Split Permissions Model

Early advisories released by Microsoft related to this vulnerability indicated that Active Directory Split Permissions Model was a possible mitigation to Domain Admin elevation. It is true Split Permissions affords additional directory protection over the Shared Permissions Model. However, Microsoft fully supports both modes of directory operation and recognizes that there are relative strengths and weaknesses inherent to both models. Before implementing a change of this type, customers should fully evaluate the impact to line of business processes, security and operational needs. The changes released today improve the security profile of the Shared Permissions Model, while retaining the administrative flexibility it affords. The combination of the directory permission changes and EWS security change provides the best possible protection against possible attacks, meaning that Active Directory Split Permissions are not required, but still optional.

Removing Legacy Auth protocols from Exchange Servers

The Exchange team has been hard at work adding a feature to limit legacy authentication mechanisms on a user by user basis. In Exchange Server 2019 Cumulative Update 1, we are announcing new cmdlet support to create organization policies that restrict legacy authentication protocols. Policies can be defined which restrict legacy authentication on a per protocol and user by user basis. The capabilities added are based upon the same functionality already available in Office 365. In the days ahead, we will release additional details on this blog concerning this exciting new feature.

Release Details

The KB articles that describe the fixes in each release and product downloads are available as follows:

Additional Information

Microsoft recommends all customers test the deployment of any update in their lab environment to determine the proper installation process for your production environment. For information on extending the schema and configuring Active Directory, please review the appropriate Microsoft Docs documentation. Also, to prevent installation issues you should ensure that the Windows PowerShell Script Execution Policy is set to “Unrestricted” on the server being upgraded or installed. To verify the policy settings, run the Get-ExecutionPolicy cmdlet from PowerShell on the machine being upgraded. If the policies are NOT set to Unrestricted you should use the resolution steps in KB981474 to adjust the settings. Reminder: Customers in hybrid deployments where Exchange is deployed on-premises and in the cloud, or who are using Exchange Online Archiving (EOA) with their on-premises Exchange deployment are required to deploy the currently supported cumulative update for the product version in use, e.g., 2013 Cumulative Update 22, 2016 Cumulative Update 12 or 11. For the latest information on Exchange Server and product announcements please see What's New in Exchange Server 2016 and Exchange Server 2016 Release Notes. You can also find updated information on Exchange Server 2013 in What’s New in Exchange Server 2013, Release Notes and product documentation available on Microsoft Docs. The updates released today will replace the quarterly servicing updates originally planned for March. The next planned set of quarterly updates is targeted for delivery in June. Important: To avoid a setup failure, it is necessary to install the Visual C++ 2012 runtime before installing Cumulative Update 22 or Cumulative Update 12 on Edge role if not already present.

Note: Documentation may not be fully available at the time this post is published.

The Exchange Team
118 Comments
Not applicable
I don't see the necessity to make the Exchange Server 2019 CU1 download only available via the VLSC. Getting Product Keys from there, ok. But the source? What are we supposed to do when we are testing and don't have a VLSC contract? My company is a Gold Partner...
Not applicable
I'm guessing as it's only available to buy through the Volume channel, MS is restricting the bits.
Not applicable
Hi Christian,

MSDN is another source to download when you need the bits for testing purposes.

Not applicable
Can't find Exchange server 2019 CU1 on Action pack Benefits download page (Partnercenter).
Not applicable
Don't see it in my MSDN downloads. Any hints?
Not applicable
Still not on MSDN Platforms aswell
Not applicable
I can confirm its presence here (Partner MSDN): https://partner.microsoft.com/en-us/pcv/partnership/benefits \Software Products
Not applicable
It's only available via Volume Licensing and MSDN. Not the Action Pack.
Not applicable
We'll check into it. Thanks for letting us know.
Not applicable
It's now available through MSDN for me.
Not applicable
So I queried this, got told this: https://twitter.com/OfficeSupport/status/1100069535300894721
Not applicable
After two weeks it is still not on my.visualstudio ... only the RTM.

Any updates and is it not possible to provide it through MS downloads?

Thanks

Christian

Not applicable
Thank you very much, works.
Not applicable
Still Nothing on MSDN. I do not understand why it takes more than a week to publish the Content.
Not applicable
Same here, not on MSDN aswell :(
Not applicable
Any reason why the MSDN download question is left unanswered?

Must we ISV devs worry about future availability of Exchange 2019 for testing?

Not applicable
Still not on MSDN for me (Enterprise).
Not applicable
Hi Greg, I can still not find 2019 CU1 on MSDN (Visual Studio Enterprise). I work for an ISV where we like to test our products on current Exchange versions early to check for regressions. Its a bit frustrating to pay MSDN and not get new versions at least the the same time as our customers. Not your teams fault, I know, but maybe you have a way to pass it on?
Not applicable
"When multiple Exchange versions co-exist in a single Active Directory forest, the cumulative update matching the latest version of Exchange deployed should be used to run /PrepareAD"

If i'm moving to Exchange 2019, can I just run the CU /PrepareAD as part of the 2019 CU1 install, or do i need to go back and apply CU22 to all 2013 boxes as well? I'd rather not go through all that CU updating if necessary as i'll be moving off them soon. But dont want any compatibility issues.

Not applicable
@mark49808: Use the Exchange 2019 CU1 sources to updates your Exchange 2019 Servers and to run Setup.exe /PrepareAD and /PrepareAllDomains but then go to the older servers and install the updates to fix the EWS credential vulnerability. Frank
Not applicable
When running 2016 and 2010 in co-existence, do the 2010 manual steps still need to be done or will the /PrepareAD for the 2016 update take care of it already?
Not applicable
HHante: The Exchange 2013/2016/2019 Setup will modify all the permissions, because these are "full setups". The Exchange 2010RU is "only" a Security Update and will fix the EWS vulnerability only. a "Setup" can modify installation settings. A RU can patches a code problem only but no a setup configuration.

So run the Exchange 2016 Setup with PrepareAD/PrepareAllDomains and don't forget to fix the Exchange 2010 afterwards

Not applicable
Just to be completely clear, the 2016 CU12 will take care of the permission changes needed in KB4490059. The only part we will need to do for 2010 is to apply UR26. Is this correct?
Not applicable
@HHante, that is correct.
Not applicable
Thanks for this full detailed description guys, however still one open question on the vulnerability part.

CVE-2018-8581 initially talked about removing the DisableLoopBackCheck Key:

To address this vulnerability, a registry value which enables NTLM authentication on the network loopback adapter needs to be removed. Future cumulative updates will ensure that this registry setting is configured correctly during installation of the cumulative update.

---

We have removed this key on our EX2016 CU11 Servers to be on the safe side and didn't see any negative side effects so far. Is this key also being removed during CU12 install and the recommendation above still valid even after the changes been implemented with the updates been released today?

Thanks for clarifying!

Not applicable
@Martin, yes the CU's released today should remove this key, if present. The 2010 RU will not remove the key. There's no harm if you have already done this, it will not interfere with CU installation.
Not applicable
Hi Brent. If DisableLoopbackCheck is now being disabled in all 2013+ CUs, why was it still in-place? Does this mean Exchange Server has been unwinding a default security feature that's been around for something like 15 years for no benefit? And why didn't the Exchange team push BackConnectionHostNames guidance as is common in other web technologies like SharePoint?
Not applicable
@Tristan - There have been legitimate reasons for Exchange to enable this. We are hearing some reports of certain Exchange monitoring tools requiring loopback to be enabled. We will look to change the behavior of these cmdlets. But honestly it appears to have been an optimization that was made for reasons that may no longer apply to Exchange code, a long time ago. In general we don't like to change behavior that has existed for a very long time due to the surface area that Exchange covers and the risk of regression. In this case however, closing a security hole made that a requirement. Our preference is to remove dependence on NTLM altogether in the product and that is the work that has been more important to us and that we have been working on.

It is a minor optimization based upon reports coming in from SCOM. We likely have to update our cmdlets, but I don't want to give the impression we haven't tested the cmdlets. It's hard for us to tell in a one-box topology what is real and what isn't when tests fail sometimes.

Not applicable
@Brent. Thanks for the candid reply. I appreciate there's always a balance to be achieved between adaptation and stability, but I think the main concern is that Exchange has been fully disabling the loopback check rather than explicitly whitelisting the Exchange URLs with BackConnectionHostNames, as has been the guidance in the SharePoint, NLB, etc. worlds for over a decade.
Not applicable
Great work on addressing this vulnerability. Thank you!
Not applicable
Just tried CU12 on our Test Edge box that did have vcredist_x64 installed already but the installed failed with:

Error:

The following error was generated when "$error.Clear();

$dllFile = join-path $RoleInstallPath "bin\ExSMIME.dll";

$regsvr = join-path (join-path $env:SystemRoot system32) regsvr32.exe;

start-SetupProcess -Name:"$regsvr" -Args:"/s `"$dllFile`"" -Timeout:120000;

" was run: "Microsoft.Exchange.Configuration.Tasks.TaskException: Process execution failed with exit code 3.

at Microsoft.Exchange.Management.Tasks.RunProcessBase.InternalProcessRecord()

at Microsoft.Exchange.Configuration.Tasks.Task.b__91_1()

at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)".

Not applicable
That is the error you will get if the Visual C++ 2012 runtime is not installed on the Edge Transport server. See the "Important" note in the post above for the link.
Not applicable
@PhageDFU - Edge only requires VC++2012. It sounds like MSI went ahead an uninstalled it due to a reference count issue. If you Install VCRedist again, setup should resume where you left off.
Not applicable
It's about time Microsoft added that to the prerequisite checker - this is not new.
Not applicable
We actually found we had VC ++ 2013 installed as the pre-req for CU10, so I added VC ++ 2012 and the install continued and completed successfully. Thanks for the response!
Not applicable
Agreed.
Not applicable
FWIW - The pre-req is included in the rules. However, pre-reqs run before actions taken by the MSI installer are completed. As Exchange was silently installing the pre-req previously, when we apply the CU upgrade that stops silently installing the binaries, the MSI removes on the next upgrade. This occurs after the pre-req engine has run. So we have a chicken and egg situation, where we detect something is installed that the MSI installer is going to remove. That is why we have the note to make certain that the package is installed before invoking setup to avoid the collision caused by the MSI installer removing the previous version.
Not applicable
we only have a small test environment. has anyone tried the cu22 for Exchange 2013 yet? does it negatively affect smartphone users? Outlook Anywhere?
Not applicable
We would expect that all to work properly after this or any update. If it doesn't we'd like to know.
Not applicable
wow.. i'm gonna sit this one out until somebody from Exchange 2013 cu22 does it.
Not applicable
Thanks for addressing this, and again a load of issues that are fixed in these CU's!
Not applicable
Do you need to run the install with /preparead for all Exchange servers or is it only needed for one of the servers of the same version?
Not applicable
You run it once - using the version that matches the highest version in the org.

If you have 2010 and 2016 in the org - run it once using the 2016 bits.

Not applicable
When running the /preparead command for the 2016 CU12 update i noticed it still says Cumulative Update 11 Unattended Setup.
Not applicable
hanskristian85, you are probably executing the old setup from install directory. This occurs when you do not specify the full path to the executable in powershell. Powershell runs hits in PATH directories before resolving hits in the current directory.
Not applicable
That is probably correct, i think i only supplied the name of the .exe file since my prompt was in the same folder.
Not applicable
I'm a bit confused about the EWS push change.

KB4490060 states:

Note This workaround causes some clients to not function correctly. This includes Outlook for Mac, Skype for Business, native iOS mail clients, and some other third-party clients. It may also include custom LOB applications.

You state in this blog:

We have evaluated the changes to push notifications against many commonly used EWS clients, e.g. Outlook Mac, Skype for Business Client, native iOS mail clients and observed no loss of functionality due to these changes.

So what is it? ;)

Not applicable
They are different things:

The workaround is setting EWS policies. That can have impact on clients. The fix is the change that shipped in our latest updates, as discussed in this blog post. In other words - if one installs the updates, the workaround is not needed. If one implements the workaround, however, there can be an impact to clients.

We are saying that we do not know of issues when customers implement a fix (install updates) but there could be impact if you do not do that but implement a workaround. Does that help?

Not applicable
Any idea on the impact for,

1. iPhone native mail app's push setting for retrieving emails, calendar popup, etc?

2. Any testing done with MaaS360 ?

Not applicable
Taken from the blog post above:

We have evaluated the changes to push notifications against many commonly used EWS clients, e.g. Outlook Mac, Skype for Business Client, native iOS mail clients and observed no loss of functionality due to these changes. EWS Pull and Streaming Notifications functionality are unchanged by today’s updates.

In other words - we do not have an exhaustive list of 3rd party EWS apps and their potential impact, but have not observed any impact to most common client apps. Please see appropriate vendors for that guidance and compatibility with our latest releases.