Home

percentage symbol goes the wrong way

%3CLINGO-SUB%20id%3D%22lingo-sub-1007036%22%20slang%3D%22en-US%22%3Epercentage%20symbol%20goes%20the%20wrong%20way%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1007036%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3ESo%20I%20have%20this%20huge%20spreadsheet%20with%20Arabic%20text%20and%20some%20Hebrew%20(both%20are%20RTL%20languages)%20with%20many%20many%20tables%20and%20charts%20that%20are%20connected%20to%20them.%20In%20the%20cells%20of%20most%20of%20the%20tables%2C%20I%20see%20the%20%25%20symbol%20in%20the%20right%2C%20where%20it%20should%20be%2C%2015%25%20for%20example%2C%20but%20in%20the%20pie%20charts'%20labels%20that%20are%20connected%20to%20those%20tables%20the%20%25%20is%20on%20the%20left%3A%20%2515%20(i'm%20attaching%20two%20print%20screen%20maybe%20it%20will%20be%20more%20clear).%3C%2FP%3E%3CP%3EI%20tried%20to%20delete%20the%20labels%20completely%20and%20add%20them%20again%20and%20it%20looks%20fine%20for%20a%20moment%20but%20then%2C%20I%20saved%20the%20file%2C%20closed%20it%20and%20open%20it%20again%20and%20problem%20came%20back.%20The%20add%20more%20mysterious%20to%20the%20situation%20in%20bar%20charts%5Cgraph%20line%20ETC%20the%20percent%20labels%20look%20fine.%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20some%20one%20can%20help%20me%20solve%20this%20mystery...%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20548px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F157003i7DBE948FA9A2677E%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22percent-3.PNG%22%20title%3D%22percent-3.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20647px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F157002i4260D1F9482AD61F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22percent-2.PNG%22%20title%3D%22percent-2.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1007036%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Epie%20chart%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1007060%22%20slang%3D%22en-US%22%3ERe%3A%20percentage%20symbol%20goes%20the%20wrong%20way%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1007060%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F457150%22%20target%3D%22_blank%22%3E%40Kerem_%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EHave%20no%20idea%20why%20it%20appears%20by%20default%2C%20but%20you%20may%20open%20labels%20format%20pane%20and%20for%20values%20add%20and%20apply%20custom%20number%20format%3C%2FP%3E%0A%3CPRE%20class%3D%22lia-code-sample%20language-markup%22%3E%3CCODE%3E0.00%25%3C%2FCODE%3E%3C%2FPRE%3E%0A%3CP%3Einstead%20of%20your%20current%20one%26nbsp%3B%250.00%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1007588%22%20slang%3D%22en-US%22%3ERe%3A%20percentage%20symbol%20goes%20the%20wrong%20way%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1007588%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F521%22%20target%3D%22_blank%22%3E%40Sergei%20Baklan%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETried%20it%2C%20but%20it%20still%20insist%20to%20put%20the%20symbol%20on%20the%20left.%20Actually%20when%20i%20use%20this%20pseudo%20custom%20format%20it%20change%20the%20category%26nbsp%3B%20number%20type%20to%20percentage%20again%20change%20the%20custom%20to%20percent%20I'm%20using%20excel%20for%20many%20many%20years%2C%20and%20never%20encounter%20this%20behavior.%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F157084i64B3C0D92729ED38%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22percent.gif%22%20title%3D%22percent.gif%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1008099%22%20slang%3D%22en-US%22%3ERe%3A%20percentage%20symbol%20goes%20the%20wrong%20way%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1008099%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F457150%22%20target%3D%22_blank%22%3E%40Kerem_%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ESorry%2C%20but%20I%20have%20no%20more%20ideas%20how%20to%20fix%20this.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Kerem_
New Contributor

Hi

So I have this huge spreadsheet with Arabic text and some Hebrew (both are RTL languages) with many many tables and charts that are connected to them. In the cells of most of the tables, I see the % symbol in the right, where it should be, 15% for example, but in the pie charts' labels that are connected to those tables the % is on the left: %15 (i'm attaching two print screen maybe it will be more clear).

I tried to delete the labels completely and add them again and it looks fine for a moment but then, I saved the file, closed it and open it again and problem came back. The add more mysterious to the situation in bar charts\graph line ETC the percent labels look fine. 

Hope some one can help me solve this mystery...

Thanks

percent-3.PNG

percent-2.PNG

3 Replies

@Kerem_ 

Have no idea why it appears by default, but you may open labels format pane and for values add and apply custom number format

0.00%

instead of your current one %0.00

Thanks @Sergei Baklan 

Tried it, but it still insist to put the symbol on the left. Actually when i use this pseudo custom format it change the category  number type to percentage again change the custom to percent I'm using excel for many many years, and never encounter this behavior.percent.gif

 

@Kerem_ 

Sorry, but I have no more ideas how to fix this.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies