Home

When copying form another tab, how to skip a row with an empty cel or filled with 0

André van der Leij
Occasional Visitor

Hello everyone,

I have a spreadsheet, which tells on the first tab how many hours someone has worked, and the spreadsheet will then calculate how much money (s)he has earned.
This information needs to be copied to a second tab, where we have created stickers, which can be printed. But on the first tab, there are also a lot of people who haven't worked, and therefor haven't earned anything, so on the second tab, I don't want to see them. In other words, when the cell for the amount of money on tab 1 is empty or 0, then I don't want it to be copied to the second tab.
Now, I use this formula =ALS('50|50 Food'!$N4>0;'50|50 Food'!$B4) and when cel N4 is > 0 it gives me the right copy. But when N4=0, then it will reply with Value, but I want it to skip copying, and go to the next row (N5). How can I do this?

 

Right now, I use this formula
=IF('50|50 Food'!$N4>0;'50|50 Food'!$B4;IF('50|50 Food'!N5>0;'50|50 Food'!B5;IF('50|50 Food'!N6>0;'50|50 Food'!B6)))
This works, but I have to refer to 60 different lines, which makes the formula extra big. I just wondered if there is another option.

Thank you all in advance for your help.

André