Home

Vlookup returning N/A except for three cells

%3CLINGO-SUB%20id%3D%22lingo-sub-386343%22%20slang%3D%22en-US%22%3EVlookup%20returning%20N%2FA%20except%20for%20three%20cells%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-386343%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20first%20two%20columns%20setup%20as%20table%203%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20doing%20a%20simple%20vlookup%20and%20the%20formula%20is%20only%20returning%20three%20cells%20with%20details%2C%20doesn't%20make%20sense%20the%20formatting%20is%20all%20the%20same.%20What%20is%20going%20wrong%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESee%20attachment%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-386343%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Evlookup%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-386366%22%20slang%3D%22en-US%22%3ERe%3A%20Vlookup%20returning%20N%2FA%20except%20for%20three%20cells%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-386366%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F306919%22%20target%3D%22_blank%22%3E%40TMAZZ%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20data%20in%20column%20C%20isn't%20clean%2C%20it%20contains%20many%20leading%20spaces!%3C%2FP%3E%3CP%3EYou%20need%20to%20clean%20these%20spaces%20using%20%3CA%20href%3D%22https%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2FTRIM-function-410388FA-C5DF-49C6-B16C-9E5630B479F9%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3ETRIM%20function%3C%2FA%3E.%20I've%20done%20that%20for%20you%20in%20the%20attached%20file.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20that%20help%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
TMAZZ
New Contributor

I have the first two columns setup as table 3, 

 

I'm doing a simple vlookup and the formula is only returning three cells with details, doesn't make sense the formatting is all the same. What is going wrong?

 

See attachment

 

 

1 Reply

Hi @TMAZZ,

 

The data in column C isn't clean, it contains many leading spaces!

You need to clean these spaces using TRIM function. I've done that for you in the attached file.

 

Hope that help

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies