Home

Unable to Connect to Web Source With Credentials in Power Query

%3CLINGO-SUB%20id%3D%22lingo-sub-116795%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116795%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20assisting%20diagnosis%2C%20Ehren.%20I've%20posted%20a%20new%20suggestion%20as%20a%20result%20of%20this%3A%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fexcel.uservoice.com%2Fforums%2F304921-excel-for-windows-desktop-application%2Fsuggestions%2F31900633-re-enable-authentication-capability-for-the-powerq%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fexcel.uservoice.com%2Fforums%2F304921-excel-for-windows-desktop-application%2Fsuggestions%2F31900633-re-enable-authentication-capability-for-the-powerq%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-103741%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103741%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%20for%20following%20up.%20I%20have%20emailed%20some%20details%20FAO%3A%20Ehren.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-103518%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103518%22%20slang%3D%22en-US%22%3E%3CP%3ETim%2C%20would%20you%20mind%20sending%20more%20details%20of%20your%20issue%20(along%20with%20a%20Fiddler%20trace%2C%20if%20possible)%20to%26nbsp%3Bpq2fb%40microsoft.com%3F%20Please%20mention%20my%20name%20when%20you%20do%20so.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%2C%3C%2FP%3E%0A%3CP%3EEhren%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-102290%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-102290%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EWe've%20been%20suffering%20from%20this%20problem%20for%20months%20and%20trying%20to%20get%20MS%20attention%20-%20maybe%20in%20the%20wrong%20places%20%3A-(.%3C%2FP%3E%3CP%3Esee%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fexcel.uservoice.com%2Fforums%2F304921-excel-for-windows-desktop-application%2Fsuggestions%2F20166799-provide-more-diagnostics-for-the-data-from-web-p%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fexcel.uservoice.com%2Fforums%2F304921-excel-for-windows-desktop-application%2Fsuggestions%2F20166799-provide-more-diagnostics-for-the-data-from-web-p%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20latest%20response%20there%20shows%20my%20frustration%20and%20it%20was%20only%20through%20examination%20of%20the%20user-agent%20heder%20that%20Excel%20supplied%20that%20I%20found%20a%20link%20to%20this%20tech%20community%20and%20I%20was%20going%20to%20post%20a%20new%20thread%20before%20I%20found%20this%20one.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20one%20extent%2C%20I%20am%20glad%20we're%20not%20the%20only%20ones%20suffering%20-%20it%20might%20get%20some%20attention%20now.%3C%2FP%3E%3CP%3EOn%20the%20other%20hand%2C%20I'm%20not%20holding%20my%20breath%20until%20I%20can%20see%20that%20someone%20at%20Microsoft%20has%20read%20and%20understood%20the%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20tips%20will%20be%20very%20much%20welcome.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3ETim%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-100748%22%20slang%3D%22en-US%22%3EUnable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-100748%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20tried%20to%20connect%20to%2020%2B%20websites%20that%20require%20sign-in%20credentials%20using%20Power%20Query%20without%20success.%20%26nbsp%3BI%20am%20able%20to%20login%20using%20Chrome%20so%20the%20credentials%20are%20correct.%20%26nbsp%3BThe%20error%20I%20receive%20is%20below.%20%26nbsp%3BI%20have%20clicked%20Edit%20Credentials%20and%20re-entered%20the%20creds%2C%20only%20to%20get%20the%20same%20error.%20%26nbsp%3BI%20have%20cleared%20the%20permissions%20in%20Power%20Query%20and%20re-done%20numerous%20times%20without%20success.%20%26nbsp%3BAlso%2C%20I'm%20certain%20I%20have%20used%20the%20feature%20successfully%20around%20a%20year%20ago.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20a%20setting%20in%20Power%20Query%20that%20enables%20connecting%20with%20credentials%3F%20%26nbsp%3BAny%20other%20ideas%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20367px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F19195i22EED697F7E753CB%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22edit%20credentials.png%22%20title%3D%22edit%20credentials.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-100748%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EBI%20%26amp%3B%20Data%20Analytics%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENeed%20Help%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-880862%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-880862%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F74289%22%20target%3D%22_blank%22%3E%40Toynk%20Accounting%3C%2FA%3EDo%20you%20have%20updates%20on%20this%20issue%3F%20I%20am%20currently%20facing%20same%20problem.%20But%20I%20find%20it%20a%20bit%20weird%20as%20it%20was%20working%20fine%20in%20my%20old%20laptop.%20I%20just%20posted%20my%20case%20few%20hours%20back.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FExcel%2FExcel-Query-From-Web-Old-laptop-OK-new-PC-not-OK%2Fm-p%2F880612%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FExcel%2FExcel-Query-From-Web-Old-laptop-OK-new-PC-not-OK%2Fm-p%2F880612%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-880883%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-880883%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F416741%22%20target%3D%22_blank%22%3E%40lealpermalino%3C%2FA%3E%26nbsp%3BI%20thought%20I'd%20posted%20my%20workaround%2C%20but%20maybe%20not%20here.%3C%2FP%3E%3CP%3EBriefly%3A%20it%20won't%20work%20with%20this%20new%20style%2C%20you%20have%20to%20re-enable%20the%20legacy%20data%20wizard%20and%20use%20that.%3C%2FP%3E%3CP%3EThis%20does%20still%20work%20-%20I%20used%20it%20last%20week.%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.office.com%2Fen-gb%2Farticle%2Fdata-import-and-analysis-options-3ea52160-08bc-45ac-acd9-bc4a11bcc2a2%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.office.com%2Fen-gb%2Farticle%2Fdata-import-and-analysis-options-3ea52160-08bc-45ac-acd9-bc4a11bcc2a2%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-881232%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-881232%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60810%22%20target%3D%22_blank%22%3E%40Tim%20Scott%3C%2FA%3E%26nbsp%3BTried%20to%20enable%20legacy%20data%20wizard%20but%20still%20didn't%20work.%20I%20also%20tried%20to%20use%20Power%20BI%20and%20gave%20me%20save%20result.%20New%20PC%20unable%20to%20fetch%20other%20tables.%20Is%20there%20a%20special%20data%20connector%20microsoft%20uses%20or%20it%20is%20really%20an%20issue%20with%20credentials%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBtw%2C%20Old%20laptop%20OS%20is%20Windows%2010%20Home%2C%20new%20PC%20OS%20is%20Windows%2010%20PRO.%20Does%20this%20affects%20Excel%2FPowerBI%20web%20data%20scraping%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-881237%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-881237%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F416741%22%20target%3D%22_blank%22%3E%40lealpermalino%3C%2FA%3E%26nbsp%3BFrom%20what%20I%20gathered%2C%20the%20new%20method%20did%20not%20handle%20authentication%20and%20the%20legacy%20wizards%20behave%20in%20the%20way%20they%20used%20to.%20At%20the%20risk%20of%20making%20a%20silly%20point%2C%20you%20did%20go%20to%20the%20legacy%20wizards%20option%20on%20the%20menu%2C%20not%20the%20option%20which%20now%20launches%20the%20new%20method%2C%20didn't%20you%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-881307%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-881307%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60810%22%20target%3D%22_blank%22%3E%40Tim%20Scott%3C%2FA%3E%26nbsp%3BI%20went%20to%20Excel%20Options%20%26gt%3B%26gt%3B%20Data%20%26gt%3B%26gt%3B%20Show%20legacy%20data%20import%20wizards%3C%2FP%3E%3CP%3EHope%20I%20did%20get%20you%20correctly.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20820px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F134004i83A9137888DCCF6D%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Excel%20-%20New_PC_Legacy.PNG%22%20title%3D%22Excel%20-%20New_PC_Legacy.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EJust%20for%20reference%2C%20below%20are%20Navigator%20snapshot%20using%20Power%20BI%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20879px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F134005i1CC0870B2A69744E%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22PBI%20-%20New_PC.PNG%22%20title%3D%22PBI%20-%20New_PC.PNG%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3EPBI_NewPC%3C%2FSPAN%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20907px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F134007i2F7F7B86A92A63DA%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22PBI%20-%20old%20laptop.PNG%22%20title%3D%22PBI%20-%20old%20laptop.PNG%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3EPBI_OldLaptop%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-881320%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-881320%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F416741%22%20target%3D%22_blank%22%3E%40lealpermalino%3C%2FA%3E%26nbsp%3Bfirst%20of%20all%2C%20it%20looks%20like%20the%20query%20on%20your%20old%20PC%20hasn't%20been%20refreshed%20in%20months.%26nbsp%3B%20From%20the%20Query%20Editor%2C%20click%20on%20REFRESH%20ALL%20and%20see%20if%20it%20still%20works.%26nbsp%3B%20If%20it%20does%20work%2C%20click%20on%20the%20Web%20View%20tab%20and%20post%20a%20screen%20shot%20of%20both%20PC's%20(redacting%20any%20sensitive%20info%20of%20course).%26nbsp%3B%20Lastly%2C%20click%20on%20Data%20Source%20Settings%20on%20the%20Main%20tab%20in%20Query%20Editor%20and%20then%20Edit%20Credentials.%26nbsp%3B%20See%20how%20the%20old%20one%20is%20set-up%20compared%20to%20the%20new%20PC.%26nbsp%3B%20I'm%20not%20convinced%20your%20problem%20is%20authentication%20or%20that%20your%20problem%20doesn't%20exist%20on%20the%20old%20PC.%26nbsp%3B%20This%20will%20prove%20or%20disprove%2C%20I%20think.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60810%22%20target%3D%22_blank%22%3E%40Tim%20Scott%3C%2FA%3E's%20legacy%20wizard%20suggestions%20are%20not%20at%20all%20what%20you're%20looking%20for.%26nbsp%3B%20the%20legacy%20scrape%20is%20far%20inferior%20and%20you%20old%20PC%20was%20not%20using%20legacy.%26nbsp%3B%20Not%20sure%20why%20it's%20even%20being%20suggested.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20answer%20your%20question%20to%20me%2C%20I%20did%20figure%20this%20out%20-%20somehow.%26nbsp%3B%20Can't%20recall%20exactly.%26nbsp%3B%20But%20it%20had%20something%20to%20do%20with%20typing%20my%20password%20into%20the%20API%20credentials%2C%20I%20think.%26nbsp%3B%20I%20can't%20quite%20recall%20but%20it%20wasn't%20an%20obvious%20move.%26nbsp%3B%20After%202%20years%20with%20no%20answer%2C%20I%20just%20started%20trying%20things%20and%20it%20worked.%26nbsp%3B%20Did%20it%20for%20a%20few%20other%20sites%2C%20didn't%20write%20it%20down%2C%20now%20I%20can't%20remember.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-881409%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-881409%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F74289%22%20target%3D%22_blank%22%3E%40Toynk%20Accounting%3C%2FA%3E%26nbsp%3BI%20just%20click%20REFRESH%20ALL%20in%20old%20PC%20and%20it%20is%20still%20working.%26nbsp%3B%3C%2FP%3E%3CP%3EBelow%20screenshots%20of%20each%20Navigator%20Web%20View%20(Seems%20like%20Internet%20Explorer%20is%20causing%20the%20error%3F)%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20873px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F134019i7AF992BA760FFA8F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22New_PC%20-%20WebView.PNG%22%20title%3D%22New_PC%20-%20WebView.PNG%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3ENewPC_WebView%3C%2FSPAN%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20876px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F134020iA69CFED0415FFD0D%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22old%20laptop_WebView.PNG%22%20title%3D%22old%20laptop_WebView.PNG%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3EOldPC_WebView%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegarding%20Data%20Source%20Setting%2C%20both%20are%20same%20and%20was%20reference%20to%20old%20PC%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-881431%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-881431%22%20slang%3D%22en-US%22%3E%3CP%3EWell%20-%20the%20legacy%20wizard%20solved%20my%20problem.%20If%20that's%20not%20the%20answer%2C%20either%20Microsoft%20have%20changed%20something%20in%20two%20years%20or%20it's%20a%20different%20problem.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-881457%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-881457%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F416741%22%20target%3D%22_blank%22%3E%40lealpermalino%3C%2FA%3E%26nbsp%3Binteresting.%26nbsp%3B%20I%20guess%20try%20and%20turn%20off%20the%20Internet%20Compatibility%20settings.%26nbsp%3B%20Otherwise%2C%20I'm%20a%20at%20a%20loss.%20Sorry%20can't%20be%20of%20more%20help%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-881526%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-881526%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F74289%22%20target%3D%22_blank%22%3E%40Toynk%20Accounting%3C%2FA%3E%26nbsp%3Bsadly%20that%20didn't%20work%20as%20well.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20remember%20in%20the%20past%20when%20I%20was%20working%20in%20the%20old%20PC%20for%20the%20same%20thing%2C%20I%20was%20able%20to%20enter%20credentials%20(Username%20%26amp%3B%20Password)%2C%20and%20after%20that%2C%20query%20shows%20all%20the%20tables%20I%20needed%20(that%20was%20Aug-Sept%202018).%20I%20really%20do%20not%20understand%20why%20credentials%20entry%20are%20currently%20not%20working%20properly.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-883131%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-883131%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F416741%22%20target%3D%22_blank%22%3E%40lealpermalino%3C%2FA%3E.%20Is%20it%20possible%20that%20your%20old%20PC%20is%20using%20the%20MSI%20version%20of%20PBIDesktop%2C%20and%20your%20new%20PC%20is%20using%20the%20Microsoft%20Store%20version%3F%20Are%20they%20running%20the%20same%20numeric%20version%20of%20PBIDesktop%20as%20well%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EEhren%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-883441%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-883441%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F76100%22%20target%3D%22_blank%22%3E%40Ehren%20von%20Lehe%3C%2FA%3E%26nbsp%3BYes%2C%20new%20PC%20PBI%20was%20from%20Microsoft%20store.%20I%20re-install%20PBI%20using%20the%20installer%2C%20and%20now%20it%20is%20able%20to%20get%20the%20table%2Fs.%20Though%20still%20confused%20because%20credentials%20are%20still%20invalid%2C%20but%20when%20I%20selected%20anonymous%2C%20it%20worked...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOld%20PC%20has%20Aug2019%20version%2C%20new%20PC%20has%20Sept2019%20version%20(not%20sure%20if%20this%20is%20the%20numeric%20versions%20you%20were%20asking..)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20think%2C%20it%20is%20the%20installer%20versions%20solved%20the%20issues.%20Thank%20you%20very%20much%20for%20this.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegarding%20EXCEL%20query%2C%20it%20is%20also%20now%20working...%20I%20didn't%20change%20any%20settings.%20I%20just%20tried%20if%20the%20other%20option%20for%20%22From%20Web%22%20function%20under%20%22Get%20Data%26gt%3B%26gt%3BFrom%20other%20sources%26gt%3B%26gt%3BFrom%20Web%22%2C%20and%20fortunately%20succeeded%20(not%20sure%20if%20this%20was%20really%20the%20solution...).%20On%20this%20one%2C%20I%20used%20credentials%20and%20was%20accepted.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20All%20for%20your%20help...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-883466%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Connect%20to%20Web%20Source%20With%20Credentials%20in%20Power%20Query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-883466%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F416741%22%20target%3D%22_blank%22%3E%40lealpermalino%3C%2FA%3E%26nbsp%3BGreat.%20The%20MSI%20version%20overrides%20a%20few%20Internet%20Explorer%20settings%20(which%20is%20what%20Web.Page%20uses%20behind%20the%20scenes)%2C%20and%20the%20store%20version%20isn't%20(yet)%20able%20to%20override%20those%20settings.%20These%20settings%20must%20be%20what%20allows%20this%20particular%20page%20to%20work%20for%20you.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EEhren%3C%2FP%3E%3C%2FLINGO-BODY%3E
Toynk Accounting
New Contributor

I have tried to connect to 20+ websites that require sign-in credentials using Power Query without success.  I am able to login using Chrome so the credentials are correct.  The error I receive is below.  I have clicked Edit Credentials and re-entered the creds, only to get the same error.  I have cleared the permissions in Power Query and re-done numerous times without success.  Also, I'm certain I have used the feature successfully around a year ago.

 

Is there a setting in Power Query that enables connecting with credentials?  Any other ideas?

 

edit credentials.png

17 Replies

Hi,

We've been suffering from this problem for months and trying to get MS attention - maybe in the wrong places :-(.

see: https://excel.uservoice.com/forums/304921-excel-for-windows-desktop-application/suggestions/20166799...

 

My latest response there shows my frustration and it was only through examination of the user-agent heder that Excel supplied that I found a link to this tech community and I was going to post a new thread before I found this one.

 

To one extent, I am glad we're not the only ones suffering - it might get some attention now.

On the other hand, I'm not holding my breath until I can see that someone at Microsoft has read and understood the problem.

 

Any tips will be very much welcome.

 

Thanks,

Tim

Tim, would you mind sending more details of your issue (along with a Fiddler trace, if possible) to pq2fb@microsoft.com? Please mention my name when you do so.

 

Thanks,

Ehren

Thank you for following up. I have emailed some details FAO: Ehren.

@Toynk AccountingDo you have updates on this issue? I am currently facing same problem. But I find it a bit weird as it was working fine in my old laptop. I just posted my case few hours back.

 

https://techcommunity.microsoft.com/t5/Excel/Excel-Query-From-Web-Old-laptop-OK-new-PC-not-OK/m-p/88...

 

@lealpermalino I thought I'd posted my workaround, but maybe not here.

Briefly: it won't work with this new style, you have to re-enable the legacy data wizard and use that.

This does still work - I used it last week.

https://support.office.com/en-gb/article/data-import-and-analysis-options-3ea52160-08bc-45ac-acd9-bc...

@Tim Scott Tried to enable legacy data wizard but still didn't work. I also tried to use Power BI and gave me save result. New PC unable to fetch other tables. Is there a special data connector microsoft uses or it is really an issue with credentials?

 

Btw, Old laptop OS is Windows 10 Home, new PC OS is Windows 10 PRO. Does this affects Excel/PowerBI web data scraping?

@lealpermalino From what I gathered, the new method did not handle authentication and the legacy wizards behave in the way they used to. At the risk of making a silly point, you did go to the legacy wizards option on the menu, not the option which now launches the new method, didn't you?

@Tim Scott I went to Excel Options >> Data >> Show legacy data import wizards

Hope I did get you correctly.

Excel - New_PC_Legacy.PNG

 

Just for reference, below are Navigator snapshot using Power BI

PBI - New_PC.PNGPBI_NewPCPBI - old laptop.PNGPBI_OldLaptop

@lealpermalino first of all, it looks like the query on your old PC hasn't been refreshed in months.  From the Query Editor, click on REFRESH ALL and see if it still works.  If it does work, click on the Web View tab and post a screen shot of both PC's (redacting any sensitive info of course).  Lastly, click on Data Source Settings on the Main tab in Query Editor and then Edit Credentials.  See how the old one is set-up compared to the new PC.  I'm not convinced your problem is authentication or that your problem doesn't exist on the old PC.  This will prove or disprove, I think.

 

@Tim Scott's legacy wizard suggestions are not at all what you're looking for.  the legacy scrape is far inferior and you old PC was not using legacy.  Not sure why it's even being suggested.

 

To answer your question to me, I did figure this out - somehow.  Can't recall exactly.  But it had something to do with typing my password into the API credentials, I think.  I can't quite recall but it wasn't an obvious move.  After 2 years with no answer, I just started trying things and it worked.  Did it for a few other sites, didn't write it down, now I can't remember.

@Toynk Accounting I just click REFRESH ALL in old PC and it is still working. 

Below screenshots of each Navigator Web View (Seems like Internet Explorer is causing the error?)

New_PC - WebView.PNGNewPC_WebViewold laptop_WebView.PNGOldPC_WebView

 

Regarding Data Source Setting, both are same and was reference to old PC

Well - the legacy wizard solved my problem. If that's not the answer, either Microsoft have changed something in two years or it's a different problem.

@lealpermalino interesting.  I guess try and turn off the Internet Compatibility settings.  Otherwise, I'm a at a loss. Sorry can't be of more help

@Toynk Accounting sadly that didn't work as well. 

I remember in the past when I was working in the old PC for the same thing, I was able to enter credentials (Username & Password), and after that, query shows all the tables I needed (that was Aug-Sept 2018). I really do not understand why credentials entry are currently not working properly. 

Hi @lealpermalino. Is it possible that your old PC is using the MSI version of PBIDesktop, and your new PC is using the Microsoft Store version? Are they running the same numeric version of PBIDesktop as well?

 

Ehren

@Ehren von Lehe Yes, new PC PBI was from Microsoft store. I re-install PBI using the installer, and now it is able to get the table/s. Though still confused because credentials are still invalid, but when I selected anonymous, it worked...

 

Old PC has Aug2019 version, new PC has Sept2019 version (not sure if this is the numeric versions you were asking..)

 

I think, it is the installer versions solved the issues. Thank you very much for this.

 

Regarding EXCEL query, it is also now working... I didn't change any settings. I just tried if the other option for "From Web" function under "Get Data>>From other sources>>From Web", and fortunately succeeded (not sure if this was really the solution...). On this one, I used credentials and was accepted.

 

Thank you All for your help...

 

@lealpermalino Great. The MSI version overrides a few Internet Explorer settings (which is what Web.Page uses behind the scenes), and the store version isn't (yet) able to override those settings. These settings must be what allows this particular page to work for you.

 

Ehren

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies