Home

Result of a formula not considered as a value

%3CLINGO-SUB%20id%3D%22lingo-sub-719540%22%20slang%3D%22en-US%22%3EResult%20of%20a%20formula%20not%20considered%20as%20a%20value%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-719540%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20everyone%2C%3C%2FP%3E%3CP%3EI%20would%20like%20to%20use%20the%20following%20formula%20(1)%3A%3C%2FP%3E%3CP%3E%3DSI(%5B%40%5BUnit%20Sold%5D%5D%26gt%3B%5B%40Ecom%5D%3B%5B%40Ecom%5D%3B%5B%40%5BUnit%20Sold%5D%5D)%3C%2FP%3E%3CP%3Eknowing%20that%26nbsp%3B%5B%40%5BUnit%20Sold%5D%5D%20has%20the%20following%20formula%20(2)%3A%3C%2FP%3E%3CP%3E%3DSIERREUR(RECHERCHEV(%24B10%3B'Unit%20Sold%20W1-W25'!%24A%241%3A%24M%244932%3B3%3BFAUX)%3B%220%22)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIdeally%20I%20wanted%20the%20formula%201%20to%20understand%20the%20value%200%20of%20the%20formula%202%20when%20it%20is%2C%20but%20it%20doesn't%20So%20I%20have%20my%20high%20value%20showing%20instead%20of%20the%200.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20could%20copy%20past%26nbsp%3B%5BUnit%20Sold%5D%5D%20as%20value%2C%20but%20Im%20trying%20to%20build%20an%20automated%20file%20so%20I%20would%20like%20to%20find%20another%20solution%20and%20keep%20the%20formula%202%20in%20my%20cells%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance%20!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-719540%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-719654%22%20slang%3D%22en-US%22%3ERe%3A%20Result%20of%20a%20formula%20not%20considered%20as%20a%20value%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-719654%22%20slang%3D%22en-US%22%3EI%20think%20you%20should%20change%20the%20%220%22%20in%20your%20SIERREUR%20formula%20to%20just%200%20(no%20quotes).%3C%2FLINGO-BODY%3E
marionatdjian
Occasional Contributor

Hi everyone,

I would like to use the following formula (1):

=SI([@[Unit Sold]]>[@Ecom];[@Ecom];[@[Unit Sold]])

knowing that [@[Unit Sold]] has the following formula (2):

=SIERREUR(RECHERCHEV($B10;'Unit Sold W1-W25'!$A$1:$M$4932;3;FAUX);"0")

 

Ideally I wanted the formula 1 to understand the value 0 of the formula 2 when it is, but it doesn't So I have my high value showing instead of the 0.

 

I could copy past [Unit Sold]] as value, but Im trying to build an automated file so I would like to find another solution and keep the formula 2 in my cells

 

Thanks in advance !

1 Reply
I think you should change the "0" in your SIERREUR formula to just 0 (no quotes).
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
16 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
11 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
*Updated 9/3* Syncing in Microsoft Edge Preview Channels
Elliot Kirk in Articles on
217 Replies