Home

Formula linking to itself after upgrading

Toby Pitblado
New Contributor

Hi,

 

If anyone can help I would be most grateful.

 

I am currently using a spreadsheet that links to a Vision Cache table which is in turn linked to SAP 9.0.  The Cache Table link is located in:

C:\Program Files\Infor\Query and Analysis\Vision Cache.xla

 

The system is being upgraded to Windows 10 and SAP 9.3.  The new Vision Cache Table link is found in:

C:\Program Files (x86)\Infor\Query and Analysis\LsAgXLB.xla

 

When I open the document on the Windows 10 machine the cell shows "?NAME", and the formula is looking for the old link:

='C:\Program Files\Infor\Query and Analysis\Vision Cache.xla'!AG_VICSUM("SAP P&L 2019",1,$C$4,$C38,$C$1)*-1

 

If I find and replace the file path up to the start of the correct formula, it works.  However, when I save and close the document, then reopen it, I get a following trying to link the file name of the document itself, formula:

='Management Ac_Master1A_2018-19_2001.xlsm'!AG_VICSUM("SAP P&L 2019",1,$C$4,$C38,$C$1)*-1

 

This causes the "?NAME" to appear in the cell again.  I can find and replace it and the formulas work again.  The problem is it keeps on coming back and I don't know how to stop it from reappearing.

 

Any suggestions would be greatly appreciated?

 

Cheers,

Toby

1 Reply

Solved it myself, woohoo.

 

For anyone else that this happens to, how I solved it:

 

Removed the macros (copied to another workbook), saved it as an xls file type, closed and reopened, added the macros back in and resaved as xlsm.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
38 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies