Home

Data Slicers not working properly with Excel 2016

%3CLINGO-SUB%20id%3D%22lingo-sub-548740%22%20slang%3D%22en-US%22%3EData%20Slicers%20not%20working%20properly%20with%20Excel%202016%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-548740%22%20slang%3D%22en-US%22%3E%3CP%3EDear%20Community%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%20class%3D%22post-text%22%3E%3CP%3EI%20have%20created%20a%20Dashboard%20with%20Excel%20365%20(V%2016.0.11601)%20using%20data%20from%20an%20SQL%20Server%2C%20via%20Power%20Query%20and%20Pivots%20%2F%20Charts.%20The%20Pivots%20and%20Charts%20are%20linked%20with%20data%20slicers%20in%20order%20to%20filter%20data.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20idea%20is%2C%20that%20the%20user%20does%20not%20need%20to%20connect%20to%20the%20SQL%20Server%20but%20uses%20directly%20the%20data%20from%20Power%20Pivot.%20With%20my%20Excel%20versions%20the%20slicers%20work%20as%20expected.%3C%2FP%3E%3CP%3ECustomers%20which%20are%20using%20Office%202016%20Professional%20Plus%20(V%2016.0.4738)%20complained%2C%20that%20the%20slicers%20and%20pivot-filters%20do%20not%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20were%20able%20to%20reproduce%20the%20issue%20with%20Excel%202016%3A%20If%20we%20click%20on%20a%20slicer%20element%20or%20select%20a%20filter-value%20in%20a%20pivot-table%2C%20excel%20is%20shortly%20%22calculating%22%20but%20then%20the%20filter%20%2F%20slicer%20gets%20reset%20and%20the%20data%20is%20not%20filtered%20or%20refreshed.%20No%20error%20is%20shown.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20has%20an%20idea%2C%20what's%20the%20reason%20of%20this%20behaviour%3F%3C%2FP%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-548740%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPower%20Pivot%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPower%20Query%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESlicer%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-868233%22%20slang%3D%22en-US%22%3ERe%3A%20Data%20Slicers%20not%20working%20properly%20with%20Excel%202016%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-868233%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F338225%22%20target%3D%22_blank%22%3E%40LordRA%3C%2FA%3E%26nbsp%3BI'm%20having%20the%20same%20problem.%20Were%20you%20able%20to%20resolve%20the%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-869744%22%20slang%3D%22en-US%22%3ERe%3A%20Data%20Slicers%20not%20working%20properly%20with%20Excel%202016%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-869744%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F412705%22%20target%3D%22_blank%22%3E%40Aswa09%3C%2FA%3EYes%2C%20i%20solved%20it.%20The%20reason%20of%20this%20behaviour%20was%20a%20Measure%20I%20used%20in%20my%20Pivots%2C%20which%20returned%20an%20error%20in%20Office%202016%2C%20but%20not%20in%20Office%20365.%20Turns%20out%2C%20there%20was%20slight%20change%20of%20the%20DAX-Formula%20logic%20between%20the%20two%20Office%20versions.%20Once%20I%20found%20a%20way%20the%20DAX-Formula%20worked%20in%20both%20versions%2C%20the%20Data%20Slicers%20worked%20like%20expected.%3C%2FP%3E%3CP%3EThe%20DAX-Formula%20which%20caused%20the%20error%20in%20my%20case%20was%3A%3C%2FP%3E%3CP%3E%3DIF(%5BPERFORMANCE%5D%26gt%3B%3D0%3B%5BPERFORMANCE%5D%3B%22%22)%3C%2FP%3E%3CP%3ESince%20the%20field%20%22%5BPERFORMANCE%5D%22%20was%20a%20number%2C%20and%20my%20IF-Formula%20could%20return%20either%20a%20number%20or%20a%20string%2C%20Office%202016%20complained%20about%20data-type%20mismatch%20(Office%20365%20doesn't%20seem%20to%20bother).%3C%2FP%3E%3CP%3ETherefore%20I%20changed%20to%20formula%20to%3A%3C%2FP%3E%3CP%3E%3DIF(%5BPERFORMANCE%5D%26gt%3B%3D0%3B%5BPERFORMANCE%5D%3BBLANK())%3C%2FP%3E%3CP%3EThis%20way%20the%20formula%20works%20in%20both%20Excel%20versions.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers%2C%20LordRA%3C%2FP%3E%3C%2FLINGO-BODY%3E
LordRA
New Contributor

Dear Community

 

I have created a Dashboard with Excel 365 (V 16.0.11601) using data from an SQL Server, via Power Query and Pivots / Charts. The Pivots and Charts are linked with data slicers in order to filter data.

 

The idea is, that the user does not need to connect to the SQL Server but uses directly the data from Power Pivot. With my Excel versions the slicers work as expected.

Customers which are using Office 2016 Professional Plus (V 16.0.4738) complained, that the slicers and pivot-filters do not work.

 

We were able to reproduce the issue with Excel 2016: If we click on a slicer element or select a filter-value in a pivot-table, excel is shortly "calculating" but then the filter / slicer gets reset and the data is not filtered or refreshed. No error is shown.

 

Anyone has an idea, what's the reason of this behaviour?

2 Replies

@LordRA I'm having the same problem. Were you able to resolve the issue?

@Aswa09Yes, i solved it. The reason of this behaviour was a Measure I used in my Pivots, which returned an error in Office 2016, but not in Office 365. Turns out, there was slight change of the DAX-Formula logic between the two Office versions. Once I found a way the DAX-Formula worked in both versions, the Data Slicers worked like expected.

The DAX-Formula which caused the error in my case was:

=IF([PERFORMANCE]>=0;[PERFORMANCE];"")

Since the field "[PERFORMANCE]" was a number, and my IF-Formula could return either a number or a string, Office 2016 complained about data-type mismatch (Office 365 doesn't seem to bother).

Therefore I changed to formula to:

=IF([PERFORMANCE]>=0;[PERFORMANCE];BLANK())

This way the formula works in both Excel versions.

 

Cheers, LordRA

Related Conversations
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
PacketMon Components are not loading in WAC 1909
HotCakeX in Windows Admin Center on
2 Replies