Home

When New Edge Dev or Canary set as Default Browser, links from UWP Apps fail to open

%3CLINGO-SUB%20id%3D%22lingo-sub-430719%22%20slang%3D%22en-US%22%3EWhen%20New%20Edge%20Dev%20or%20Canary%20set%20as%20Default%20Browser%2C%20links%20from%20UWP%20Apps%20fail%20to%20open%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-430719%22%20slang%3D%22en-US%22%3E%3CP%3EAll%20throw%20some%20version%20of%20%22Unable%20to%20Open%22%20dialog%20box.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUsing%20old%20Edge%20or%20Chrome%20works%20correctly.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-430790%22%20slang%3D%22en-US%22%3ERe%3A%20When%20New%20Edge%20Dev%20or%20Canary%20set%20as%20Default%20Browser%2C%20links%20from%20UWP%20Apps%20fail%20to%20open%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-430790%22%20slang%3D%22en-US%22%3EThanks.%20Typically%20this%20can%20be%20resolved%20by%20uninstalling%20and%20reinstalling.%20Sorry%20for%20the%20hassle.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-431121%22%20slang%3D%22en-US%22%3ERe%3A%20When%20New%20Edge%20Dev%20or%20Canary%20set%20as%20Default%20Browser%2C%20links%20from%20UWP%20Apps%20fail%20to%20open%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-431121%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317619%22%20target%3D%22_blank%22%3E%40ericlaw%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETried%20uninstalling%20and%20reinstalling%20both%20Canary%20and%20Dev%20and%20same%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERunning%20on%20Win%2010%201903%2F19H1%2FMay%20whatever-it's-called-today.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-431178%22%20slang%3D%22en-US%22%3ERe%3A%20When%20New%20Edge%20Dev%20or%20Canary%20set%20as%20Default%20Browser%2C%20links%20from%20UWP%20Apps%20fail%20to%20open%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-431178%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F316812%22%20target%3D%22_blank%22%3E%40edspar%3C%2FA%3E%26nbsp%3BInteresting!%20Could%20you%20share%20a%20screenshot%20or%20the%20full%20text%20of%20the%20box%3F%20Does%20opening%20the%20browser%20work%20otherwise%20(e.g.%20from%20Win%2BR%2C%20%3CA%20href%3D%22https%3A%2F%2Fexample.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fexample.com%3C%2FA%3E%20)%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-431392%22%20slang%3D%22en-US%22%3ERe%3A%20When%20New%20Edge%20Dev%20or%20Canary%20set%20as%20Default%20Browser%2C%20links%20from%20UWP%20Apps%20fail%20to%20open%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-431392%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317619%22%20target%3D%22_blank%22%3E%40ericlaw%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUpdated%3A%20worked%20after%20reboot%20with%20Dev%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E
edspar
Occasional Contributor

All throw some version of "Unable to Open" dialog box.

 

Using old Edge or Chrome works correctly.

4 Replies
Thanks. Typically this can be resolved by uninstalling and reinstalling. Sorry for the hassle.

Thanks @ericlaw 

 

Tried uninstalling and reinstalling both Canary and Dev and same issue.

 

Running on Win 10 1903/19H1/May whatever-it's-called-today.

 

 

@edspar Interesting! Could you share a screenshot or the full text of the box? Does opening the browser work otherwise (e.g. from Win+R, https://example.com )?

 

@ericlaw 

Updated: worked after reboot with Dev

 

Thanks for the help.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies