Home

Unable to install Edge with a NTLM proxy

%3CLINGO-SUB%20id%3D%22lingo-sub-416148%22%20slang%3D%22en-US%22%3EUnable%20to%20install%20Edge%20with%20a%20NTLM%20proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-416148%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20am%20unable%20to%20install%20the%20Edge%20(Dev)%20version%20as%20it%20seems%20the%20installer%20does%20not%20play%20nicely%20with%20the%20NTLM%20proxy%20that%20is%20in%20place.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20using%20Fiddler%20to%20pre-authenticate%20but%20that%20makes%20no%20difference.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20736px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F106347i6CDD9D91EC324A81%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-04-09%20121435.png%22%20title%3D%22Annotation%202019-04-09%20121435.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20suggestions%20at%20all%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-421609%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20install%20Edge%20with%20a%20NTLM%20proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-421609%22%20slang%3D%22en-US%22%3EI%20will%20ask%20our%20setup%20specialists%20for%20you.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-443538%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20install%20Edge%20with%20a%20NTLM%20proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-443538%22%20slang%3D%22en-US%22%3ECool%20thanks.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20did%20get%20ti%20installed%20but%20I%20had%20to%20use%20a%20different%20network%20(no%20proxy).%3CBR%20%2F%3E%3CBR%20%2F%3EReturning%20to%20the%20proxied%20network%20means%20I%20can%20no%20longer%20update%20it.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-451298%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20install%20Edge%20with%20a%20NTLM%20proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-451298%22%20slang%3D%22en-US%22%3E%3CP%3EProxy%20support%20with%20Omaha%20(the%20Chromium%20updater)%20is%20questionable.%26nbsp%3B%20We%20found%20what%20could%20be%20a%20work%20around%20for%20you%20when%20looking%20through%20an%20old%20Chrome%20forum%2C%20it%20might%20help%20you%20get%20Edge%20working%20from%20behind%20your%20proxy.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3E%E2%80%9C%3C%2FI%3E%3CI%3E%3CSPAN%3EFor%20Microsoft%20EdgeUpdate%20to%20work%20via%26nbsp%3B%3CSPAN%20class%3D%22mark7llayq757%22%20data-markjs%3D%22true%22%20data-ogac%3D%22%22%20data-ogab%3D%22%22%20data-ogsc%3D%22%22%20data-ogsb%3D%22%22%3Eproxy%3C%2FSPAN%3E%2C%20you%20must%20allow%20Windows%20(Internet%20Explorer)%20and%20Microsoft%20Edge%20to%20save%20(remember)%20your%26nbsp%3B%3CSPAN%20class%3D%22mark7llayq757%22%20data-markjs%3D%22true%22%20data-ogac%3D%22%22%20data-ogab%3D%22%22%20data-ogsc%3D%22%22%20data-ogsb%3D%22%22%3Eproxy%3C%2FSPAN%3E%26nbsp%3Bcredential%20(login%20and%20password).%20You%20must%20do%20it%20in%20both%20places%3A%201)%20in%20the%20checkbox%20%22Remember%20password%22%20in%20_Internet%20Explorer_%26nbsp%3B%3CSPAN%20class%3D%22mark7llayq757%22%20data-markjs%3D%22true%22%20data-ogac%3D%22%22%20data-ogab%3D%22%22%20data-ogsc%3D%22%22%20data-ogsb%3D%22%22%3Eproxy%3C%2FSPAN%3E%26nbsp%3Bauthentication%20prompt%20window%20and%202)%20in%20Microsoft%20Edge%20during%20first%26nbsp%3B%3CSPAN%20class%3D%22mark7llayq757%22%20data-markjs%3D%22true%22%20data-ogac%3D%22%22%20data-ogab%3D%22%22%20data-ogsc%3D%22%22%20data-ogsb%3D%22%22%3Eproxy%3C%2FSPAN%3E%26nbsp%3Bauthentication%20(remember%20password%20in%20yellow%20top%20line%20of%20the%20window).%20If%20you%20already%20told%20Microsoft%20Edge%20NOT%20TO%20remember%26nbsp%3B%3CSPAN%20class%3D%22mark7llayq757%22%20data-markjs%3D%22true%22%20data-ogac%3D%22%22%20data-ogab%3D%22%22%20data-ogsc%3D%22%22%20data-ogsb%3D%22%22%3Eproxy%3C%2FSPAN%3E%26nbsp%3Bpassword%2C%20you%20should%20go%20to%20Microsoft%20Edge%20settings%20-%20password%20settings%20and%20delete%20you%26nbsp%3B%3CSPAN%20class%3D%22mark7llayq757%22%20data-markjs%3D%22true%22%20data-ogac%3D%22%22%20data-ogab%3D%22%22%20data-ogsc%3D%22%22%20data-ogsb%3D%22%22%3Eproxy%3C%2FSPAN%3E%26nbsp%3Baddress%20from%20the%20list%20of%20sites%2C%20for%20which%20Microsoft%20Edge%20should%20not%20remember%20passwords.%3C%2FSPAN%3E%3C%2FI%3E%3CI%3E%3CSPAN%3E%3CBR%20%2F%3E%26nbsp%3BYou%20should%20also%20disable%20getting%20automatic%26nbsp%3B%3CSPAN%20class%3D%22mark7llayq757%22%20data-markjs%3D%22true%22%20data-ogac%3D%22%22%20data-ogab%3D%22%22%20data-ogsc%3D%22%22%20data-ogsb%3D%22%22%3Eproxy%3C%2FSPAN%3E%26nbsp%3Bsettings%20in%20Internet%20Explorer%20network%20configuration%20window.%3CBR%20%2F%3EAfter%20that%20you%20should%20close%20Internet%20Explorer%2C%20close%20Microsoft%20Edge%20window%2C%20and%20in%20windows%20task%20manager%20kill%20all%20Microsoft%20Edge%20processes%20all%20Microsoft%20EdgeUpdate.%20When%20you%20start%20Microsoft%20Edge%20again%20automatic%20update%20should%20work%20fine.%E2%80%9D%3C%2FSPAN%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
AndyOfEngland
New Contributor

Hi,

I am unable to install the Edge (Dev) version as it seems the installer does not play nicely with the NTLM proxy that is in place.

 

I've tried using Fiddler to pre-authenticate but that makes no difference.

 

Annotation 2019-04-09 121435.png

 

Any suggestions at all?

 

Cheers

4 Replies
I will ask our setup specialists for you.
Cool thanks.

I did get ti installed but I had to use a different network (no proxy).

Returning to the proxied network means I can no longer update it.

Proxy support with Omaha (the Chromium updater) is questionable.  We found what could be a work around for you when looking through an old Chrome forum, it might help you get Edge working from behind your proxy.

 

For Microsoft EdgeUpdate to work via proxy, you must allow Windows (Internet Explorer) and Microsoft Edge to save (remember) your proxy credential (login and password). You must do it in both places: 1) in the checkbox "Remember password" in _Internet Explorer_ proxy authentication prompt window and 2) in Microsoft Edge during first proxy authentication (remember password in yellow top line of the window). If you already told Microsoft Edge NOT TO remember proxy password, you should go to Microsoft Edge settings - password settings and delete you proxy address from the list of sites, for which Microsoft Edge should not remember passwords.
 You should also disable getting automatic proxy settings in Internet Explorer network configuration window.
After that you should close Internet Explorer, close Microsoft Edge window, and in windows task manager kill all Microsoft Edge processes all Microsoft EdgeUpdate. When you start Microsoft Edge again automatic update should work fine.”

@Elliot Kirk 

Thanks for the update - sadly, as it's a NTLM proxy, there isn't generally a password prompt as it uses the Windows kerberos token to handle the authentication.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies