Home

Translate doesnt seem to work

David Williams
New Contributor

I tried using the built-in translate in build 75.0.139.4 doesnt consistently work.  About 50% of time it doesnt do anything other than the translate icon spins.  Steps to reproduce:

 

1. Go to: https://www.microsoftedgeinsider.com/en-us/welcome/update?channel=dev&version=75.0.139.4

2. Click on the translate icon in address bar and pick a language.

3. May translate.

4. If it translates choose a different language.

5. For me doesnt translate and just get spinning translate icon.

 

6 Replies

Hi @David Williams, thank you for reporting this issue.  I am not seeing this behavior, when I try the steps that you have listed.  Are there languages or network conditions that you find cause translation to fail more often than others?

@Elliot Kirk, no its not any particular language but it always happens on the second time I translate a page after I translate it.  For example:

 

1. Go to http://www.microsoft.com and comes up in English.

2. Click on translate icon and change to Dutch and it changes to Dutch.

3. Click on translate icon and change to German and the icon just spins.

 

If I try any language in step 3 it does the same thing.  

 

I am running this on Windows 10 Build 1809

This is on hardwired/ethernet network connection connected to internet using Gigabit fiber.

 

Are there any logs you would like me to send?

 

@David Williams, I have reached out to the team that is working on translation. When I hear back from them, I will let you know.  Thank you again for trying out these new features as we bring them online.

@Elliot Kirk, thank you.  Let me know if you need anything from me. 

Hey @David Williams, thank you for self-hosting and reporting this bug. The bug is now fixed. I just validated in a Canary build [76.0.147.0]. 

Request you to try on the latest Canary. The fix hasn't reached the dev build yet and should be there soon. 

@amitkun Sorry for delays for testing this, latest version seems to be working much better.  Thanks to you and the MSFT team for allowing users like me to part of the journey.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies