Home

Techcommunity website loading slower than on Old Edge

%3CLINGO-SUB%20id%3D%22lingo-sub-412159%22%20slang%3D%22en-US%22%3ETechcommunity%20website%20loading%20slower%20than%20on%20Old%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-412159%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20it's%20my%20first%20time%20using%20the%26nbsp%3BTechcommunity%20website%20and%20through%20some%20other%20threads%20I%20found%20out%20that%20it's%20common%20place%20for%20it%20to%20be%20running%20slowly%20however%20it%20doesn't%20look%20good%20when%20the%20website%20is%20loading%20pages%20slower%20than%20Old%20Edge%20was.%20I'm%20not%20sure%20if%20this%20is%20the%20fault%20of%20New%20Edge%20or%20the%20website%20but%20since%20all%20of%20us%20here%20will%20be%20spending%20a%20lot%20of%20time%20on%20the%20website%20it%20might%20be%20nicer%20as%20a%20problem%20fixed%20sooner%20rather%20than%20later.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-412209%22%20slang%3D%22en-US%22%3ERe%3A%20Techcommunity%20website%20loading%20slower%20than%20on%20Old%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-412209%22%20slang%3D%22en-US%22%3EAre%20you%20seeing%20a%20difference%20in%20speed%20between%20browsers%20today%2C%20or%20is%20it%20different%20from%20what%20you%20remember%20seeing%20on%20the%20current%20version%20of%20Edge%20so%20time%20ago%3F%20If%20the%20preview%20Edge%20is%20slower%20than%20the%20current%20version%20of%20edge%20on%20the%20same%20page%20at%20the%20same%20time%2C%20please%20let%20me%20know.%20Otherwise%2C%20I%20will%20pass%20the%20suggestion%20on%20to%20the%20Tech%20Community%20webmasters.%3CBR%20%2F%3EThanks%2C%3CBR%20%2F%3EElliot%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-412235%22%20slang%3D%22en-US%22%3ERe%3A%20Techcommunity%20website%20loading%20slower%20than%20on%20Old%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-412235%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F239638%22%20target%3D%22_blank%22%3E%40Elliot%20Kirk%3C%2FA%3E%26nbsp%3BYeah%20to%20be%20fair%20I%20tested%20the%20speeds%20at%20loading%20the%20same%20techcommunity%20page%20on%20both%20New%20and%20Old%20Edge%20at%20current%20release.%20Old%20Edge%20definitely%20take%20the%20lead%20consistently%20regardless%20of%20the%20quantity%20of%20content%20on%20the%20page.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Cameron_Bush
Contributor

So it's my first time using the Techcommunity website and through some other threads I found out that it's common place for it to be running slowly however it doesn't look good when the website is loading pages slower than Old Edge was. I'm not sure if this is the fault of New Edge or the website but since all of us here will be spending a lot of time on the website it might be nicer as a problem fixed sooner rather than later.

2 Replies
Are you seeing a difference in speed between browsers today, or is it different from what you remember seeing on the current version of Edge so time ago? If the preview Edge is slower than the current version of edge on the same page at the same time, please let me know. Otherwise, I will pass the suggestion on to the Tech Community webmasters.
Thanks,
Elliot

@Elliot Kirk Yeah to be fair I tested the speeds at loading the same techcommunity page on both New and Old Edge at current release. Old Edge definitely take the lead consistently regardless of the quantity of content on the page.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies