Home

Rendered Color Inaccuracies

%3CLINGO-SUB%20id%3D%22lingo-sub-720452%22%20slang%3D%22en-US%22%3ERendered%20Color%20Inaccuracies%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-720452%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20not%20sure%20if%20anyone%20has%20noticed%2C%20but%20colors%20are%20not%20being%20rendered%20accurately%20in%20Edge%20Chromium%20(%3CSPAN%3EVersion%2077.0.197.1%20(Official%20build)%20dev%20(64-bit))%3C%2FSPAN%3E.%20%3CA%20href%3D%22https%3A%2F%2Fi.imgur.com%2F2QqDyUY.png%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3EHere%20is%20a%20side-by-side%20(imgur)%3C%2FA%3E%20of%20Edge%20Chromium%20(left)%20and%20Chrome%20(right).%20From%20what%20I%20can%20tell%2C%20Chrome%20is%20extremely%20accurate%20in%20its%20color%20rendering.%20Edge%20Chromium%2C%20for%20some%20reason%2C%20not%20so%20much.%20Specifically%2C%20blues%20have%20a%20purple-ish%20tinge%20to%20them.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20HTML%20file%20used%20to%20test%20this%20is%20available%20for%20download%20%3CA%20href%3D%22https%3A%2F%2F1drv.ms%2Fu%2Fs!AmpRcIfIvYzWgZkTAT8hvQKtvJ2OKg%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehere%20from%20my%20OneDrive%3C%2FA%3E%20account%20(since%20.html%20isn't%20a%20valid%20file%20extension%20to%20upload%20here).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'd%20like%20to%20see%20this%20issue%20fixed%20before%20final%20release.%20The%20point%20of%20Edge%20Chromium%20was%20unification%2C%20not%26nbsp%3B%3CEM%3Eyet%20another%3C%2FEM%3E%20browser%20rendering%20engine%20to%20code%20for.%20In%20my%20opinion%2C%20this%20is%20a%20pretty%20large%20difference%20in%20color%20representation.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20don't%20believe%20this%20is%20just%20me%2C%20but%20if%20it%20is%20please%20let%20me%20know%20in%20the%20comments.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-721141%22%20slang%3D%22en-US%22%3ERe%3A%20Rendered%20Color%20Inaccuracies%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-721141%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F347890%22%20target%3D%22_blank%22%3E%40tc-at-work%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20have%20no%20doubt%20you%20are%20running%20into%20some%20color%20saturation%20issue.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20have%20tried%20to%20reproduce%20this%20issue%20with%20Canary%2C%20Dev%20and%20Chrome%20on%20a%20couple%20different%20machines%3C%2FP%3E%0A%3CP%3Ebut%20the%20colors%20seem%20almost%20identical%20on%20my%20side%20with%20all%20three%20browsers.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20style%3D%22width%3A%20594px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F120650iD4664B267B70FC6B%2Fimage-dimensions%2F594x404%3Fv%3D1.0%22%20width%3D%22594%22%20height%3D%22404%22%20alt%3D%22color%20test.PNG%22%20title%3D%22color%20test.PNG%22%20%2F%3E%3C%2FSPAN%3EWe%20are%20still%20in%20preview%20builds%20so%20we%20will%20for%20sure%20have%20browser%20functions%20fixed%2C%3C%2FP%3E%0A%3CP%3Eor%20improved%20before%20a%20final%20release.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20for%20taking%20the%20time%20to%20upload%20the%20test%20HTML%20and%20screenshot%2C%3C%2FP%3E%0A%3CP%3EFrank%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-721144%22%20slang%3D%22en-US%22%3ERe%3A%20Rendered%20Color%20Inaccuracies%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-721144%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F347890%22%20target%3D%22_blank%22%3E%40tc-at-work%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20it%20be%20a%20problem%20with%20Chrome%3F%20There%20is%20a%20setting%20force-color-profile.%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.faqforge.com%2Fwindows%2Ffixed-google-chrome-wrong-color-after-update%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.faqforge.com%2Fwindows%2Ffixed-google-chrome-wrong-color-after-update%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYou%20could%20try%20installing%20Firefox%20and%20see%20whether%20the%20problem%20is%20actually%20with%20edge%20or%20with%20chrome.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-722906%22%20slang%3D%22en-US%22%3ERe%3A%20Rendered%20Color%20Inaccuracies%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-722906%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F65328%22%20target%3D%22_blank%22%3E%40Daniel%20Niccoli%3C%2FA%3E%26nbsp%3BSo%20I%20checked%20to%20see%20if%20the%20color%20difference%20remains%20in%20Opera%20(also%20Chromium%20based)%2C%20and%20Opera%20shows%20the%20same%20behavior%20as%20Edge%20dev.%20However%2C%20in%20testing%20with%20both%20Edge%20(stable%2C%20public)%20and%20Internet%20Explorer%2C%20the%20color%20is%20the%20same%20as%20Chrome.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EChanging%20the%20Chrome%20color%20profile%20to%20forced%20sRGB%20did%20not%20make%20a%20difference.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGiven%20that%20it%20is%20occurring%20in%20both%20Opera%20and%20Edge%20dev%2C%20I%20would%20assume%20that%20its%20some%20Chromium%20bug%20that%20Google%20Chrome%20has%20figured%20out%20how%20to%20resolve%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-722913%22%20slang%3D%22en-US%22%3ERe%3A%20Rendered%20Color%20Inaccuracies%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-722913%22%20slang%3D%22en-US%22%3EHey%20Frank%2C%20please%20see%20my%20response%20to%20another%20commenter%20here%3A%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FDiscussions%2FRendered-Color-Inaccuracies%2Fm-p%2F722906%2Fhighlight%2Ftrue%23M5976%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FDiscussions%2FRendered-Color-Inaccuracies%2Fm-p%2F722906%2Fhighlight%2Ftrue%23M5976%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EI'm%20not%20sure%20what%20the%20issue%20could%20be%20if%20you%20aren't%20also%20seeing%20it.%20Let%20me%20know%20if%20you'd%20like%20any%20diagnostic%20information%20and%20I%20will%20do%20my%20best%20to%20provide%20it.%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-729356%22%20slang%3D%22en-US%22%3ERe%3A%20Rendered%20Color%20Inaccuracies%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-729356%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F347890%22%20target%3D%22_blank%22%3E%40tc-at-work%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20could%20not%20reproduce%20the%20same%20color%20issues%2C%20but%20I%20will%20research%20into%20what%20could%26nbsp%3B%3C%2FP%3E%0A%3CP%3Ebe%20a%20possible%20culprit%20for%20this%20problem.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20for%20your%20patience%2C%3C%2FP%3E%0A%3CP%3EFrank%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-994712%22%20slang%3D%22en-US%22%3ERe%3A%20Rendered%20Color%20Inaccuracies%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-994712%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F347890%22%20target%3D%22_blank%22%3E%40tc-at-work%3C%2FA%3E%26nbsp%3B%20To%20correct%20how%20the%20browser%20was%20display%20color.%26nbsp%3B%20I%20changed%20the%20Force%20Color%20Profile%20setting%20from%20Default%20to%20sRGB%20by%20browsing%20to%3A%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fflags%2F%23force-color-profile%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fflags%2F%23force-color-profile%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
tc-at-work
New Contributor

I'm not sure if anyone has noticed, but colors are not being rendered accurately in Edge Chromium (Version 77.0.197.1 (Official build) dev (64-bit)). Here is a side-by-side (imgur) of Edge Chromium (left) and Chrome (right). From what I can tell, Chrome is extremely accurate in its color rendering. Edge Chromium, for some reason, not so much. Specifically, blues have a purple-ish tinge to them.

 

The HTML file used to test this is available for download here from my OneDrive account (since .html isn't a valid file extension to upload here).

 

I'd like to see this issue fixed before final release. The point of Edge Chromium was unification, not yet another browser rendering engine to code for. In my opinion, this is a pretty large difference in color representation.

 

I don't believe this is just me, but if it is please let me know in the comments.

6 Replies

@tc-at-work 

 

I have no doubt you are running into some color saturation issue.

 

I have tried to reproduce this issue with Canary, Dev and Chrome on a couple different machines

but the colors seem almost identical on my side with all three browsers.

 

color test.PNGWe are still in preview builds so we will for sure have browser functions fixed,

or improved before a final release.

 

Thanks for taking the time to upload the test HTML and screenshot,

Frank

@tc-at-work 

 

Could it be a problem with Chrome? There is a setting force-color-profile.

https://www.faqforge.com/windows/fixed-google-chrome-wrong-color-after-update/

 

You could try installing Firefox and see whether the problem is actually with edge or with chrome.

@Daniel Niccoli So I checked to see if the color difference remains in Opera (also Chromium based), and Opera shows the same behavior as Edge dev. However, in testing with both Edge (stable, public) and Internet Explorer, the color is the same as Chrome.

 

Changing the Chrome color profile to forced sRGB did not make a difference.

 

Given that it is occurring in both Opera and Edge dev, I would assume that its some Chromium bug that Google Chrome has figured out how to resolve?

Hey Frank, please see my response to another commenter here: https://techcommunity.microsoft.com/t5/Discussions/Rendered-Color-Inaccuracies/m-p/722906/highlight/...

I'm not sure what the issue could be if you aren't also seeing it. Let me know if you'd like any diagnostic information and I will do my best to provide it.

Thanks

@tc-at-work 

I could not reproduce the same color issues, but I will research into what could 

be a possible culprit for this problem.

 

Thanks for your patience,

Frank

@tc-at-work  To correct how the browser was display color.  I changed the Force Color Profile setting from Default to sRGB by browsing to:  edge://flags/#force-color-profile

 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
48 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies