Home

Previously closed installed app relaunches when new browser window is opened

%3CLINGO-SUB%20id%3D%22lingo-sub-522903%22%20slang%3D%22en-US%22%3EPreviously%20closed%20installed%20app%20relaunches%20when%20new%20browser%20window%20is%20opened%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-522903%22%20slang%3D%22en-US%22%3E%3CP%3EInstall%20any%20website%20as%20an%20app.%3C%2FP%3E%3CP%3EPin%20it%20to%20taskbar.%3C%2FP%3E%3CP%3EIn%20a%20new%20browser%20window%2C%26nbsp%3BGo%20to%20Settings.%3C%2FP%3E%3CP%3EOn%20startup%3A%20change%20to%20%22Continue%20where%20you%20left%20off%22.%3C%2FP%3E%3CP%3EClose%20all%20browser%20windows.%3C%2FP%3E%3CP%3EOpen%20your%20pinned%20app.%3C%2FP%3E%3CP%3EClose%20it.%3C%2FP%3E%3CP%3EOpen%20Edge%20browser%20window.%3C%2FP%3E%3CP%3EYou%20will%20see%20two%20windows%20open%2C%20your%20pinned%20app%20and%20Edge%20browser%20window.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EExpected%3A%20only%20open%20Edge%20browser%20window.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-529588%22%20slang%3D%22en-US%22%3ERe%3A%20Previously%20closed%20installed%20app%20relaunches%20when%20new%20browser%20window%20is%20opened%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-529588%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F316234%22%20target%3D%22_blank%22%3E%40CodeDJ%3C%2FA%3E%26nbsp%3Bthanks%20for%20reporting%20this!%20I%20can%20see%20how%20this%20could%20happen.%20I've%20not%20been%20able%20to%20repro%20it%20yet%2C%20but%20I'm%20assigning%20myself%20a%20task%20to%20try%20again%20with%20the%20next%20build%20of%20Canary.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-546012%22%20slang%3D%22en-US%22%3ERe%3A%20Previously%20closed%20installed%20app%20relaunches%20when%20new%20browser%20window%20is%20opened%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-546012%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20issue%20as%20well%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-549802%22%20slang%3D%22en-US%22%3ERe%3A%20Previously%20closed%20installed%20app%20relaunches%20when%20new%20browser%20window%20is%20opened%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-549802%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F327184%22%20target%3D%22_blank%22%3E%40MrJamesMoore%3C%2FA%3E%20thanks!%20Yeah%2C%20I%20see%20this%20now%20as%20well.%20I'll%20open%20a%20bug%20on%20it.%20I%20am%20also%20seeing%20that%20the%20first%20launch%20after%20installing%20the%20app%20does%20not%20actually%20continue%2C%20instead%20I%20see%20the%20New%20Tab%20Page%20as%20well%20as%20the%20installed%20app.%20I'm%20going%20to%20open%20that%20as%20a%20separate%20bug.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-550403%22%20slang%3D%22en-US%22%3ERe%3A%20Previously%20closed%20installed%20app%20relaunches%20when%20new%20browser%20window%20is%20opened%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-550403%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F318459%22%20target%3D%22_blank%22%3E%40johnjansen%3C%2FA%3E%26nbsp%3BGlad%20you%20can%20reproduce%20it%20and%20thanks%20for%20your%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-708977%22%20slang%3D%22en-US%22%3ERe%3A%20Previously%20closed%20installed%20app%20relaunches%20when%20new%20browser%20window%20is%20opened%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-708977%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F318459%22%20target%3D%22_blank%22%3E%40johnjansen%3C%2FA%3E%26nbsp%3BI%20hope%20this%20gets%20fixed%20before%20going%20live.%20Keep%20hitting%20it%20every%20day.%20Thanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-709588%22%20slang%3D%22en-US%22%3ERE%3A%20Previously%20closed%20installed%20app%20relaunches%20when%20new%20browser%20window%20is%20opened%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-709588%22%20slang%3D%22en-US%22%3EThis%20happens%20to%20me%20as%20well%20sometimes...%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-712288%22%20slang%3D%22en-US%22%3ERe%3A%20Previously%20closed%20installed%20app%20relaunches%20when%20new%20browser%20window%20is%20opened%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-712288%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F316234%22%20target%3D%22_blank%22%3E%40CodeDJ%3C%2FA%3E%26nbsp%3Bthis%20works%20correctly%20on%20Canary.%20Not%20sure%20if%20it%20was%20recently%20fixed.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-720115%22%20slang%3D%22en-US%22%3ERe%3A%20Previously%20closed%20installed%20app%20relaunches%20when%20new%20browser%20window%20is%20opened%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-720115%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20is%20now%20fixed%20in%20the%20dev%20branch%20as%20well.%26nbsp%3B%3CSPAN%3EVersion%2077.0.197.1%20(Official%20build)%20dev%20(64-bit).%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
CodeDJ
Contributor

Install any website as an app.

Pin it to taskbar.

In a new browser window, Go to Settings.

On startup: change to "Continue where you left off".

Close all browser windows.

Open your pinned app.

Close it.

Open Edge browser window.

You will see two windows open, your pinned app and Edge browser window.

 

Expected: only open Edge browser window.

8 Replies

@CodeDJ thanks for reporting this! I can see how this could happen. I've not been able to repro it yet, but I'm assigning myself a task to try again with the next build of Canary.

@MrJamesMoore thanks! Yeah, I see this now as well. I'll open a bug on it. I am also seeing that the first launch after installing the app does not actually continue, instead I see the New Tab Page as well as the installed app. I'm going to open that as a separate bug. 

@johnjansen Glad you can reproduce it and thanks for your help.

@johnjansen I hope this gets fixed before going live. Keep hitting it every day. Thanks!

This happens to me as well sometimes...

@CodeDJ this works correctly on Canary. Not sure if it was recently fixed.

This is now fixed in the dev branch as well. Version 77.0.197.1 (Official build) dev (64-bit).

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies