Home

Possible bug: Installation of an addon wont work if first tried in a private browsing window

%3CLINGO-SUB%20id%3D%22lingo-sub-462029%22%20slang%3D%22en-US%22%3ERe%3A%20Possible%20bug%3A%20Installation%20of%20an%20addon%20wont%20work%20if%20first%20tried%20in%20a%20private%20browsing%20window%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-462029%22%20slang%3D%22en-US%22%3E%3CP%3EPS%20%3A%20Shared%20this%20info%20using%20the%20%22Send%20feedback%22%20form%2C%20%26amp%3B%20included%20a%20link%20to%20this%20thread%20for%20more%20details.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-462013%22%20slang%3D%22en-US%22%3EPossible%20bug%3A%20Installation%20of%20an%20addon%20wont%20work%20if%20first%20tried%20in%20a%20private%20browsing%20window%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-462013%22%20slang%3D%22en-US%22%3E%3CP%3EA%20possible%20bug%20%3A%3C%2FP%3E%3CP%3EIf%20you%20try%20to%20install%20an%20addon%20(from%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fmicrosoftedge.microsoft.com%2Finsider-addons%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmicrosoftedge.microsoft.com%2Finsider-addons%3C%2FA%3E)%20on%20an%20inPrivate%20window%2C%20you%20will%20get%20this%20error%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20385px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F109118iC48184F5DEB86D7A%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Error1.png%22%20title%3D%22Error1.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20problem%20i%20found%20is%20that%2C%20if%20you%20switch%20right%20after%20to%20a%20%22normal%22%20browsing%20window%20%26amp%3B%20try%20to%20install%20the%20same%20addon%20you%20will%20get%20this%20one%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20397px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F109119i15919D35A67F8A16%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Error2.png%22%20title%3D%22Error2.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOf%20course%2C%20the%20said%20addon%20has%20not%20been%20installed.%3C%2FP%3E%3CP%3EGetting%20around%20this%20error%20for%20now%20require%20closing%20all%20browser%20windows%20%26amp%3B%20restarting%20it%20to%20try%20again%20(from%20a%20normal%20window)%20to%20effectively%20install%20it.%3C%2FP%3E%3CP%3EFound%20using%26nbsp%3B%3CSPAN%3EVersion%2075.0.130.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EHope%20this%20help%2C%20%26amp%3B%20good%20luck%20%3Asmiling_face_with_smiling_eyes%3A%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEDIT%3A%26nbsp%3B%3CSPAN%3EShared%20this%20info%20using%20the%20%22Send%20feedback%22%20form%2C%20%26amp%3B%20included%20a%20link%20to%20this%20thread%20for%20more%20details.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EEDIT2%3A%20Same%20with%20the%20latest%20build%20(Version%2075.0.131.0%20(Official%20build)%20canary%2064-bit)%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-462929%22%20slang%3D%22en-US%22%3ERe%3A%20Possible%20bug%3A%20Installation%20of%20an%20addon%20wont%20work%20if%20first%20tried%20in%20a%20private%20browsing%20window%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-462929%22%20slang%3D%22en-US%22%3EThank%20you%20for%20your%20thorough%20investigation%20on%20this%20issue.%20Thank%20you%20again%20for%20submitting%20via%20the%20in-app%20feedback%20form!%20I%20will%20let%20the%20extensions%20team%20know%20about%20this%20issue.%3C%2FLINGO-BODY%3E
AimanJ
Occasional Contributor

A possible bug :

If you try to install an addon (from https://microsoftedge.microsoft.com/insider-addons) on an inPrivate window, you will get this error :

 

Error1.png

 

The problem i found is that, if you switch right after to a "normal" browsing window & try to install the same addon you will get this one :

 

Error2.png

 

 

Of course, the said addon has not been installed.

Getting around this error for now require closing all browser windows & restarting it to try again (from a normal window) to effectively install it.

Found using Version 75.0.130.0 (Official build) canary (64-bit)

Hope this help, & good luck :smiling_face_with_smiling_eyes:

 

EDIT: Shared this info using the "Send feedback" form, & included a link to this thread for more details.

EDIT2: Same with the latest build (Version 75.0.131.0 (Official build) canary 64-bit)

1 Reply
Thank you for your thorough investigation on this issue. Thank you again for submitting via the in-app feedback form! I will let the extensions team know about this issue.