SOLVED
Home

PDF files not opening in Edge Dev

%3CLINGO-SUB%20id%3D%22lingo-sub-745223%22%20slang%3D%22en-US%22%3EPDF%20files%20not%20opening%20in%20Edge%20Dev%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-745223%22%20slang%3D%22en-US%22%3E%3CP%3EIn%20version%26nbsp%3B%3CSPAN%3E77.0.197.1%20and%20a%20couple%20of%20versions%20prior%20to%20that%2C%20Edge%20Dev%20hangs%20trying%20to%20open%20most%20PDF%20files%20when%20those%20files%20are%20double-clicked%20in%20the%20Windows%20File%20Explorer.%20Edge%20Dev%20is%20set%20as%20the%20default%20application%20for%20PDF%20files.%20Dragging%20and%20dropping%20a%20PDF%20file%20onto%20Edge%20Dev%20seems%20to%20work%20more%20reliably.%20This%20was%20all%20working%20perfectly%20fine%20two%20or%20three%20weeks%20ago.%20Thanks.%20Jeff.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-745309%22%20slang%3D%22en-US%22%3ERe%3A%20PDF%20files%20not%20opening%20in%20Edge%20Dev%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-745309%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F180266%22%20target%3D%22_blank%22%3E%40Dr.%20Jeffry%20A.%20Spain%3C%2FA%3E%26nbsp%3B-%20thanks%20for%20reporting%20this.%20This%20is%20a%20known%20issue%20%26amp%3B%20was%20fixed%20in%20Canary%20channel%20last%20week.%20The%20fix%20should%20be%20coming%20soon%20to%20Dev%20channel.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-747719%22%20slang%3D%22en-US%22%3ERe%3A%20PDF%20files%20not%20opening%20in%20Edge%20Dev%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-747719%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F180266%22%20target%3D%22_blank%22%3E%40Dr.%20Jeffry%20A.%20Spain%3C%2FA%3E%26nbsp%3B-%20this%20should%20now%20be%20fixed%20in%20the%20latest%20dev%20channel%20build%20-%2077.0.211.2.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-747759%22%20slang%3D%22en-US%22%3ERe%3A%20PDF%20files%20not%20opening%20in%20Edge%20Dev%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-747759%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F315999%22%20target%3D%22_blank%22%3E%40Balaje_Krishnan%3C%2FA%3E%26nbsp%3BYes%2C%20thanks%2C%20I%20confirmed%20that%20this%20is%20fixed%20in%2077.0.211.2.%20I've%20been%20using%20Edge%20Dev%20as%20my%20default%20browser%20for%20a%20couple%20of%20months%20now.%20It's%20working%20really%20well%20overall.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'll%20add%20one%20more%20comment.%20When%20Edge%20Dev%20is%20launched%20from%20a%20built-in%20administrator%20account%2C%20it%20displays%20the%20message%20%22Administrator%20Mode%20Detected%3A%20Close%20Microsoft%20Edge%20and%20relaunch%20in%20non-administrator%20mode%20for%20best%20performance.%22%20I'd%20like%20to%20be%20able%20to%20turn%20this%20warning%20off%20in%20the%20Edge%20Dev%20settings.%20It's%20my%20usual%20practice%20(and%20I%20imagine%20that%20of%20a%20lot%20of%20other%20system%20administrators)%20to%20sign%20into%20Windows%20servers%20as%20a%20built-in%20administrator.%20I'd%20rather%20use%20Edge%20Dev%20than%20the%20ancient%20Internet%20Explorer%2C%20and%20I'd%20rather%20not%20use%20a%20third-party%20browser.%20I'll%20stipulate%20to%20the%20pros%20and%20cons%20in%20terms%20of%20security%20vs.%20ease%20of%20use%20of%20logging%20onto%20a%20server%20as%20a%20built-in%20administrator.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%20Jeff.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Dr. Jeffry A. Spain
New Contributor

In version 77.0.197.1 and a couple of versions prior to that, Edge Dev hangs trying to open most PDF files when those files are double-clicked in the Windows File Explorer. Edge Dev is set as the default application for PDF files. Dragging and dropping a PDF file onto Edge Dev seems to work more reliably. This was all working perfectly fine two or three weeks ago. Thanks. Jeff.

3 Replies
Solution

@Dr. Jeffry A. Spain - thanks for reporting this. This is a known issue & was fixed in Canary channel last week. The fix should be coming soon to Dev channel.

@Dr. Jeffry A. Spain - this should now be fixed in the latest dev channel build - 77.0.211.2.

@Balaje_Krishnan Yes, thanks, I confirmed that this is fixed in 77.0.211.2. I've been using Edge Dev as my default browser for a couple of months now. It's working really well overall.

 

I'll add one more comment. When Edge Dev is launched from a built-in administrator account, it displays the message "Administrator Mode Detected: Close Microsoft Edge and relaunch in non-administrator mode for best performance." I'd like to be able to turn this warning off in the Edge Dev settings. It's my usual practice (and I imagine that of a lot of other system administrators) to sign into Windows servers as a built-in administrator. I'd rather use Edge Dev than the ancient Internet Explorer, and I'd rather not use a third-party browser. I'll stipulate to the pros and cons in terms of security vs. ease of use of logging onto a server as a built-in administrator.

 

Thanks. Jeff.

Related Conversations
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
PacketMon Components are not loading in WAC 1909
HotCakeX in Windows Admin Center on
2 Replies