Old bug back - Lastpass extension cannot connect to server

Regular Contributor

The Lastpass extension cannot connect to its server. I use a Ubikey for two-factor authentication.


1- Login with password

2- Press on Ubikey when prompted

3- The Tab for the Ubikey closes and reopens again asking to press on the key

4- The request to press the Ubikey repeats ad nauseam.


The problem arises in Canary and Dev versions, not on any other app (Edge Classic, Chrome, Opera, Firefox and Brave). I've tested the bug on my workstation, Surface Pro 4 and Dell Alienware 17r3 and it's the same story everywhere.

9 Replies
I have no problems with LastPass and MFA using the LastPass authenticator app. Sound like it's a Ubikey-related issue.

@ahl2ndc How could it be? The key works fine with every app except Edge Canary and Dev?

Sorry, didn't mean it to sound like it's the Unikey that's the problem. Just that Edge has a problem with the Ubikey in LastPass and not a general LastPass problem, as I have no problems with LastPass.

@ahl2ndc I just tried logging in using an Authenticator but the Vault refuses to change the default multifactor option. It gives me a message that the change has been saved but leaving the Account Settings page and coming back shows that my change hasn't taken. However, I was able to disable the Yubikey MFA option and was given the option of getting a six-digit code via SMS when in Edge. However, I am still told LastPass cannot connect to its server.


1- Launch Edge Canary or Dev

2- Click on the extension

3- Log in

Result: cannot connect to server message

My best bet is to remove LastPass and reinstalling it. It should be noted, that I have only installed the browser extension and not the "Universal installer". Maybe somethings up with that.

@NicolSD wrote:

... LastPass cannot connect to its server.

This sounds like CORB getting in the way. If this is the case, it looks like it's the extension author that has to make some changes.

@ahl2ndc Done that twice. Even tried different extensions (Microsoft store and Google store).

There was a message for me when I logged on to Lastpass support today (in Edge dev) that told me my extension was outdated and needed to be upgraded. I ran the universal installer, which promptly failed to upgrade anything. Then I removed and reinstalled the extension fro the Edge store but the installed version (4.27.1 I believe). I went out to the Chrome store and they had 4.28 and installed from there. No joy - the upgrade did not fix this issue. I've tried to turn off the Yubikey as well and it happily tells me it's changed to fingerprint authentication as the primary method and then cheerfully ignores it when I try to logon. Now on to the really weird. I switched over to Chrome as my primary browser till there is a fix for this. It does recognize my fingerprint scanner as the primary logon method, scans my fingerprint (which it then happily ignores), takes me to the password logon screen, then the Yubikey authentication page which works in Chrome. Just my nickels worth of info

@DavidCashion I disable the Ubikey. After that, I automatically was changed to the authenticator. I ended up using an SMS code. Once in a while, I log out, then log in again to make sure I am still getting the message about not connecting to the server.


Nothing can make me use Chrome. I'll switch to Firefox, Brave or Vivaldi first.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
38 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies