Home

New InPrivate Window = Edge (dev) Crashes

%3CLINGO-SUB%20id%3D%22lingo-sub-852487%22%20slang%3D%22en-US%22%3ENew%20InPrivate%20Window%20%3D%20Edge%20(dev)%20Crashes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-852487%22%20slang%3D%22en-US%22%3E%3CP%3EFor%20the%20past%20week%20or%20two%2C%20I've%20had%20trouble%20opening%20an%20InPrivate%20window.%26nbsp%3B%20When%20I%20select%20New%20InPrivate%20Window%20from%20the%20menu%2C%20Edge%20crashes.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20else%20run%20into%20this%3F%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-852487%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Ecrash%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EEdge%20Dev%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EEdge%20insider%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EInPrivate%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-852729%22%20slang%3D%22en-US%22%3ERe%3A%20New%20InPrivate%20Window%20%3D%20Edge%20(dev)%20Crashes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-852729%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F27877%22%20target%3D%22_blank%22%3E%40Steve%20Whitcher%3C%2FA%3E%26nbsp%3BI'm%20using%20Canary%2C%20but%20no%20it%20hasn't%20happen%20to%20me.%20I%20use%20inprivate%20often%20for%20email%20because%20it%20doesn't%20leave%20the%20login%20hanging%20for%20my%20emails%20if%20I%20forget%20to%20do%20a%20clear%20browser%20history.%20I%20never%20had%20any%20problems%20with%20it.%20So%20it%20could%20be%20just%20a%20Edge%20Dev%20thing%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-853313%22%20slang%3D%22en-US%22%3ERe%3A%20New%20InPrivate%20Window%20%3D%20Edge%20(dev)%20Crashes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-853313%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F27877%22%20target%3D%22_blank%22%3E%40Steve%20Whitcher%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eplease%20try%20the%20followings%3A%3C%2FP%3E%3CP%3E1.%20reset%20all%20flags%20back%20to%20their%20default%20values%3A%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fflags%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fflags%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E2.%20reset%20Edge%20insider%20settings%20to%20the%20defaults%3A%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fsettings%2Freset%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fsettings%2Freset%3C%2FA%3E%3C%2FP%3E%3CP%3E3.%20temporary%20disable%20all%20the%20extensions.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Elet's%20see%20if%20they%20will%20prevent%20InPrivate%20window%20crash..%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ewhen%20I%20try%20to%20open%20InPrivate%20mode%20on%20a%20fresh%20Edge%20dev%20it%20opens%20without%20problem%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F131572i1D828E77354A5B84%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-09-12%20234305.png%22%20title%3D%22Annotation%202019-09-12%20234305.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-854485%22%20slang%3D%22en-US%22%3ERe%3A%20New%20InPrivate%20Window%20%3D%20Edge%20(dev)%20Crashes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-854485%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BThanks%2C%20it%20only%20took%20resetting%20the%20flags%20to%20get%20it%20working%20again.%26nbsp%3B%20Turning%20them%20on%20one%20by%20one%2C%20it%20seems%20that%20the%20problematic%20flag%20is%3A%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fflags%2F%23edge-identity-based-http-auth%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%23edge-identity-based-http-auth%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOnce%20I%20enable%20that%20flag%20and%20restart%20the%20browser%2C%20I%20can%20no%20longer%20start%20an%20InPrivate%20window%20without%20the%20browser%20crashing.%26nbsp%3B%20Revert%20only%20that%20flag%20back%20to%20default%2C%20restart%20browser%2C%20and%20InPrivate%20windows%20work%20fine%20again.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20you%20reproduce%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-854615%22%20slang%3D%22en-US%22%3ERe%3A%20New%20InPrivate%20Window%20%3D%20Edge%20(dev)%20Crashes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-854615%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F27877%22%20target%3D%22_blank%22%3E%40Steve%20Whitcher%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYeah%20It%20crashes%20with%20that%20flag%20on%20for%20me%20too.%20devs%20should%20look%20into%20the%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Steve Whitcher
Regular Contributor

For the past week or two, I've had trouble opening an InPrivate window.  When I select New InPrivate Window from the menu, Edge crashes.  

 

Anyone else run into this?  

4 Replies

@Steve Whitcher I'm using Canary, but no it hasn't happen to me. I use inprivate often for email because it doesn't leave the login hanging for my emails if I forget to do a clear browser history. I never had any problems with it. So it could be just a Edge Dev thing?

@Steve Whitcher 

 

please try the followings:

1. reset all flags back to their default values: edge://flags/

2. reset Edge insider settings to the defaults: edge://settings/reset

3. temporary disable all the extensions.

 

let's see if they will prevent InPrivate window crash..

 

when I try to open InPrivate mode on a fresh Edge dev it opens without problem

Annotation 2019-09-12 234305.png

 

@HotCakeX Thanks, it only took resetting the flags to get it working again.  Turning them on one by one, it seems that the problematic flag is: #edge-identity-based-http-auth 

 

Once I enable that flag and restart the browser, I can no longer start an InPrivate window without the browser crashing.  Revert only that flag back to default, restart browser, and InPrivate windows work fine again.  

 

Can you reproduce this?

@Steve Whitcher 

Yeah It crashes with that flag on for me too. devs should look into the issue.

Related Conversations
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
Early preview of Microsoft Edge group policies
Sean Lyndersay in Discussions on
65 Replies
*Updated 9/3* Syncing in Microsoft Edge Preview Channels
Elliot Kirk in Articles on
201 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
2 Replies