Home

Nagging about running as an administrator!

%3CLINGO-SUB%20id%3D%22lingo-sub-679077%22%20slang%3D%22en-US%22%3ENagging%20about%20running%20as%20an%20administrator!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-679077%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20getting%20tired%20of%20being%20nagged%20for%20the%20fact%20I'm%20running%20an%20administrator%20account.%20I'm%20not%20running%20a%20system%20administrator%20account%2C%20just%20a%20user%20administrator%20account%20and%20I%20even%20have%20UAC%20turned%20on.%20I%20need%20to%20do%20this%20for%20some%20of%20the%20other%20specialty%20software%20is%20I%20use%20and%20thus%20I%20don't%20want%20to%20take%20the%20time%20to%20log%20into%20a%20different%20user%20account%20just%20to%20use%20the%20new%20version%20of%20Edge!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20see%20no%20reason%20to%20not%20use%20an%20user%20administrator%20account%2C%20I've%20done%20it%20forever%20and%20ever%20experience%20any%20problems%20of%20any%20type.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOverall%2C%20I%20really%20like%20the%20new%20Edge%20browser%20and%20if%20I%20can%20get%20rid%20of%20this%20issue%20would%20definitely%20use%20it%20as%20my%20primary%20browser.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-679551%22%20slang%3D%22en-US%22%3ERe%3A%20Nagging%20about%20running%20as%20an%20administrator!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-679551%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F356980%22%20target%3D%22_blank%22%3E%40MSRadell%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERunning%20Windows%2010%20as%20an%20Administrator%20does%20not%2C%20as%20I%20understand%20it%2C%20trigger%20Edge%20Chromium%20to%20run%20in%20administrator%20mode.%20My%20Windows%2010%20account%20is%20an%20Administrator%20account%2C%20not%20a%20standard%20user%20account%2C%20and%20Edge%20Chromium%20does%20not%20run%20in%20administrator%20mode.%20To%20run%20Edge%20Chromium%20in%20administrator%20mode%2C%20I%20would%20have%20to%20take%20affirmative%20steps%20to%20set%20Edge%20Chromium%20to%20run%20in%20administrator%20mode%2C%20selecting%20%22Run%20as%20administrator%22%20either%20in%20Settings%2FControl%20Panel%2C%20or%20setting%20the%20executable%20to%20%22Run%20as%20administrator%22%20in%20properties.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEdge%20(Classic)%2C%20in-built%20into%20Windows%2010%2C%20cannot%20be%20set%20to%20run%20in%20administrator%20mode.%20The%20reason%20is%20that%20running%20a%20browser%20in%20administrator%20mode%20is%20a%20security%20risk%2C%20allowing%20the%20browser%20to%20access%20system-protect%20areas%20and%20files%2C%20and%20allowing%20downloaded%20programs%20running%20from%20the%20browser%20to%20inherit%20and%20retain%20the%20brower's%20system%20access%20privileges.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20agree%20that%20the%20pop-up%20%22Administrator%20Mode%20Detected%22%20warning%20can%20be%20distracting.%20I%20hope%20that%20Microsoft%20will%20lock%20down%20Edge%20Chromium%20(as%20it%20does%20Edge%20(Classic))%20in%20the%20release%20version.%20That%20would%20eliminate%20both%20the%20pop-up%20warning%20and%20the%20risk%20involved%20in%20running%20the%20browser%20in%20administrator%20mode.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-679559%22%20slang%3D%22en-US%22%3ERe%3A%20Nagging%20about%20running%20as%20an%20administrator!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-679559%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F318339%22%20target%3D%22_blank%22%3E%40tomscharbach%3C%2FA%3E%26nbsp%3B%26nbsp%3BI%20read%20what%20you%20wrote%20in%20other%20places%20and%20really%20don't%20understand%20why%20I'm%20getting%20the%20morning.%20I've%20checked%20everyplace%20I%20can%20think%20of%20to%20make%20sure%20I'm%20not%20opening%20Chromium%20Edge%20as%20an%20administrator%20and%20I%20don't%20see%20any%20place%20where%20I%20am.%20I%20have%20started%20from%20the%20start%20menu%2C%20the%20icon%20I%20have%20on%20my%20taskbar%20and%20from%20the%20actual%20executable%20file%20in%20the%20Program%20Files%20(86)%20directory%20and%20I%20always%20get%20the%20same%20result.%20I%20also%20make%20sure%20that%20I%20don't%20have%20the%20system%20administrator%20account%20turned%20on%20which%20I%20don't.%20Any%20other%20idea%20where%20it%20could%20be%20getting%20information%20to%20open%20itself%20under%20an%20administrator%20account%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20wouldn't%20mind%20it%20so%20much%20if%20you%20just%20got%20the%20pop-up%20when%20you%201st%20open%20Chromium%20Edge%20but%20you%20even%20get%20it%20every%20time%20it%20opens%20a%20new%20tab.%20To%20say%20that's%20frustrating%20is%20an%20understatement.%20Other%20than%20that%20I%20write%20like%20everything%20about%20the%20new%20Edge.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-679590%22%20slang%3D%22en-US%22%3ERe%3A%20Nagging%20about%20running%20as%20an%20administrator!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-679590%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F356980%22%20target%3D%22_blank%22%3E%40MSRadell%3C%2FA%3E%26nbsp%3B%22%3CSPAN%3E%3CEM%3EI've%20checked%20everyplace%20I%20can%20think%20of%20to%20make%20sure%20I'm%20not%20opening%20Chromium%20Edge%20as%20an%20administrator%20and%20I%20don't%20see%20any%20place%20where%20I%20am.%20I%20have%20started%20from%20the%20start%20menu%2C%20the%20icon%20I%20have%20on%20my%20taskbar%20and%20from%20the%20actual%20executable%20file%20in%20the%20Program%20Files%20(86)%20directory%20and%20I%20always%20get%20the%20same%20result.%20I%20also%20make%20sure%20that%20I%20don't%20have%20the%20system%20administrator%20account%20turned%20on%20which%20I%20don't.%20Any%20other%20idea%20where%20it%20could%20be%20getting%20information%20to%20open%20itself%20under%20an%20administrator%20account%3F%3C%2FEM%3E%22%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EYour%20setup%2Fresults%20seem%20to%20be%20identical%20to%20mine.%26nbsp%3B%20%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EIf%20Edge%20Chromium%20is%20not%20set%20to%20%22Run%20as%20administrator%20...%22)%20natively%20(and%20it%20clearly%20is%20not%20based%20on%20your%20investigation)%2C%20my%20guess%20(and%20I'm%20not%20sure%20that%20it%20even%20rises%20to%20an%20%3CEM%3Eintelligent%3C%2FEM%3E%20guess)%20is%20that%20the%20browser%20must%20have%20inherited%20administrator%20privileges%20from%20an%20app%2Fprogram%20running%20through%2Ffrom%20the%20browser%2C%20typically%20by%20opening%20from%20a%20link%20in%20the%20app%2Fprogram%20while%20running%20in%20administrator%20mode%2C%20and%20somehow%20the%20elevated%20privileges%20%22stuck%22%20to%20the%20browser.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ESomething%20is%20not%20right.%26nbsp%3B%20Inherited%20administrator%20privileges%20from%20opening%20links%20from%20apps%2Fprograms%20with%20elevated%20privileges%20are%20%3CEM%3Enot%3C%2FEM%3E%20supposed%20to%20be%20persistent.%26nbsp%3B%20The%20elevated%20privileges%20are%20%3CEM%3Esupposed%3C%2FEM%3E%20to%20go%20away%20when%20you%20close%20the%20browser%20and%20reopen%20in%20from%20the%20desktop%2Fstart%2Ftaskbar.%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EMy%20only%20thoughts%20are%20(1)%20report%20the%20situation%20as%20a%20bug%20to%20%3CA%20href%3D%22https%3A%2F%2Fmicrosoftedgesupport.microsoft.com%2Fhc%2Fen-us%2Frequests%2Fnew%3F%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3EMicrosoft%20Insider%20Support%3C%2FA%3E%2C%20and%20let%20them%20work%20on%20it%20with%20you%2C%20or%20(2)%20if%20you%20want%20to%20do%20some%20preliminary%20work%20before%20contacting%20support%2C%20uninstall%20Edge%20Chromium%2C%20reboot%20and%20reinstall%2C%20and%20see%20if%20the%20problem%20persists.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ESorry%20that%20I%20can't%20be%20of%20much%20help.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
MSRadell
Occasional Contributor

I'm getting tired of being nagged for the fact I'm running an administrator account. I'm not running a system administrator account, just a user administrator account and I even have UAC turned on. I need to do this for some of the other specialty software is I use and thus I don't want to take the time to log into a different user account just to use the new version of Edge!

 

I see no reason to not use an user administrator account, I've done it forever and ever experience any problems of any type.

 

Overall, I really like the new Edge browser and if I can get rid of this issue would definitely use it as my primary browser.

3 Replies

@MSRadell 

Running Windows 10 as an Administrator does not, as I understand it, trigger Edge Chromium to run in administrator mode. My Windows 10 account is an Administrator account, not a standard user account, and Edge Chromium does not run in administrator mode. To run Edge Chromium in administrator mode, I would have to take affirmative steps to set Edge Chromium to run in administrator mode, selecting "Run as administrator" either in Settings/Control Panel, or setting the executable to "Run as administrator" in properties.

 

Edge (Classic), in-built into Windows 10, cannot be set to run in administrator mode. The reason is that running a browser in administrator mode is a security risk, allowing the browser to access system-protect areas and files, and allowing downloaded programs running from the browser to inherit and retain the brower's system access privileges.

 

I agree that the pop-up "Administrator Mode Detected" warning can be distracting. I hope that Microsoft will lock down Edge Chromium (as it does Edge (Classic)) in the release version. That would eliminate both the pop-up warning and the risk involved in running the browser in administrator mode.

@tomscharbach  I read what you wrote in other places and really don't understand why I'm getting the morning. I've checked everyplace I can think of to make sure I'm not opening Chromium Edge as an administrator and I don't see any place where I am. I have started from the start menu, the icon I have on my taskbar and from the actual executable file in the Program Files (86) directory and I always get the same result. I also make sure that I don't have the system administrator account turned on which I don't. Any other idea where it could be getting information to open itself under an administrator account?

 

I wouldn't mind it so much if you just got the pop-up when you 1st open Chromium Edge but you even get it every time it opens a new tab. To say that's frustrating is an understatement. Other than that I write like everything about the new Edge.

Highlighted

@MSRadell "I've checked everyplace I can think of to make sure I'm not opening Chromium Edge as an administrator and I don't see any place where I am. I have started from the start menu, the icon I have on my taskbar and from the actual executable file in the Program Files (86) directory and I always get the same result. I also make sure that I don't have the system administrator account turned on which I don't. Any other idea where it could be getting information to open itself under an administrator account?"

 

Your setup/results seem to be identical to mine. 

 

If Edge Chromium is not set to "Run as administrator ...") natively (and it clearly is not based on your investigation), my guess (and I'm not sure that it even rises to an intelligent guess) is that the browser must have inherited administrator privileges from an app/program running through/from the browser, typically by opening from a link in the app/program while running in administrator mode, and somehow the elevated privileges "stuck" to the browser.

 

Something is not right.  Inherited administrator privileges from opening links from apps/programs with elevated privileges are not supposed to be persistent.  The elevated privileges are supposed to go away when you close the browser and reopen in from the desktop/start/taskbar.  

 

My only thoughts are (1) report the situation as a bug to Microsoft Insider Support, and let them work on it with you, or (2) if you want to do some preliminary work before contacting support, uninstall Edge Chromium, reboot and reinstall, and see if the problem persists.

 

Sorry that I can't be of much help.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies