SOLVED
Home

IE Mode stuck in authentication loop for websites using SSO authentication

%3CLINGO-SUB%20id%3D%22lingo-sub-784769%22%20slang%3D%22en-US%22%3EIE%20Mode%20stuck%20in%20authentication%20loop%20for%20websites%20using%20SSO%20authentication%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-784769%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%20been%20testing%20IE%20Mode%20with%20Edge%20Dev%20an%20seeing%20an%20issue%20with%20websites%20that%20use%20SSO%20authentication%20when%20we%20run%20them%20in%20IE%20Mode.%26nbsp%3B%20Using%20Fiddler%20we%20see%20that%20when%20the%20website%20sends%20its%20post%20for%20login%20authentication%2C%20the%20post%20turns%20into%20a%20get%20and%20the%20post%20body%20is%20dropped.%26nbsp%3B%20Edge%20or%20IE%20Mode%20is%20changing%20the%20http%20method%20when%20switching%20browsers%20and%20turning%20posts%20into%20gets.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20result%20is%20an%20endless%20loop%20where%20it%20looks%20like%20the%20webpage%20just%20keeps%20reloading%20and%20trying%20to%20authenticate%20over%20and%20over%20again%20until%20you%20close%20the%20tab.%26nbsp%3B%20In%20the%20Fiddler%20results%2C%20we%20see%20the%20process%20jumping%20back%20and%20forth%20between%20msedge%20and%20iexplore.%26nbsp%3B%20Testing%20another%20website%20that%20uses%20SSO%20in%20IE%20Mode%2C%20it%20doesn't%20get%20stuck%20in%20a%20loop%2C%20but%20the%20SSO%20authentication%20just%20fails%20and%20the%20user%20isn't%20logged%20in.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20we%20go%20to%20the%20same%20website%20in%20Edge%20Dev%20but%20not%20in%20IE%20Mode%2C%20the%20authentication%20works%20fine%20and%20the%20page%20loads%20correctly.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERunning%20Edge%20Dev%26nbsp%3B%3CSPAN%3E77.0.230.2%3C%2FSPAN%3Eon%20Win10%201809%20and%201903%2C%20all%2064bit.%26nbsp%3B%20Previous%20version%20of%20Edge%20Dev%20did%20this%20as%20well.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20else%20seeing%20this%20as%20well%3F%26nbsp%3B%20I'm%20not%20an%20authentication%20expert%2C%20so%20please%20let%20me%20know%20if%20more%20info%20is%20needed.%26nbsp%3B%20Thanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-789315%22%20slang%3D%22en-US%22%3ERe%3A%20IE%20Mode%20stuck%20in%20authentication%20loop%20for%20websites%20using%20SSO%20authentication%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-789315%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F368377%22%20target%3D%22_blank%22%3E%40SteveSta%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThis%20is%20probably%20happening%20because%20the%20site%20you%20are%20trying%20to%20reach%20is%20redirecting%20to%20an%20authentication%20server%20that%20is%20not%20configured%20to%20open%20in%20IE%20mode.%20You%20can%20try%20opening%20the%20site%20in%20standalone%20IE11%20with%20Developer%20Tools%20open%20to%20see%20the%20identity%20of%20the%20authentication%20server.%3C%2FP%3E%0A%3CP%3EThe%20solution%20is%20to%20then%20configure%20the%20authentication%20server%20in%20your%20EMIE%20site%20list%20as%20%E2%80%9Cneutral%E2%80%9D%2C%20like%20this%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSITE%20url%3D%22%26quot%3Blogin.contoso.com%26quot%3B%22%3E%3C%2FSITE%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3CCOMPAT-MODE%3Edefault%3C%2FCOMPAT-MODE%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3COPEN-IN%3ENeutral%3C%2FOPEN-IN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CP%3E%3C%2FP%3E%3CLINGO-SUB%20id%3D%22lingo-sub-790907%22%20slang%3D%22en-US%22%3ERe%3A%20IE%20Mode%20stuck%20in%20authentication%20loop%20for%20websites%20using%20SSO%20authentication%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-790907%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F381707%22%20target%3D%22_blank%22%3E%40Adrian_Guta%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20Adrian%2C%20that%20did%20the%20trick!%26nbsp%3B%20Not%20having%20our%20authentication%20site%20in%20the%20list%20caused%20the%20issue%2C%20but%20adding%20it%20and%20setting%20it%20to%20Neutral%20(or%20setting%20it%20to%20None)%20works%20and%20our%20site%20that%20we%20wanted%20to%20get%20redirected%20to%20IEMode%20works%20as%20expected%2C%20and%20authenticates%20as%20expected.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAppreciate%20it!%3C%2FP%3E%3C%2FLINGO-BODY%3E
SteveSta
Occasional Contributor

Hi all, been testing IE Mode with Edge Dev an seeing an issue with websites that use SSO authentication when we run them in IE Mode.  Using Fiddler we see that when the website sends its post for login authentication, the post turns into a get and the post body is dropped.  Edge or IE Mode is changing the http method when switching browsers and turning posts into gets.

 

The result is an endless loop where it looks like the webpage just keeps reloading and trying to authenticate over and over again until you close the tab.  In the Fiddler results, we see the process jumping back and forth between msedge and iexplore.  Testing another website that uses SSO in IE Mode, it doesn't get stuck in a loop, but the SSO authentication just fails and the user isn't logged in.

 

If we go to the same website in Edge Dev but not in IE Mode, the authentication works fine and the page loads correctly.

 

Running Edge Dev 77.0.230.2 on Win10 1809 and 1903, all 64bit.  Previous version of Edge Dev did this as well.

 

Anyone else seeing this as well?  I'm not an authentication expert, so please let me know if more info is needed.  Thanks!

2 Replies
Solution

@SteveSta 

This is probably happening because the site you are trying to reach is redirecting to an authentication server that is not configured to open in IE mode. You can try opening the site in standalone IE11 with Developer Tools open to see the identity of the authentication server.

The solution is to then configure the authentication server in your EMIE site list as “neutral”, like this:

 

<site url="login.contoso.com">

        <compat-mode>default</compat-mode>

        <open-in>Neutral</open-in>

    </site>

@Adrian_Guta 

 

Thanks Adrian, that did the trick!  Not having our authentication site in the list caused the issue, but adding it and setting it to Neutral (or setting it to None) works and our site that we wanted to get redirected to IEMode works as expected, and authenticates as expected.  

 

Appreciate it!

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies