FYI regarding PDFs

Trusted Contributor

Feedback: Following "Try It" request.

I tried this in both Dev & Canary.  I used the highlighted method. They opened fine, all 'controls' worked just fine.  Whole effort was or seemed snag-free.



19 Replies
yep, same here...
Yes, me too, all working fine as far as i can tell.
It worked fine at my end.
pdf reader working fine without any issue....but some editing and annotation features are abscent.

Sad to say it's not working at all for me. I've tryed severial times and all I get is an option to save to my downloads and never able to open them in the browser. This is happening no matter if the file is on the web or on my computer. I've set Edge Dev as my default for opening .pdf and as my default web browser. One question I have is this just working with the canary builds because I'm using the beta version. @Drew1903 

Correction using Edge Dev version :face_with_rolling_eyes:
For me, the down loads show in the lower left of the browser where I am able to click it and it opens the file in the browser.......



1st line from my OP, "I tried this in both Dev & Canary.".


I also have them popup at the same place but when I click on them it just goes back to downloading window again. I'm not sure if this is user error or a bug but I'm thinking a bug. I probably tried about a dozen times changing different settings and from different locations no luck. If anyone has any  suggestions of something to try I'll try it. Other than that I'll wait for the next update and try again. @Dennis5mile 

Sorry reading comprehension on me:\


Ok, on the surface & from this vantage point, this doesn't make any, obvious, sense when, it is 'plug-n-play' for everyone (else).  But, I'll make a couple of suggestions and with no guarantee of anything.  Close your Dev, completely & refire it.  As for this PDF excercise, put everything back to square one & try re-attempting to whole scenario from scratch.  In other words, basically, remove, refresh, re-install & redo the task.  Could, even, rebboot the machine.  I'm wondering, recommending to see what it does for you with all clean, cleared & tried anew.  Certainly, I am suggest this type of approach since, what is, actually, causing it is baffling & mysterious.  And, report the behavior you have to Mr. Smiley (Alt+Shift+I).


Tried all your suggestions and even uninstalled Edge Dev and reinstalled and still no luck. Something that I didn’t expect was when reinstalling Edge it was at the same state as it was when I uninstalled it. (same settings signed in etc. as when I uninstalled) not sure if this is registry settings not deleted or something the insider program keeps track of.

I’m going to keep playing with this and I think I’ll try the Canary build and see how that works for me. I did report this to Mr. Smiley when I first encountered it and will do so again with more details.

Thank for taking the time to offer the suggestions.



1st of all, you're welcome.  I am, very, anxious to know what you have with Canary!  It is darn cool to know you tried my suggestions; not, very, cool that there is no change.  I'll suggest all came back as it was, due to 'sign-in' or the power of your MS Acc't; if you do R&R the OS, will come back as 'YOU' upon sign-in.


 @Drew1903   I found it. In Settings>Site Permissions>PDF documents > Download PDF files instead of automatically opening them was set to on. I honestly don't remember turning this setting on when I first setup Edge Dev. 

I did install Canary and tried it without doing any changes except signing in and it worked perfectly. So I compared each setting between the two and noticed the difference (wasn't turned on in cannery) made the change and everything worked. If I turn on again it breaks again just keeps going back to the save to  download folder. 

Like I said I don't remember turning the setting on and it didn't get turned off when I used the Reset Settings option. I'm curious if this setting change causes problems for others or if it's just me.

Also like the Canary build too. I'm going to keep it setup basic might come in handy in the future.


So glad & good to hear, to know you discovered the problem :thumbs_up::thumbs_up: :clinking_beer_mugs:.  'Tis a bit odd as it, certainly, is Off by default.  No wonder it made no bleedin sense!  Sometimes it's best to just be happy with a solve than, (try to) find or explain the cause OR to put it another way, "fun with 'puters".

Myself, I run both Dev & Canary.  Just find it interesting and intriguing seeing them develop and fun comparing them.


I encountered no problems using pdf files with Canary. But I am missing the options available in current Edge.

I am pleased to hear that most of you are having good experiences with the PDF changes that we have enabled.  @SCook1280, If you wouldn't mind, can you use the in-app feedback (send-a-smile) to report this issue?  That will give us some telemetry that may help us better understand what is going on.  I have already tipped the PDF team off to your issue.  Thanks to everyone who has tried out our PDF functionality.

@Elliot Kirk 

Elliot, the issue scook had was corrected.  Was not a bug.  A Setting toggle was in the wrong position.  All ok, now.

However, please :folded_hands:, take the Full screen issue to the Edge C Team.  That scenario must (continue) to function as it does in Edge.

Oh & BTW, would you, please, check your PMs?  Thanks :thumbs_up::)


@Elliot Kirk  I have reported the issue through smiley ☺ and included a link to this discussion. It was a setting toggle that was switched on causing the problem . I can reproduce the issue by turning the setting back on again. This might be something that someone with better troubleshooting experience than me might try to see if its something that needs looked into more. Never know who else might change this setting in the future and experience the same issue.If there's anything else that you need from me just let me know.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
38 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies