Home

Enable PDF reader

%3CLINGO-SUB%20id%3D%22lingo-sub-747894%22%20slang%3D%22en-US%22%3ERe%3A%20Enable%20PDF%20reader%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-747894%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F318661%22%20target%3D%22_blank%22%3E%40mjl12%3C%2FA%3E%26nbsp%3B-%20I%20am%20not%20able%20to%20repro%2077.0.211.2%20(Dev)%20an%20do%20not%20get%20this%20message.%20I%20was%20not%20able%20to%20locate%20a%20specific%20setting%20in%20Microsoft%20Edge%20about%20PDF%20Reader%20settings.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWith%20that%2C%20lets%20take%20a%20look%20at%20Windows%20settings%20(I%20am%20going%20to%20assume%20Windows%2010%20in%20your%20scenario).%26nbsp%3B%3CSPAN%3EBy%20default%2C%20Windows%2010%20opens%20PDF%20files%20in%20Microsoft%20Edge.%26nbsp%3B%20Can%20you%20verify%20PDF%20file%20association%20in%20Settings%20per%20below%3F%20Note%20steps%20might%20vary%20slightly%20depending%20upon%20which%20version%20of%20Windows%2010%20you%20have%20installed.%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EFrom%20Windows%2010%2C%20open%20%3CSTRONG%3ESettings%3C%2FSTRONG%3E%2C%26nbsp%3Bgo%20to%20%3CSTRONG%3EApps%3C%2FSTRONG%3E%2C%20then%20%3CSTRONG%3EDefault%20app%3C%2FSTRONG%3Es.%26nbsp%3BScroll%20down%20to%20the%20link%26nbsp%3B%3CSTRONG%3EChoose%20default%20apps%20by%20file%20type%3C%2FSTRONG%3E%26nbsp%3Band%20click%20it.%26nbsp%3BFind%20the%20.pdf%20file%20extension%20on%20the%20left%20side.%20On%20the%20right%20side%2C%20select%20a%20application%20to%20open%20PDF%20files%20with%20(Microsoft%20Edge%20Dev%20in%20this%20example%20is%20what%20I%20am%20set%20at).%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3ELet%20me%20know%20if%20this%20resolves.%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-749929%22%20slang%3D%22en-US%22%3ERe%3A%20Enable%20PDF%20reader%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-749929%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F328980%22%20target%3D%22_blank%22%3E%40DarrenMH%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20don't%20want%20Edge%20Dev%20as%20my%20default%20app%20-%20I'm%20using%20another%20programme%20for%20that%2C%20at%20least%20until%20reading%20pdfs%20in%20Edge%20Dev%20is%20good.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20just%20want%20Edge%20Dev%20not%20to%20refuse%20to%20open%20pdfs.%20Offline%20I%20can%20right-click%20a%20pdf%20and%20open%20it%20in%20Edge%20(which%20also%20isn't%20the%20default%20App)%2C%20but%20I%20can't%20open%20it%20in%20Edge%20Dev.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOK%2C%26nbsp%3B%3CSPAN%3EI%20tried%20making%20Edge%20Dev%20the%20default%20App%2C%20and%20it%20still%20doesn't%20work.%20I%20get%20the%20same%20message%2C%20%22PDF%20reader%20is%20disabled%20in%20Microsoft%20Edge.%20To%20change%20preferences%2C%20go%20to%20Settings%20and%20enable%20PDF%20reader%22%20and%20I'm%20invited%20to%20%22Download%20file%22.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThere's%20no%20reference%20to%20Windows%20settings%2C%20it%20surely%20means%20Edge%20settings%2C%20so%20I'd%20like%20to%20find%20it%3C%2FSPAN%3E%3CSPAN%3E.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-746756%22%20slang%3D%22en-US%22%3EEnable%20PDF%20reader%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-746756%22%20slang%3D%22en-US%22%3E%3CDIV%20class%3D%22top-container%22%3E%3CDIV%20class%3D%22title-container%22%3E%3CDIV%3EI'm%20trying%20to%20test%20the%20PDF%20reader%20in%20the%20latest%20build%20(%3CSPAN%3E77.0.211.2%3C%2FSPAN%3E)%20and%20I'm%20getting%20the%20message%20%3A%3C%2FDIV%3E%3CDIV%3E%22PDF%20reader%20is%20disabled%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CDIV%20class%3D%22body-container%22%3E%3CDIV%3E%26nbsp%3BPDF%20reader%20is%20disabled%20in%20Microsoft%20Edge.%3C%2FDIV%3E%3CDIV%3E%26nbsp%3BTo%20change%20preferences%2C%20go%20to%20Settings%20and%20enable%20PDF%20reader%22%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EI%20can't%20find%20how%20to%20do%20this%20anywhere%20in%20the%20settings.%3C%2FDIV%3EDo%20I%20need%20to%20reset%20something%3F%3C%2FDIV%3E%3CDIV%20class%3D%22body-container%22%3E%3CP%3E%3CBR%20%2F%3E%3CSTRONG%3EUPDATE%20%3C%2FSTRONG%3E%3A%2030%2F07%2F2019%20-%20I%20finally%20fixed%20it%20myself.%20I%20don't%20know%20if%20this%20option%20was%20there%20before%2C%20or%20why%20I%20might%20have%20selected%20it%2C%20but%20in%20%3CEM%3E'Settings%2C%20Site%20Permissions%2C%20PDF%20documents'%3C%2FEM%3Ethe%20option%20to%20%3CEM%3E%22Always%20open%20PDF%20files%20externally%22%3C%2FEM%3Ewas%20selected.%26nbsp%3B%20Now%20it%20isn't%2C%20and%20pdfs%20open%20in%20Edge%20Dev%20as%20they%20should.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E
Highlighted
Deleted
Not applicable
I'm trying to test the PDF reader in the latest build (77.0.211.2) and I'm getting the message :
"PDF reader is disabled
 PDF reader is disabled in Microsoft Edge.
 To change preferences, go to Settings and enable PDF reader"
 
I can't find how to do this anywhere in the settings.
Do I need to reset something?


UPDATE : 30/07/2019 - I finally fixed it myself. I don't know if this option was there before, or why I might have selected it, but in 'Settings, Site Permissions, PDF documents' the option to "Always open PDF files externally" was selected.  Now it isn't, and pdfs open in Edge Dev as they should.

 

2 Replies

Hi @Deleted - I am not able to repro 77.0.211.2 (Dev) an do not get this message. I was not able to locate a specific setting in Microsoft Edge about PDF Reader settings.

 

With that, lets take a look at Windows settings (I am going to assume Windows 10 in your scenario). By default, Windows 10 opens PDF files in Microsoft Edge.  Can you verify PDF file association in Settings per below? Note steps might vary slightly depending upon which version of Windows 10 you have installed.

 

From Windows 10, open Settings, go to Apps, then Default apps. Scroll down to the link Choose default apps by file type and click it. Find the .pdf file extension on the left side. On the right side, select a application to open PDF files with (Microsoft Edge Dev in this example is what I am set at).

 

Let me know if this resolves.

 

 

Thanks @DarrenMH 

 

I don't want Edge Dev as my default app - I'm using another programme for that, at least until reading pdfs in Edge Dev is good.

 

I just want Edge Dev not to refuse to open pdfs. Offline I can right-click a pdf and open it in Edge (which also isn't the default App), but I can't open it in Edge Dev. 

 

OK, I tried making Edge Dev the default App, and it still doesn't work. I get the same message, "PDF reader is disabled in Microsoft Edge. To change preferences, go to Settings and enable PDF reader" and I'm invited to "Download file".

 

There's no reference to Windows settings, it surely means Edge settings, so I'd like to find it.

 

Thanks

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies