SOLVED
Home

Edge constantly asking for permission to "Access Your Location"

%3CLINGO-SUB%20id%3D%22lingo-sub-832463%22%20slang%3D%22en-US%22%3EEdge%20constantly%20asking%20for%20permission%20to%20%22Access%20Your%20Location%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-832463%22%20slang%3D%22en-US%22%3E%3CP%3E1%20of%20the%20%22Features%22%20of%20update%2078.0.249.1%20was%20stated%20as%20%22Added%20a%20warning%20message%20when%20giving%20websites%20permission%20to%20access%20a%20device%E2%80%99s%20location%20if%20Windows%2010%E2%80%99s%20global%20location%20permission%20is%20disabled.%22.%20This%20is%20far%20from%20a%20%22Feature%22%2C%20instead%20it's%20a%20complete%20harassment%20when%20you%20want%20to%20leave%20your%20location%20information%20turned%20off%20for%20privacy%20issues.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20if%20there's%20a%20way%20to%20stop%20from%20getting%20the%20pop-up%3A%3CBR%20%2F%3E%3CEM%3E%22Allow%20Windows%20to%20access%20your%20location%3F%22%20Windows%20just%20got%20have%20access%20to%20your%20location.%20For%20Edge%20to%20access%2C%20you%20must%20first%20allow%20Windows%20to%20access%20your%20location.%20Do%20you%20want%20to%20open%20settings%20to%20allow%20Windows%20access%20to%20your%20location%3F%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-832480%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20constantly%20asking%20for%20permission%20to%20%22Access%20Your%20Location%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-832480%22%20slang%3D%22en-US%22%3EWhen%20you%20disabled%20location%20from%20Windows%20settings%2C%20did%20you%20also%20disable%20location%20from%20the%20browser%20settings%3F%3CBR%20%2F%3Eedge%3A%2F%2Fsettings%2Fcontent%2Flocation%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-832488%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20constantly%20asking%20for%20permission%20to%20%22Access%20Your%20Location%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-832488%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3Ethe%20only%20thing%20I%20could%20find%20regarding%20location%20is%20shown%20in%20the%20screenshot%20below.%20I've%20have%20it%20set%20like%20this%20for%20quite%20a%20while.%20Is%20this%20is%20that%20you're%20talking%20about%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.dropbox.com%2Fs%2Fnymy67m005i7iq0%2FCapture.JPG%3Fdl%3D0%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.dropbox.com%2Fs%2Fnymy67m005i7iq0%2FCapture.JPG%3Fdl%3D0%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-832494%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20constantly%20asking%20for%20permission%20to%20%22Access%20Your%20Location%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-832494%22%20slang%3D%22en-US%22%3EYes%20i'm%20talking%20about%20that%20option%20but%20i%20can't%20see%20in%20the%20picture%20whether%20it's%20off%20or%20on.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-832498%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20constantly%20asking%20for%20permission%20to%20%22Access%20Your%20Location%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-832498%22%20slang%3D%22en-US%22%3EIt's%20turned%20off%20and%20has%20been%20since%20I%201st%20installed%20the%20developmental%20version%20of%20Edge%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-832508%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20constantly%20asking%20for%20permission%20to%20%22Access%20Your%20Location%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-832508%22%20slang%3D%22en-US%22%3EGood%2C%20can%20you%20also%20try%20turning%20off%20notifications%3F%3CBR%20%2F%3Eedge%3A%2F%2Fsettings%2Fcontent%2Fnotifications%3CBR%20%2F%3Ethen%20see%20if%20you%20still%20get%20location%20spams.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-832541%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20constantly%20asking%20for%20permission%20to%20%22Access%20Your%20Location%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-832541%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%20I%20didn't%20have%20that%20turned%20off.%20Looks%20like%20that%20took%20care%20of%20the%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-832548%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20constantly%20asking%20for%20permission%20to%20%22Access%20Your%20Location%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-832548%22%20slang%3D%22en-US%22%3EThat's%20good%2C%20you're%20welcome%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E
MSRadell
Occasional Contributor

1 of the "Features" of update 78.0.249.1 was stated as "Added a warning message when giving websites permission to access a device’s location if Windows 10’s global location permission is disabled.". This is far from a "Feature", instead it's a complete harassment when you want to leave your location information turned off for privacy issues.

 

Does anyone know if there's a way to stop from getting the pop-up:
"Allow Windows to access your location?" Windows just got have access to your location. For Edge to access, you must first allow Windows to access your location. Do you want to open settings to allow Windows access to your location?

7 Replies
When you disabled location from Windows settings, did you also disable location from the browser settings?
edge://settings/content/location

@HotCakeXthe only thing I could find regarding location is shown in the screenshot below. I've have it set like this for quite a while. Is this is that you're talking about?

 

https://www.dropbox.com/s/nymy67m005i7iq0/Capture.JPG?dl=0

 

Yes i'm talking about that option but i can't see in the picture whether it's off or on.
It's turned off and has been since I 1st installed the developmental version of Edge
Solution
Good, can you also try turning off notifications?
edge://settings/content/notifications
then see if you still get location spams.

@HotCakeX 

Thanks, I didn't have that turned off. Looks like that took care of the problem.

 

Thanks!

That's good, you're welcome :)
Related Conversations