Home

Disable autofill of forms

%3CLINGO-SUB%20id%3D%22lingo-sub-450039%22%20slang%3D%22en-US%22%3EDisable%20autofill%20of%20forms%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-450039%22%20slang%3D%22en-US%22%3E%3CP%3EIn%20Microsoft%20Edge%20Insider%20(dev%20branch)%2C%20when%20I%20type%20into%20a%20text%20box%20in%20a%20form%2C%20a%20drop-down%20sometimes%20appears%20containing%20all%20prior%20values%20I%20ever%20typed%20into%20that%20textbox.%20I%20cannot%20remove%20entries%20from%20the%20drop-down%2C%20nor%20can%20I%20disable%20the%20drop-down%20entirely.%20I%20looked%20at%20edge%3A%2F%2Fflags%2C%20but%20nothing%20jumped%20out%20at%20me%20(most%20autofill%20options%20had%20to%20do%20with%20credit-card%20forms%2C%20which%20is%20not%20what%20I%20am%20dealing%20with%20here)%2C%20and%20the%20few%20options%20that%20seemed%20relevant%20did%20nothing.%20I%20would%20greatly%20appreciate%20it%20if%20this%20drop-down%20can%20be%20permanently%20disabled%20for%20all%20websites%2C%20as%20I%20do%20not%20like%20it%20one%20bit.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESteps%20to%20reproduce%3A%3C%2FP%3E%3COL%3E%3CLI%3EGo%20to%20%3CA%20href%3D%22https%3A%2F%2Fchocolatey.org%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fchocolatey.org%2F%3C%2FA%3E%20(this%20is%20where%20I%20saw%20the%20issue)%3C%2FLI%3E%3CLI%3EClick%20in%20the%20search%20box%20at%20the%20top%20of%20the%20page.%20Type%20something%20(%22paint.net%22%2C%20for%20example)%2C%20and%20press%20Enter.%3C%2FLI%3E%3CLI%3EOpen%20a%20new%20tab%2C%20and%20go%20to%20%3CA%20href%3D%22https%3A%2F%2Fchocolatey.org%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fchocolatey.org%2F%3C%2FA%3E%20again.%3C%2FLI%3E%3CLI%3EClick%20in%20the%20search%20box%2C%20and%20observe%20the%20pop-up%20that%20appears%20with%20the%20previous%20values%20typed%20into%20that%20search%20box.%3C%2FLI%3E%3C%2FOL%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-451238%22%20slang%3D%22en-US%22%3ERe%3A%20Disable%20autofill%20of%20forms%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-451238%22%20slang%3D%22en-US%22%3EThank%20you%20for%20your%20feedback%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F320660%22%20target%3D%22_blank%22%3E%40Sunburst%3C%2FA%3E.%20I%20will%20let%20the%20autofill%20team%20know%20about%20this%20issue.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-644981%22%20slang%3D%22en-US%22%3ERe%3A%20Disable%20autofill%20of%20forms%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-644981%22%20slang%3D%22en-US%22%3E%3CP%3EI%2C%20on%20the%20other%20hand%2C%20want%20form%20field%20to%20auto-fill%2C%20but%20it's%20not%20happening%20and%20I%20don't%20see%20how%20to%20turn%20it%20on.%20I%20like%20it%20use%20it%20to%20remember%20my%20customer%20number%20on%20the%20Dell%20recent%20orders%20page%20(%3CA%20href%3D%22https%3A%2F%2Fwww.dell.com%2Fsupport%2Forders%2Fus%2Fen%2F19%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.dell.com%2Fsupport%2Forders%2Fus%2Fen%2F19%3C%2FA%3E)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20on%20Edge%26nbsp%3B%3CSPAN%3EVersion%2076.0.159.0%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-781238%22%20slang%3D%22en-US%22%3ERe%3A%20Disable%20autofill%20of%20forms%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-781238%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F320660%22%20target%3D%22_blank%22%3E%40Sunburst%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20only%20or%20sensitive%20information%2C%20sometime%20is%20really%20annoying%20when%20you%20use%20TAB%20to%20jump%20into%20forms%20space%2C%20all%20information%20appears%20in%20a%20drop%20down%20menu.%20Will%20be%20really%20nice%20if%20there%20is%20a%20way%20to%20turned%20off.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Sunburst
New Contributor

In Microsoft Edge Insider (dev branch), when I type into a text box in a form, a drop-down sometimes appears containing all prior values I ever typed into that textbox. I cannot remove entries from the drop-down, nor can I disable the drop-down entirely. I looked at edge://flags, but nothing jumped out at me (most autofill options had to do with credit-card forms, which is not what I am dealing with here), and the few options that seemed relevant did nothing. I would greatly appreciate it if this drop-down can be permanently disabled for all websites, as I do not like it one bit.

 

Steps to reproduce:

  1. Go to https://chocolatey.org/ (this is where I saw the issue)
  2. Click in the search box at the top of the page. Type something ("paint.net", for example), and press Enter.
  3. Open a new tab, and go to https://chocolatey.org/ again.
  4. Click in the search box, and observe the pop-up that appears with the previous values typed into that search box.
3 Replies
Thank you for your feedback @Sunburst. I will let the autofill team know about this issue.

I, on the other hand, want form field to auto-fill, but it's not happening and I don't see how to turn it on. I like it use it to remember my customer number on the Dell recent orders page (https://www.dell.com/support/orders/us/en/19)

 

This is on Edge Version 76.0.159.0

@Sunburst 

 

Not only or sensitive information, sometime is really annoying when you use TAB to jump into forms space, all information appears in a drop down menu. Will be really nice if there is a way to turned off.