Dev channel update to is live

David Rubino

Hello insiders! Today we released build to the Microsoft Edge Dev Channel.  This is our very first update for the Mac Dev Channel, and as you can see below, we’re now including Mac changes in our release notes.  Some of the fixes and improvements that we believe are significant enough to mention include: 


Changes in feature behavior or appearance: 


  • Added the number of additional tabs present in the window title.
  • Fixed an issue where the + button to open new tabs is invisible.
  • Fixed an issue where corrupted characters appeared in certain parts of the UI like the address bar dropdown or the … menu.
  • Fixed an issue where clicking quickly on the X on entries on the history page would open them instead of deleting them.
  • Fixed an issue where clicking the “Remove All” button to remove all cookies doesn’t do anything.
  • Fixed an issue where the order of user profiles differed between the user flyout and the list in Settings.
  • Fixed an issue where signing out of user profiles didn’t work.
  • Fixed an issue where favorites sometimes don’t sync to other machines.
  • Fixed an issue where the Read Aloud bar sometimes takes a long time to appear.
  • Fixed an issue where entries on the history or download pages overlap at narrow window widths.


Fixes for better reliability and security: 


  • Fixed an issue where switching between user profiles sometimes crashes the browser.
  • Fixed an issue where sending feedback from a webpage that had crashed sometimes crashes the whole browser.
  • Fixed an issue where the browser sometimes hangs when it’s closed.
  • Updated to the latest version of Adobe Flash Player (


Mac-specific changes:


  • Fixed an issue where the browser sometimes doesn’t launch.
  • Fixed an issue where video controls remained on the Touch Bar after leaving the page with the video.
  • Fixed an issue where refreshing the settings page caused certain UI buttons to appear to be disabled.
  • Fixed an issue where menu text can appear white on white in certain situations.


Thank you all for being an insider, and a special thanks to all of our Mac users over the past few weeks for helping us get our Mac builds stable enough to release to the Dev Channel.  Keep sending us that feedback! 

32 Replies
I have been having my extensions either reset or corrupted. I created a ticket for it but I was wondering if anyone else has been having the same issue.

@David Rubino I reported "Fixed an issue where the + button to open new tabs is invisible." (as, I'm sure, did many others!) so thank you for the swift fix on this!


I also found one or two of the Canary builds to be very CPU intensive which this latest build seems to fix (mostly).


Looking forward to getting a lot of the old Edge UX back tho': more sync'ing, set tabs aside, sharing, Cortana integration!


@David Rubino Thanks for including Mac users now. But for me, I'd rather like to see the new Edge coming to Win Server. Are there any plans on this? Like in this thread discussed: https://techcommunity.microsoft.com/t5/Discussions/new-Edge-for-RDS-Server-2016-2019/m-p/481805

@David Rubino have you planned when we have the password sync enabled?

I have told this earlier that voice is not working on google search and google translate but the issue is still there and hasn't been solves. Please look into it and fix it.


In the last version, it seemed that my Evernote Web Clipper (an extension from the Chrome extension shop) was currupted; I couldn't get it to work. It's working again.

@David Rubino  There's an issue with LastPass Extension - first it got corrupted, then I couldn't log-in.  That occurred with the June 4th update I think.  It fails to log-in after Multifactor identification (UbiKey). I tried also removing and installing it again - same issue. I have to stop using Edge Chromium for the time being, as without LastPass I can't do anything (I went back to the old Edge)

Just a quick note to say I was really not sure about this venture. I am not a chrome fan, but this is turning into a great program. It is starting to feel like Edge, but W/O the memory problems. Very smooth on my new machine and Nimbal. DOn't get used to me talking nice though.@David Rubino 

I have the same issue; Ublock Origin (installed from the Chrome Web Store) corrupts with regularity.

@David Rubino 


We have Conditional access polices set up via Azure for access to SharePoint / one drive in particular.


Using latest versions of Chrome, Edge and IE work as expected internally and will access these services correcly by allowing user to download and print etc.. Externally users get the massage "Your organization does not allow you to download... etc". As expected.


When connecting with the Dev version internally to Sharepoint online (Onedrive or any other sharepoint site) I get the following message "Your organization does not allow you to download... etc" 



Please add the old Edge UX like fluent in the tab bar. And Please remove the ugly Google context menu.

@l1234580 I found that this issue was not due to Edge, but also present in Chrome (which I'm not using anymore) and/or the Evernote Web Clipper. For those interested, see https://discussion.evernote.com/topic/120112-web-clipper-not-working/.  In any case, in the latest version of Edge and the Web Clipper it works again, and I didn't investigate in detail what the problem was.


Congratulations to the Edge team in providing such a stable dev-channel version, and making regular and good progress.



I just downloaded this Dev version and it does not load in Mac... it tries to run and then it closes... the same with Edge Feedback. The Canary version works fine.

@l1234580 : Maybe something related to this?

At the very least maybe worthwhile to check if you now have a patched version. 

The + button (and some overflowing tabs) being invisible doesn't appear fixed over here. Maybe it's another issue though ? I already reported it before so I'm not sure if I should report again image.png @David Rubino 

@Donkz wrote:

@l1234580 : Maybe something related to this?

At the very least maybe worthwhile to check if you now have a patched version. 

@Donkz: Yes, that's the one, and yes, it updated automatically, and I took my precautions. Again, not an Edge problem. 

@David Rubino When going full screen in either YouTube or Twitch the ui does not fully go away 100% of the time. More often than not it'll become transparent but still visible enough to see. It takes multiple attempts of exiting full screen and re-entering it to make the ui go away.Screenshot (8).png

@David Rubino 

The release version of Edge has a dark mode which is independent from any dark mode settings in Windows or apps.  Will that be implemented in this new Edge?

@David Rubino 

On fontlot.com I find that font samples render on top of what appears to be alt-text descriptions. Reported last week on the prior version. Will report for this version in a moment. Sample screenshot shows Edge Chromium on the left, Chrome 74.0.3729.169 on the right.



@fjose Very annoying on my dual screen setup, most of the time, the YouTube UI will remain visible on my second screen. Doesn't happen with Chrome.


I see the problem in a normal windowed mode:


If I move the cursor in and out of the video - just on the edge of the video - I can get it to come out really often. When it is with the barely visible YouTube controls (like the picture) it stays like this, until the mouse cursor has moved over something (like a link or text input box) that changes the cursor, where the YouTube controls disappears. Also, if I move the mouse up to a favorite in the favorite bar, the YouTube controls also disappears.

The screenshot is from here: https://www.petri.com/a-little-about-powerapps-a-lot-about-flow

@JoveroIV Yes, Adblock was crashing for me, but reinstalling stopped it from crashing! I think it was the extensions being corrupt, but a reinstall should help! Also, if you downloaded the extension from the chrome web store, try checking if the same extensions are on the official store!


@David Rubino awesome fix to history "X" clicking quickly.  That was a bit annoying.  Edge is so much faster due to the new foundation.

@Deleted, you might want to remove the Chrome store version of Ublock and install it from the Microsoft store. I have the Microsoft store version and it has never corrupted. (Dev version)


@awesomekalin For me, it would corrupt again after reinstalling.

@PlamenVT  For what it's worth, I have been using the MS extension for LastPass (currently 4.29.0) since the extension was first available in EdgeDev.  I use 2FA sign in, but DUO and not Ubikey.  When authenticating, the LastPass extension will complete sign in, but always with an error suggesting it had trouble contacting the server.  Despite this error, sign in is approved.  I've tested disapproving the sign in with the response that MFA failed - and I (thankfully) do not get access to the account when disapproved.  So, the short of this (outside of providing the alternate detail for our MS friends), is that temporarily moving from your hardware key to another form of MFA may keep you running in the interim.  



This bug would be bothersome. I can't reproduce it: I moved the mouse in and out, but each time, the YouTube UI immediately faded away completely. Because it's so bothersome, I feel like I have a civic duty to troubleshoot. What GPU are you using?


Perhaps a new thread on this could help gather more info.


I'm on Windows 10 Pro x64 1803 (17134.829), an i5-6200U iGPU (driver, and Chromium Edge Version (Official build) dev (64-bit).


I've just tested it again and I still have the problem. I have attached a (poor) GIF of the problem. The GIF show the problem and at the end, I move the cursor over a link and the problem disappears.


Windows 10 Pro x64 1903 (build 18362.175)

i7-7500U CPU

Intel HD620 (driver

Chromium Edge Version (Official build) dev (64-bit)


@ahl2ndc That's crazy weird: we have similar enough systems, though different Windows builds & GPU drivers. 

I'm at a loss here. Is this bug still happening on newer Edge versions?


@ikjadoon I've just tested it again - no problems now. Before I could get it to fail within a few tries - now I have tried 50 or so times with no problem with this build:

Version (Official build) dev (64-bit)
Just saw a new build has come up, but can't restart the browser just yet to test it out. But most likely it will still work in the new build.

The issue I had with failed sign-in of LastPass with UbiKey is now fixed with the latest update.


Log-in is successful with no issues. Worked on both Win 8.1 & Win10.

Likewise --- no more errors logging into LastPass while running Dev channel Version (with LastPass extension 4.29.0). Thank you.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
38 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
12 Replies