Home

After changing your Diagnostic data setting, we recommend you restart the browser

%3CLINGO-SUB%20id%3D%22lingo-sub-813794%22%20slang%3D%22en-US%22%3EAfter%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-813794%22%20slang%3D%22en-US%22%3E%3CP%3ESince%20I%20installed%20the%20beta%20channel%20build%2C%20I'm%20regularly%20getting%20this%20popup%20on%20my%20work%20system%20(every%20hour%20or%20so%3F).%26nbsp%3B%20I've%20been%20hitting%20%22not%20now%22.%26nbsp%3B%20Once%20I%20hit%20%22restart%22%20and%20the%20browser%20restarted%2C%20and%20it%20came%20back%20with%20the%20same%20prompt%20again%20immediately.%26nbsp%3B%20I%20am%20not%20making%20any%20change%20to%20the%20%22diagnostic%20data%20setting%22%20to%20prompt%20it%2C%20but%20we%20do%20have%20AD%20managing%20the%20Windows%2010%20diagnostic%20data%20settings%20with%20group%20policy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20463px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F127698iE06C2776CCD3F070%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-08-20%20172006.png%22%20title%3D%22Annotation%202019-08-20%20172006.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-814757%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-814757%22%20slang%3D%22en-US%22%3E%3CP%3EInstalled%20the%20beta%20this%20morning%20and%20I'm%20getting%20this%20all%20the%20time%20too.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEdge%20also%20seems%20to%20crash%20when%20I%20undock%2Fredock%20my%20laptop.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-815525%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-815525%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317827%22%20target%3D%22_blank%22%3E%40Aaron44126%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESame%20thing....%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-815770%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-815770%22%20slang%3D%22en-US%22%3ECanary%2C%20as%20opposed%20to%20what%20majority%20think%2C%20is%20fully%20stable.%20I've%20Installed%20it%20on%20many%20different%20machines%20ranging%20from%20a%20laptop%20from%202009%20to%20Windows%20server%202019%20AD%2FDC.%3CBR%20%2F%3EIMO%20it%20was%20too%20early%20to%20release%20the%20beta%20channel%2C%20so%20many%20fixes%20and%20features%20are%20missing.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-818291%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-818291%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317827%22%20target%3D%22_blank%22%3E%40Aaron44126%3C%2FA%3E%26nbsp%3BExact%20same%20issue%20in%20our%20organization.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-818468%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-818468%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20seems%20that%20if%20I%20select%20%22Not%20now%22%2C%20then%20as%20long%20as%20I%20don't%20close%20the%20browser%2C%20it%20won't%20ask%20again.%26nbsp%3B%20If%20I%20close%20and%20restart%20Edge%20then%20it%20will%20pop%20up%20again%20in%20short%20order.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-818522%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-818522%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317827%22%20target%3D%22_blank%22%3E%40Aaron44126%3C%2FA%3E%2C%20we%20are%20aware%20of%20this%20issue%2C%20and%20have%20a%20bug%20tracking%20it.%26nbsp%3B%20IT%20appears%20to%20be%20an%20issue%20where%20a%20settings%20changes%2C%20often%20due%20to%20a%20group%20policy%20or%20similar%20mechanism%2C%20then%20the%20setting%20switches%20back%20immediately.%20At%20this%20point%20we%20don't%20have%20a%20work%20around%2C%20but%20as%20soon%20as%20we%20do%2C%20I%20will%20post%20it%20here.%3C%2FP%3E%0A%3CP%3EThanks%20-%20Elliot%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-820116%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-820116%22%20slang%3D%22en-US%22%3EWould%20be%20great%20to%20see%20a%20fix%20or%20a%20workaround%20for%20this.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-878239%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-878239%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F239638%22%20target%3D%22_blank%22%3E%40Elliot%20Kirk%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20Beta%20channel%20received%20first%20update%20today%20and%20updated%20to%26nbsp%3B%3CSPAN%3EVersion%2078.0.276.8%20(Official%20build)%20beta%20(64-bit).%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThis%20issue%20was%20not%20there%20before%20this%20major%20update%20but%20as%20soon%20as%20I%20restarted%20the%20browser%20after%20this%20major%20update%2C%20this%20issue%20started%20appearing.%20I%20am%20also%20on%20my%20work%20network%20using%20Windows%2010%20x64.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20have%20noticed%20this%20issue%20first%20time%20when%20I%20have%20installed%20the%20very%20first%20release%20of%20Beta%20channel%20(77.0.235.9)%20when%20it%20was%20released%20but%20then%20it%20was%20resolved%20for%20some%20minor%20update%20to%20Beta%20channel.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFixing%20this%20will%20help%20a%20lot%20as%20its%20annoying.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-890294%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-890294%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20also%20noticed%20one%20more%20trend%20on%20this%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20lock%20my%20computer%20and%20then%20unlock%20next%20time%20with%20the%20browser%20open%20on%20my%20system%2C%20this%20message%20appears%20every%20single%20time%20as%20soon%20as%20I%20log%20in.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESame%20scenario%20goes%20with%20putting%20the%20system%20in%20sleep%20mode%20and%20then%20wake%20up%20and%20log%20in%20again%2C%20it%20gives%20error%20message%20every%20single%20time.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20believe%20system%20changes%20being%20applied%20when%20logging%20into%20Windows%20and%20causing%20this%20issue%20!%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-977720%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-977720%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F423052%22%20target%3D%22_blank%22%3E%40Bryce117%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWe%20just%20checked%20with%20the%20most%20recent%20beta%20x.24%20and%20still%20run%20into%20the%20notification%20after%20each%20policy%20refresh%2C%20so%20unfortunately%20not%20fixed%20yet.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-902899%22%20slang%3D%22en-US%22%3ERe%3A%20After%20changing%20your%20Diagnostic%20data%20setting%2C%20we%20recommend%20you%20restart%20the%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-902899%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20behavior%20most%20likely%20is%20caused%20by%20Windows%20Diagnostic%20setting%20being%20controlled%20by%20GPO.%20According%20to%20Edge%20Beta%20documentation%2C%20the%20browser%20looks%20to%20Windows%20Diagnostic%20setting%20if%20a%20browser%20defined%20diagnostic%20data%20level%20hasn't%20been%20set%20to%20determine%20what%20data%20to%20send%20to%20Microsoft.%20If%20on%20Edge%20Dev%20channel%2C%20I%20think%20it%20just%20looks%20to%20the%20browser%2Fuser%20setting.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20started%20noticing%20this%20on%2078.0.276.8%20also%20on%2078.0.276.11.%26nbsp%3B%20We%20are%20hoping%20with%20recent%20minor%20update%20release%20of%2078.0.276.14%20and%20updating%20our%20Edge%20GPO%20template%20to%20match%2C%20this%20issue%20goes%20away.%20Pending%20feedback%20as%20not%20every%20user%20experiences%20the%20problem%20despite%20having%20same%20RSOP.%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317827%22%20target%3D%22_blank%22%3E%40Aaron44126%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Aaron44126
Contributor

Since I installed the beta channel build, I'm regularly getting this popup on my work system (every hour or so?).  I've been hitting "not now".  Once I hit "restart" and the browser restarted, and it came back with the same prompt again immediately.  I am not making any change to the "diagnostic data setting" to prompt it, but we do have AD managing the Windows 10 diagnostic data settings with group policy.

 

Annotation 2019-08-20 172006.png

11 Replies

Installed the beta this morning and I'm getting this all the time too.

 

Edge also seems to crash when I undock/redock my laptop.

Canary, as opposed to what majority think, is fully stable. I've Installed it on many different machines ranging from a laptop from 2009 to Windows server 2019 AD/DC.
IMO it was too early to release the beta channel, so many fixes and features are missing.

It seems that if I select "Not now", then as long as I don't close the browser, it won't ask again.  If I close and restart Edge then it will pop up again in short order.

Hi @Aaron44126, we are aware of this issue, and have a bug tracking it.  IT appears to be an issue where a settings changes, often due to a group policy or similar mechanism, then the setting switches back immediately. At this point we don't have a work around, but as soon as we do, I will post it here.

Thanks - Elliot

Would be great to see a fix or a workaround for this.

@Elliot Kirk 

 

My Beta channel received first update today and updated to Version 78.0.276.8 (Official build) beta (64-bit).

 

This issue was not there before this major update but as soon as I restarted the browser after this major update, this issue started appearing. I am also on my work network using Windows 10 x64.

 

I have noticed this issue first time when I have installed the very first release of Beta channel (77.0.235.9) when it was released but then it was resolved for some minor update to Beta channel.

 

Fixing this will help a lot as its annoying.

Thanks.

I have also noticed one more trend on this issue.

 

When I lock my computer and then unlock next time with the browser open on my system, this message appears every single time as soon as I log in.

 

Same scenario goes with putting the system in sleep mode and then wake up and log in again, it gives error message every single time.

 

I believe system changes being applied when logging into Windows and causing this issue !?

This behavior most likely is caused by Windows Diagnostic setting being controlled by GPO. According to Edge Beta documentation, the browser looks to Windows Diagnostic setting if a browser defined diagnostic data level hasn't been set to determine what data to send to Microsoft. If on Edge Dev channel, I think it just looks to the browser/user setting.

 

We started noticing this on 78.0.276.8 also on 78.0.276.11.  We are hoping with recent minor update release of 78.0.276.14 and updating our Edge GPO template to match, this issue goes away. Pending feedback as not every user experiences the problem despite having same RSOP.  @Aaron44126 

@Bryce117 

 

We just checked with the most recent beta x.24 and still run into the notification after each policy refresh, so unfortunately not fixed yet. 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies