SOLVED
Home

connect-pnpmicrosoftgraph Has Been Deprecated

%3CLINGO-SUB%20id%3D%22lingo-sub-134428%22%20slang%3D%22en-US%22%3Econnect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-134428%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20script%20that%20creates%20an%20Office%20365%20group%20and%20the%20associated%20SharePoint%20site%20using%20PnP%20PowerShell.%26nbsp%3B%20I%20recently%20updated%20the%20SharePointPnPPowerShell%20assemblies%20to%20version%202.20.1711.0.%26nbsp%3B%20Now%20I'm%20getting%20a%20warning%20that%20connect-pnpmicrosoftgraph%20has%20been%20deprecated%20and%20will%20be%20removed%20in%20April%202018.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20have%20found%20that%20connect-pnponline%20is%20it's%20replacement%20but%20I'm%20having%20trouble%20connecting.%26nbsp%3B%20For%20connect-pnpmicrosoftgraph%2C%20I'm%20using%3C%2FP%3E%0A%3CP%3E%24conn%20%3D%20connect-pnpmicrosoftgraph%20-AppId%20%24appid%20-AppSecret%20%24client_secret%20-AADDomain%20%22mydomain.onmicrosoft.com%22%20-Verbose%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWhen%20I%20look%20at%20the%20details%20of%20Connect-PnPOnline%20with%20Microsoft%20Graph%20using%20Azure%20Active%20Directory%2C%20I%20see%20the%20same%20parameters%2C%20but%20running%20this%20throws%20an%20error%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20412px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F25150iCF22812B5367AC07%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22image.png%22%20title%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CPRE%3Econnect-pnponline%20%3A%20Value%20cannot%20be%20null.%0AParameter%20name%3A%20uriString%0AAt%20line%3A1%20char%3A9%0A%2B%20%24conn%20%3D%20connect-pnponline%20-AppId%20%24appid%20-AppSecret%20%24client_secret%20-AA%20...%0A%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%0A%2B%20CategoryInfo%20%3A%20NotSpecified%3A%20(%3A)%20%5BConnect-PnPOnline%5D%2C%20ArgumentNullException%0A%2B%20FullyQualifiedErrorId%20%3A%20System.ArgumentNullException%2CSharePointPnP.PowerShell.Commands.Base.ConnectOnline%3C%2FPRE%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EUpon%20further%20investigation%2C%20it%20appears%20that%20AADDomain%20is%20incorrect%20and%20that%20I%20should%20be%20using%20url.%26nbsp%3B%20But%20I'm%20at%20a%20loss%20as%20to%20what%20I'm%20supposed%20to%20use%20here.%26nbsp%3B%20I've%20tried%20mydomain.onmicrosoft.com%2C%20but%20get%20an%20error%3C%2FP%3E%0A%3CPRE%3EConnect-PnPOnline%20%3A%20Invalid%20URI%3A%20The%20format%20of%20the%20URI%20could%20not%20be%20determined.%0AAt%20line%3A1%20char%3A1%0A%2B%20Connect-PnPOnline%20-url%20%22mydomain.onmicrosoft.com%22%20-AppId%20%22xxxxxxx-xxx%20...%0A%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%0A%20%20%20%20%2B%20CategoryInfo%20%20%20%20%20%20%20%20%20%20%3A%20NotSpecified%3A%20(%3A)%20%5BConnect-PnPOnline%5D%2C%20UriFormatException%0A%20%20%20%20%2B%20FullyQualifiedErrorId%20%3A%20System.UriFormatException%2CSharePointPnP.PowerShell.Commands.Base.ConnectOnline%3C%2FPRE%3E%0A%3CP%3ESo%20I%20tried%20%3CA%20href%3D%22https%3A%2F%2Fmydomain.onmicrosoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmydomain.onmicrosoft.com%3C%2FA%3E%2C%20but%20get%20this%20error%3C%2FP%3E%0A%3CPRE%3EConnect-PnPOnline%20%3A%20Token%20request%20failed.%0AAt%20line%3A1%20char%3A1%0A%2B%20Connect-PnPOnline%20-url%20%22https%3A%2F%2Fmydomain.onmicrosoft.com%22%20-AppId%20%22xxxx%20...%0A%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%0A%20%20%20%20%2B%20CategoryInfo%20%20%20%20%20%20%20%20%20%20%3A%20NotSpecified%3A%20(%3A)%20%5BConnect-PnPOnline%5D%2C%20RequestFailedException%0A%20%20%20%20%2B%20FullyQualifiedErrorId%20%3A%20Microsoft.IdentityModel.SecurityTokenService.RequestFailedException%2CSharePointPnP.PowerShell.Commands.Base.Conne%20%0A%20%20%20ctOnline%0A%3C%2FPRE%3E%0A%3CP%3ESame%20when%20I%20use%20%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%3C%2FA%3E%2C%20and%20%3CA%20href%3D%22https%3A%2F%2Fmydomain-admin.sharepoint.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmydomain-admin.sharepoint.com%3C%2FA%3E%3C%2FP%3E%0A%3CP%3EUsing%20%3CA%20href%3D%22https%3A%2F%2Fmydomain.sharepoint.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmydomain.sharepoint.com%3C%2FA%3E%20gives%20me%20a%20403%20forbidden%20error.%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWhat%20is%20the%20correct%20replacement%20URL%20for%20connect-pnpmicrosoftgraph%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-134428%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAPI%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%20Groups%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPnP%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-136959%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-136959%22%20slang%3D%22en-US%22%3E%3CP%3EHa!%20Got%20it.%20I%20just%20ran%20an%20install%20of%20the%20code%20rather%20than%20an%20update%3C%2FP%3E%0A%3CPRE%3Einstall-Module%20SharePointPnPPowerShellOnline%20-force%20-SkipPublisherCheck%3C%2FPRE%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-136957%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-136957%22%20slang%3D%22en-US%22%3E%3CP%3EAlthough%20I%20am%20getting%20this%20error%20when%20I%20update%20the%20module%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CPRE%3EPackageManagement%5CInstall-Package%20%3A%20Authenticode%20issuer%20'CN%3DMicrosoft%20Root%20Certificate%20Authority%202011%2C%20O%3DMicrosoft%0ACorporation%2C%20L%3DRedmond%2C%20S%3DWashington%2C%20C%3DUS'%20of%20the%20new%20module%20'SharePointPnPPowerShellOnline'%20with%20version%0A'2.21.1712.2'%20is%20not%20matching%20with%20the%20authenticode%20issuer%20'CN%3Dthawte%20Primary%20Root%20CA%2C%20OU%3D%22(c)%202006%20thawte%2C%20Inc.%20-%20For%0Aauthorized%20use%20only%22%2C%20OU%3DCertification%20Services%20Division%2C%20O%3D%22thawte%2C%20Inc.%22%2C%20C%3DUS'%20of%20the%20previously-installed%20module%0A'SharePointPnPPowerShellOnline'%20with%20version%20'2.20.1711.0'.%20If%20you%20still%20want%20to%20install%20or%20update%2C%20use%0A-SkipPublisherCheck%20parameter.%0AAt%20C%3A%5CProgram%20Files%5CWindowsPowerShell%5CModules%5CPowerShellGet%5C1.0.0.1%5CPSModule.psm1%3A2089%20char%3A20%0A%2B%20...%20%20%20%20%20%20%20%20%20%20%20%24sid%20%3D%20PackageManagement%5CInstall-Package%20%40PSBoundParameters%0A%2B%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%0A%20%20%20%20%2B%20CategoryInfo%20%20%20%20%20%20%20%20%20%20%3A%20InvalidOperation%3A%20(Microsoft.Power....InstallPackage%3AInstallPackage)%20%5BInstall-Package%5D%2C%0A%20%20%20Exception%0A%20%20%20%20%2B%20FullyQualifiedErrorId%20%3A%20AuthenticodeIssuerMismatch%2CValidate-ModuleAuthenticodeSignature%2CMicrosoft.PowerShell.Pac%0A%20%20%20kageManagement.Cmdlets.InstallPackage%3C%2FPRE%3E%0A%3CP%3EAfter%20I%20ran%26nbsp%3BUpdate-Module%20SharePointPnPPowerShell*%20and%20got%20the%20above%20error%2C%20the%20version%20numbers%20did%20increase%20to%20the%20current%20version%2C%20but%20I'm%20not%20sure%20if%20everything%20installed%20correctly.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-136950%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-136950%22%20slang%3D%22en-US%22%3E%3CP%3EI%20updated%20mine%20just%20now%20as%20well.%20Still%20no%20luck.%20I'm%20getting%20the%20same%20error.%26nbsp%3B%20I%20wonder%20what%20you're%20doing%20differently%20than%20me.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-136764%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-136764%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20-%20after%20downloading%20the%20latest%20version%20of%20Sharepoint%20PNP%20for%20Online%20it%20works%20as%20expected!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-136751%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-136751%22%20slang%3D%22en-US%22%3E%3CP%3EDid%20you%20find%20a%20solution%20for%20this%3F%20I%20am%20seeing%20the%20exact%20same%20thing%20when%20I%20change%20my%20working%20config%20using%20C%3CSPAN%3Eonnect-PnPMicrosoftGraph%20to%20%22Connect-PnPOnline%20-AppId%20'%3CID%3E'%20-AppSecret%20'%3CSECRET%3E'%20-AADDomain%20'contoso.onmicrosoft.com'%22...%3C%2FSECRET%3E%3C%2FID%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-135568%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-135568%22%20slang%3D%22en-US%22%3ESorry%2C%20can't%20help%20you%20any%20more%2C%20I%20have%20had%20to%20do%20a%20lot%20of%20trial%20and%20error%20with%20the%20various%20connection%20parameters%20to%20figure%20out%20what%20works%20for%20my%20customers%20tenants%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-135560%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-135560%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20is%20an%20automated%20script.%20I%20won't%20be%20logging%20in%20at%20anytime.%20That's%20why%20I%20set%20up%20the%20application.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-135559%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-135559%22%20slang%3D%22en-US%22%3E%3CP%3Eit%20depends%2C%20i%20entered%20my%20credentials%20and%20told%20the%20browser%20to%20keep%20me%20logged%20in%20several%20days%20ago%2C%20and%20have%20not%20logged%20in%20since%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-135558%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-135558%22%20slang%3D%22en-US%22%3E%3CP%3EDoesn't%20that%20require%20user%20interaction%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-135555%22%20slang%3D%22en-US%22%3ERe%3A%20connect-pnpmicrosoftgraph%20Has%20Been%20Deprecated%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-135555%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20using%20the%20following%20and%20it%20works%20fine.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CDIV%3E%0A%3CDIV%3E%3CSPAN%3E%24tenantUrl%20%3D%20'%3CA%20href%3D%22https%3A%2F%2Ftenant.sharepoint.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ftenant.sharepoint.com%3C%2FA%3E'%3C%2FSPAN%3E%3C%2FDIV%3E%0A%3CDIV%3E%0A%3CDIV%3E%0A%3CDIV%3E%3CSPAN%3EConnect-PnPOnline%3C%2FSPAN%3E%20%3CSPAN%3E%24%3C%2FSPAN%3E%3CSPAN%3EtenantUrl%3C%2FSPAN%3E%20%3CSPAN%3E-%3C%2FSPAN%3E%3CSPAN%3EUseWebLogin%3C%2FSPAN%3E%3C%2FDIV%3E%0A%3C%2FDIV%3E%0A%3C%2FDIV%3E%0A%3C%2FDIV%3E%3C%2FLINGO-BODY%3E
Robbert van Andel
Occasional Contributor

I have a script that creates an Office 365 group and the associated SharePoint site using PnP PowerShell.  I recently updated the SharePointPnPPowerShell assemblies to version 2.20.1711.0.  Now I'm getting a warning that connect-pnpmicrosoftgraph has been deprecated and will be removed in April 2018. 

 

I have found that connect-pnponline is it's replacement but I'm having trouble connecting.  For connect-pnpmicrosoftgraph, I'm using

$conn = connect-pnpmicrosoftgraph -AppId $appid -AppSecret $client_secret -AADDomain "mydomain.onmicrosoft.com" -Verbose;

 

When I look at the details of Connect-PnPOnline with Microsoft Graph using Azure Active Directory, I see the same parameters, but running this throws an error

image.png

 

connect-pnponline : Value cannot be null.
Parameter name: uriString
At line:1 char:9
+ $conn = connect-pnponline -AppId $appid -AppSecret $client_secret -AA ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Connect-PnPOnline], ArgumentNullException
+ FullyQualifiedErrorId : System.ArgumentNullException,SharePointPnP.PowerShell.Commands.Base.ConnectOnline

 

Upon further investigation, it appears that AADDomain is incorrect and that I should be using url.  But I'm at a loss as to what I'm supposed to use here.  I've tried mydomain.onmicrosoft.com, but get an error

Connect-PnPOnline : Invalid URI: The format of the URI could not be determined.
At line:1 char:1
+ Connect-PnPOnline -url "mydomain.onmicrosoft.com" -AppId "xxxxxxx-xxx ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Connect-PnPOnline], UriFormatException
    + FullyQualifiedErrorId : System.UriFormatException,SharePointPnP.PowerShell.Commands.Base.ConnectOnline

So I tried https://mydomain.onmicrosoft.com, but get this error

Connect-PnPOnline : Token request failed.
At line:1 char:1
+ Connect-PnPOnline -url "https://mydomain.onmicrosoft.com" -AppId "xxxx ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Connect-PnPOnline], RequestFailedException
    + FullyQualifiedErrorId : Microsoft.IdentityModel.SecurityTokenService.RequestFailedException,SharePointPnP.PowerShell.Commands.Base.Conne 
   ctOnline

Same when I use https://graph.microsoft.com, and https://mydomain-admin.sharepoint.com

Using https://mydomain.sharepoint.com gives me a 403 forbidden error. 

What is the correct replacement URL for connect-pnpmicrosoftgraph?

10 Replies

I'm using the following and it works fine.

 

Connect-PnPOnline $tenantUrl -UseWebLogin

Doesn't that require user interaction?

it depends, i entered my credentials and told the browser to keep me logged in several days ago, and have not logged in since

 

Highlighted

This is an automated script. I won't be logging in at anytime. That's why I set up the application.  

Sorry, can't help you any more, I have had to do a lot of trial and error with the various connection parameters to figure out what works for my customers tenants

Did you find a solution for this? I am seeing the exact same thing when I change my working config using Connect-PnPMicrosoftGraph to "Connect-PnPOnline -AppId '<id>' -AppSecret '<secret>' -AADDomain 'contoso.onmicrosoft.com'"...

Solution

So - after downloading the latest version of Sharepoint PNP for Online it works as expected!

I updated mine just now as well. Still no luck. I'm getting the same error.  I wonder what you're doing differently than me.

Although I am getting this error when I update the module

 

PackageManagement\Install-Package : Authenticode issuer 'CN=Microsoft Root Certificate Authority 2011, O=Microsoft
Corporation, L=Redmond, S=Washington, C=US' of the new module 'SharePointPnPPowerShellOnline' with version
'2.21.1712.2' is not matching with the authenticode issuer 'CN=thawte Primary Root CA, OU="(c) 2006 thawte, Inc. - For
authorized use only", OU=Certification Services Division, O="thawte, Inc.", C=US' of the previously-installed module
'SharePointPnPPowerShellOnline' with version '2.20.1711.0'. If you still want to install or update, use
-SkipPublisherCheck parameter.
At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\1.0.0.1\PSModule.psm1:2089 char:20
+ ...           $sid = PackageManagement\Install-Package @PSBoundParameters
+                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (Microsoft.Power....InstallPackage:InstallPackage) [Install-Package],
   Exception
    + FullyQualifiedErrorId : AuthenticodeIssuerMismatch,Validate-ModuleAuthenticodeSignature,Microsoft.PowerShell.Pac
   kageManagement.Cmdlets.InstallPackage

After I ran Update-Module SharePointPnPPowerShell* and got the above error, the version numbers did increase to the current version, but I'm not sure if everything installed correctly.

Ha! Got it. I just ran an install of the code rather than an update

install-Module SharePointPnPPowerShellOnline -force -SkipPublisherCheck

 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies