Home

nvidia openGL in Ubuntu not working

%3CLINGO-SUB%20id%3D%22lingo-sub-102949%22%20slang%3D%22en-US%22%3Envidia%20openGL%20in%20Ubuntu%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-102949%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Everyone%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20created%20a%20linux%20based%20VM%20in%20Azure%20which%20uses%20the%20Nvidia%20graphics%20cards%26nbsp%3Band%20i've%20been%20trying%20to%20get%20openGL%20working%20on%20my%20ubuntu%20azure%20machine%20and%20simply%20can't%20get%20it%20to%20work.%20I've%20wasted%2012hrs%20so%20far%20today%20and%20i'm%20tearing%20my%20hear%20out%20now.%20I've%20followed%20microsofts%20guide%20to%20the%20letter!%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Flinux%2Fn-series-driver-setup%3Ftoc%3D%252fazure%252fvirtual-machines%252flinux%252ftoc.json%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Flinux%2Fn-series-driver-setup%3Ftoc%3D%252fazure%252fvirtual-machines%252flinux%252ftoc.json%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20read%20tons%20of%20posts%20in%20other%20forums%2C%20none%20of%20them%20of%20any%20help.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ebasically%20whenever%20i%20try%20and%20run%20glxinfo%20i%20get%20the%20error%20%22couldn't%20find%20RGB%20GLX%20visual%20or%20fbconfig.%3C%2FP%3E%3CP%3EI%20can't%20run%20any%20openGL%20programs%20as%20it%20says%20that%20i%20don't%20have%20openGL.%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20uploaded%20my%20xorg%20log%20and%20i%20there's%20a%20line%20in%20there%20stating%20%22failed%20to%20initialize%20GLX%20extension%20(compatible%20nvidia%20x%20driver%20not%20found)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20also%20confirmed%20the%20drivers%20are%20installed%20correctly%20by%20running%20the%20%22nvidia-smi%22%20command%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eany%20help%20would%20be%20very%20much%20appreciated.%3C%2FP%3E%3CP%3ESal%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-102949%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ECompute%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENvidia%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EopenGL%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EVirtual%20Machine%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-751861%22%20slang%3D%22en-US%22%3ERe%3A%20nvidia%20openGL%20in%20Ubuntu%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-751861%22%20slang%3D%22en-US%22%3E%3CP%3EAny%20update%20on%20that%20issue%3F%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F75704%22%20target%3D%22_blank%22%3E%40sal%20mirabile%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-103244%22%20slang%3D%22en-US%22%3ERe%3A%20nvidia%20openGL%20in%20Ubuntu%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103244%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Sal%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20iv%20been%20researching%20some%20of%20the%20errors%20you%20had%20in%20your%20log%2C%20must%20cases%20with%20similar%20errors%20could%20indicate%20the%20OS%20is%20unable%20to%20detect%20the%20GPU.%20could%20you%20pleas%20confirm%20you%20deployed%26nbsp%3B%3CSPAN%3EUbuntu%2016.04%20LTS%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThe%20reason%20i%20ask%20is%20i%20stumbled%20apon%20this%20%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Faskubuntu.com%2Fquestions%2F886445%2Fhow-do-i-properly-install-cuda-8-on-an-azure-vm-running-ubuntu-14-04-lts%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Faskubuntu.com%2Fquestions%2F886445%2Fhow-do-i-properly-install-cuda-8-on-an-azure-vm-running-ubuntu-14-04-lts%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-103018%22%20slang%3D%22en-US%22%3ERe%3A%20nvidia%20openGL%20in%20Ubuntu%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103018%22%20slang%3D%22en-US%22%3EAnyone%3F%3C%2FLINGO-BODY%3E
sal mirabile
New Contributor

Hi Everyone,

 

I've created a linux based VM in Azure which uses the Nvidia graphics cards and i've been trying to get openGL working on my ubuntu azure machine and simply can't get it to work. I've wasted 12hrs so far today and i'm tearing my hear out now. I've followed microsofts guide to the letter! https://docs.microsoft.com/en-us/azure/virtual-machines/linux/n-series-driver-setup?toc=%2fazure%2fv...

 

I've read tons of posts in other forums, none of them of any help.

 

basically whenever i try and run glxinfo i get the error "couldn't find RGB GLX visual or fbconfig.

I can't run any openGL programs as it says that i don't have openGL.

I've uploaded my xorg log and i there's a line in there stating "failed to initialize GLX extension (compatible nvidia x driver not found)

 

I've also confirmed the drivers are installed correctly by running the "nvidia-smi" command

 

any help would be very much appreciated.

Sal

 

3 Replies
Anyone?

Hi Sal

 

So iv been researching some of the errors you had in your log, must cases with similar errors could indicate the OS is unable to detect the GPU. could you pleas confirm you deployed Ubuntu 16.04 LTS

 

The reason i ask is i stumbled apon this : https://askubuntu.com/questions/886445/how-do-i-properly-install-cuda-8-on-an-azure-vm-running-ubunt...

Any update on that issue? @sal mirabile 

Related Conversations