Home

How to find the real root directory of my docker compose with app services?

%3CLINGO-SUB%20id%3D%22lingo-sub-892308%22%20slang%3D%22en-US%22%3EHow%20to%20find%20the%20real%20root%20directory%20of%20my%20docker%20compose%20with%20app%20services%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-892308%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20created%20a%20docker%20compose%20file.%20In%20my%20local%20env%20this%20works%20fine.%20In%20the%20Azure%20Web%20App%20env%20this%20works%20fine%20in%20as%20much%20as%20it%20serves%20the%20nginx%20splash%20page.%20However%2C%20when%20I%20deploy%20my%20app%2C%20which%20works%20fine%20when%20it's%20in%20the%20same%20directory%20as%20the%20docker%20compose%20file%20(the%20way%20you'd%20assume%20Azure%20would%20do%20it)%2C%20it%20ignores%20my%20files%20completely.%20What's%20going%20on%3F%20Do%20I%20need%20to%20access%20bash%2C%20work%20out%20where%20my%20docker%20compose%20directory%20is%20relative%20to%20my%20build%20files%20and%20manually%20copy%20stuff%20across%3F%20Doesn't%20that%20kinda%20defeat%20the%20point%3F%20If%20I'm%20doing%20something%20wrong%20I'd%20be%20really%20interested%20to%20know%20as%20I%20had%20thought%20this%20was%20supposed%20to%20make%20the%20deploy%20process%20less%20painful%2C%20and%20I%20don't%20really%20want%20to%20go%20back%20to%20having%20to%20spin%20up%20my%20own%20Linux%20server%20every%20time.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-892308%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EApp%20Services%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
PeterDCarter
Occasional Visitor

I have created a docker compose file. In my local env this works fine. In the Azure Web App env this works fine in as much as it serves the nginx splash page. However, when I deploy my app, which works fine when it's in the same directory as the docker compose file (the way you'd assume Azure would do it), it ignores my files completely. What's going on? Do I need to access bash, work out where my docker compose directory is relative to my build files and manually copy stuff across? Doesn't that kinda defeat the point? If I'm doing something wrong I'd be really interested to know as I had thought this was supposed to make the deploy process less painful, and I don't really want to go back to having to spin up my own Linux server every time.

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
9 Replies