Home

Cannot access new vm via public ip address

%3CLINGO-SUB%20id%3D%22lingo-sub-94545%22%20slang%3D%22en-US%22%3ECannot%20access%20new%20vm%20via%20public%20ip%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-94545%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20am%20new%20to%20Azure.%20%26nbsp%3BI%20have%20created%20a%20new%20vm%2C%20which%20i%20am%20able%20to%20access%20via%20rdp%20and%20have%20setup%20iis%2C%20which%20is%20accessialbe%20via%20the%20internal%20ip%20address.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20setup%20a%20load%20balancer%20and%20virtual%20public%20address.%20%26nbsp%3BI%20have%20inserted%20the%20public%20ip%20address%20on%20our%20web%20hosting%20providers%20portal.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20problem%20i%20have%20is%20i%20cant%20access%20the%20public%20ip%20address%20and%20therefore%20cant%20see%20the%20iis.%20%26nbsp%3BThe%20error%20message%20say%20%22The%20site%20cant%20be%20reached%22.%3C%2FP%3E%3CP%3EAny%20help%20would%20be%20much%20appricated.%3C%2FP%3E%3CP%3Ethanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-94545%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-149300%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20access%20new%20vm%20via%20public%20ip%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-149300%22%20slang%3D%22en-US%22%3E%3CP%3EMohammad%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20was%20finally%20able%20to%20have%20success%20by%20creating%20an%20inbound%20rule%20to%20allow%20incoming%20traffic%20on%20port%2080.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EUnder%20the%20Azure%20Dashboard%2C%20I%20clicked%20on%20the%20VM%20entry%2C%20then%20under%20its%20options%20I%20scrolled%20down%20to%20Networking.%20There%20I%20created%20a%20new%20inbound%20rule%2C%20for%20port%2080%2C%20with%20a%20priority%20of%20100%2C%20and%20the%20VM%20was%20finally%20viewable%20on%20the%20public%20IP%20address.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-149287%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20access%20new%20vm%20via%20public%20ip%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-149287%22%20slang%3D%22en-US%22%3E%3CP%3EI%20seem%20to%20have%20the%20same%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-465010%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20access%20new%20vm%20via%20public%20ip%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-465010%22%20slang%3D%22en-US%22%3E%3CP%3EI%20did%20same%20and%20issue%20still%20there%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F113133%22%20target%3D%22_blank%22%3E%40Doug%20Joseph%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-856235%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20access%20new%20vm%20via%20public%20ip%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-856235%22%20slang%3D%22en-US%22%3EI%20followed%20the%20same%20approach%20and%20now%20I%20can%20access%20my%20public%20ip%20%2C%20thanks%20for%20the%20help%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-975626%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20access%20new%20vm%20via%20public%20ip%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-975626%22%20slang%3D%22en-US%22%3E%3CP%3EI%20had%20the%20same%20problem%20with%20port%2080%20open.%26nbsp%3B%3CBR%20%2F%3EI%20managed%20to%20solve%20it%20by%20getting%20a%20root%20session%20using%20terminal%20and%20reboot%20the%20VM%2C%20that%20was%20it.%20public%20ip%20is%20accessible.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Mohammad Ahmad
Occasional Visitor

Hi,

I am new to Azure.  I have created a new vm, which i am able to access via rdp and have setup iis, which is accessialbe via the internal ip address.

 

I have setup a load balancer and virtual public address.  I have inserted the public ip address on our web hosting providers portal.

 

The problem i have is i cant access the public ip address and therefore cant see the iis.  The error message say "The site cant be reached".

Any help would be much appricated.

thanks

5 Replies

I seem to have the same issue.

Mohammad:

 

I was finally able to have success by creating an inbound rule to allow incoming traffic on port 80.

 

Under the Azure Dashboard, I clicked on the VM entry, then under its options I scrolled down to Networking. There I created a new inbound rule, for port 80, with a priority of 100, and the VM was finally viewable on the public IP address.

I did same and issue still there @Doug Joseph 

I followed the same approach and now I can access my public ip , thanks for the help

I had the same problem with port 80 open. 
I managed to solve it by getting a root session using terminal and reboot the VM, that was it. public ip is accessible. 

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies