Azure Multi Factor Authentication Issues on Mobile devices

New Contributor

Hey There,


i am planning to enable Azure Multi Factor Authentication in our company. Right now i am facing some problems with mobile devices. If i am connected to the company wifi, everything works, as soon i am in UMTS or an wifi outside the company, i cant open MS Teams or Outlook for example. I tried a lot of things i found on different forums, but no success so far, maybe someone had this problem already.


If i try to open outlook it says i have to reconnect, when i try this, it asks me to open the authenticator app. After opening the app it is just loading, not opening anything, ending with an error.



Outlook App: 3.34.0

Teams App: 1.0.80

Company Portal: 3.12.0

Authenticator App: 6.3.12


Thanks in advance

4 Replies

Hey Guys,


for those who are facing the same problems, i worked around this error, by excluding managed devices from the Multi-Factor Feature.




I am using MFA with Outlook in an Android device. I am receiving Calls and text messages from MFA, even though I am not trying to authenticate.


Does any experience this issue?



Hi Sergio,

change your password, looks to me that someone else tries to authenticate with your password.

@slick156: That really is a workaround. But I'm curious: On company wifi: Is there any CA policy running which prevents you from MFA and MFA is only requested when you're outside the company? Then it may be that you only need to reconnect your Authenticator app.

Or is MFA requested and working in your internal network and not working on the outside?
Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies