Home

Logic Apps - Issue Passing Entity from Sentinel Connector to PowerShell Runbook Parameter

%3CLINGO-SUB%20id%3D%22lingo-sub-1023671%22%20slang%3D%22en-US%22%3ELogic%20Apps%20-%20Issue%20Passing%20Entity%20from%20Sentinel%20Connector%20to%20PowerShell%20Runbook%20Parameter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1023671%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20previously%20created%20some%20basic%20Logic%20Apps%20that%20would%20generate%20whenever%20an%20Azure%20Monitor%20(Log%20Analytics)%20alert%20was%20triggered%20and%20would%20then%20take%20the%20host%20name%20and%20IP%20address%20(depending%20on%20the%20use%20cases%20it%20was%20one%20or%20both)%20and%20pass%20those%20values%20generated%20from%20the%20alert%20into%20a%20%22Create%20Job%22%20event%20for%20Automation%20Account%20Logic%20Apps%20connector.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20want%20to%20move%20these%20playbooks%20into%20Sentinel%20leveraging%20the%20Sentinel%20Connector%20to%20get%20the%20data%20generated%20from%20the%20alert%2C%20grab%20the%20specific%20entities%20(in%20the%20case%20a%20HostName%2C%20IP%20or%20combination%20of%20both)%20and%20then%20pass%20those%20entities%20into%20the%20runbook%20parameters.%20I%20set%20up%20the%20Logic%20App%20as%20such%2C%20however%2C%20I'm%20running%20into%20an%20error%20(attached%20screenshot)%20stating%20the%20input%20value%20was%20not%20a%20JSON%20object.%20Is%20there%20something%20I%20am%20missing%20from%20the%20Sentinel%20connector%20generating%20the%20results%20and%20passing%20that%20entity%20on%3F%20Does%20it%20need%20to%20be%20converted%20into%20a%20JSON%20object%20after%20getting%20the%20entities%2C%20and%20if%20so%2C%20how%20would%20I%20go%20about%20doing%20that%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3ESean%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1023794%22%20slang%3D%22en-US%22%3ERe%3A%20Logic%20Apps%20-%20Issue%20Passing%20Entity%20from%20Sentinel%20Connector%20to%20PowerShell%20Runbook%20Parameter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1023794%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F113720%22%20target%3D%22_blank%22%3E%40Sean%20Hecht%3C%2FA%3E%26nbsp%3BIt%20may%20be%20that%20you%20need%20to%20load%20the%20Incident%20between%20the%20trigger%20and%20the%20Get%20hosts%20alert%20and%20use%20the%20Entites%20from%20the%20Incident%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1023968%22%20slang%3D%22en-US%22%3ERe%3A%20Logic%20Apps%20-%20Issue%20Passing%20Entity%20from%20Sentinel%20Connector%20to%20PowerShell%20Runbook%20Parameter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1023968%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F46875%22%20target%3D%22_blank%22%3E%40Gary%20Bushey%3C%2FA%3E%2C%26nbsp%3Bwill%20try%20that%20out%20and%20let%20you%20know%20the%20results.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1024139%22%20slang%3D%22en-US%22%3ERe%3A%20Logic%20Apps%20-%20Issue%20Passing%20Entity%20from%20Sentinel%20Connector%20to%20PowerShell%20Runbook%20Parameter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1024139%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F46875%22%20target%3D%22_blank%22%3E%40Gary%20Bushey%3C%2FA%3E%26nbsp%3BThanks%20again%20for%20the%20suggestion%2C%20unfortunately%20it's%20still%20running%20into%20the%20same%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1024397%22%20slang%3D%22en-US%22%3ERe%3A%20Logic%20Apps%20-%20Issue%20Passing%20Entity%20from%20Sentinel%20Connector%20to%20PowerShell%20Runbook%20Parameter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1024397%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F113720%22%20target%3D%22_blank%22%3E%40Sean%20Hecht%3C%2FA%3E%26nbsp%3BI%20had%20a%20response%20come%20back%20that%20was%20throwing%20a%20JSON%20Formatting%20error%20and%20it%20went%20away%20when%20I%20completely%20rebuilt%20my%20workbook%20from%20scratch.%26nbsp%3B%20Not%20sure%20if%20that%20is%20how%20you%20built%20this%20one%20or%20not.%26nbsp%3B%20Hope%20it%20helps.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Sean Hecht
Occasional Contributor

Hi All,

 

I previously created some basic Logic Apps that would generate whenever an Azure Monitor (Log Analytics) alert was triggered and would then take the host name and IP address (depending on the use cases it was one or both) and pass those values generated from the alert into a "Create Job" event for Automation Account Logic Apps connector. 

 

I want to move these playbooks into Sentinel leveraging the Sentinel Connector to get the data generated from the alert, grab the specific entities (in the case a HostName, IP or combination of both) and then pass those entities into the runbook parameters. I set up the Logic App as such, however, I'm running into an error (attached screenshot) stating the input value was not a JSON object. Is there something I am missing from the Sentinel connector generating the results and passing that entity on? Does it need to be converted into a JSON object after getting the entities, and if so, how would I go about doing that?

 

Thanks,

Sean

6 Replies

@Sean Hecht It may be that you need to load the Incident between the trigger and the Get hosts alert and use the Entites from the Incident

Thanks @Gary Bushey, will try that out and let you know the results.

@Gary Bushey Thanks again for the suggestion, unfortunately it's still running into the same issue.

@Sean Hecht I had a response come back that was throwing a JSON Formatting error and it went away when I completely rebuilt my workbook from scratch.  Not sure if that is how you built this one or not.  Hope it helps.

@Gary Bushey Thanks for the heads up there as well. Went and re-created the entire flow and still hitting those same errors, at this point not entirely sure what the issue is.

 

Thanks again.

@Sean Hecht The only other thing I can suggest is writing out the values into a Team message to see if there is something wrong with it.

 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies