Azure PaaS Developer blog
Copied!
Home
Options
812
mohitkhanna on 10-09-2019 07:10 AM
450
Braja on 09-20-2019 05:26 AM
1,830
Vivekananda_G_MSFT on 09-12-2019 10:46 PM
892
manish_gupta on 09-05-2019 06:30 AM
3,525
anantkm_msft on 08-09-2019 06:22 AM
2,235
Braja on 08-09-2019 02:43 AM
1,349
Braja on 07-25-2019 09:24 AM
Latest Comments
Thank you @Josh_Gallagher I confirm "RequestScheme" works, although I had to wait a few hours before seeing a consistent redirect on every device and browser.
0 Likes
Hello everyone,Sorry for the delayed response as i was away from work for sometime. Checked the updates here internally and understood that the fix had been pushed and the http to https redirection rule shall work, however you need to use the "RequestScheme" rule condition instead of "RequestMethod"...
1 Likes
Okay, so trying this again it seems that if I use only the "RequestScheme" condition mentioned in my last comment, and not the "GET" condition, it works. It is also possible that when I tried to have both conditions in the rule yesterday I did not leave enough time for the policy to propagate before...
1 Likes
This seems to have been resolved now. I just completed the steps without error today. However, this then resulted in an infinite redirect as it seemed to be matching HTTPS as well as HTTP. Given that the rule only matches GET verbs and ignores the scheme, I guess this was to be expected. I tried to ...
0 Likes
Thank you @Braja! We're holding up a production rollout of a site, so this fix will be much appreciated.
0 Likes