Home

Microsoft Monitoring Agent Setup Error

%3CLINGO-SUB%20id%3D%22lingo-sub-139950%22%20slang%3D%22en-US%22%3EMicrosoft%20Monitoring%20Agent%20Setup%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-139950%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20getting%20an%20error%20while%20trying%20to%20install%20the%20agent%20on%20two%20servers...%20I%20have%20one%20working%20just%20fine.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EInvalid%20Azure%20Log%20Analytics%20Configuration%3C%2FP%3E%0A%3CP%3EUnknown%20error%20was%20encountered%20during%20setup.%26nbsp%3B%20Please%20check%20log%20file%3A%20(%25temp%25%5CMonitoringAgent.log).%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20510px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F26147i78E2B39B625C6A86%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Capture.JPG%22%20title%3D%22Capture.JPG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3EAny%20suggestions%3F%3C%2FP%3E%0A%3CP%3EHere%20is%20the%20log%20file%20I%20inserted%201234567890%20into%20spots%20tied%20to%20my%20account...%3C%2FP%3E%0A%3CPRE%3E2017-12-26T11%3A12%3A30.6140400-06%3A00%20Debug%3A%20%0A%0A%20***%20Trace%20Started%20***%0A%0A%0A2017-12-26T11%3A12%3A30.6296658-06%3A00%20Debug%3A%20Workspace%20ID%201234567890%0A2017-12-26T11%3A12%3A30.6296658-06%3A00%20Debug%3A%20Azure%20Cloud%20Type%200%20%0A2017-12-26T11%3A12%3A30.6296658-06%3A00%20Debug%3A%20Proxy%20Url%20%20%0A2017-12-26T11%3A12%3A30.6296658-06%3A00%20Debug%3A%20Proxy%20User%20Name%20%20%3A%0A2017-12-26T11%3A12%3A30.6296658-06%3A00%20Debug%3A%20Current%20Connector%20Version%20August%2C%202014%3A%0A2017-12-26T11%3A12%3A30.6296658-06%3A00%20Debug%3A%20Is%20Certificate%20Pinning%20Disabled%20%3A%0A2017-12-26T11%3A12%3A30.6296658-06%3A00%20Debug%3A%20Logging%20url%20https%3A%2F%2F1234567890.oms.opinsights.azure.com%2FValidationService.Svc%2FValidateWorkspaceKey%3FWorkspaceId%3D1234567890%20%0A2017-12-26T11%3A12%3A30.6452848-06%3A00%20Debug%3A%20x-ms-version%20%3A%20August%2C%202014%0A2017-12-26T11%3A12%3A30.6452848-06%3A00%20Debug%3A%20x-ms-Date%20%3A%202017-12-26T11%3A12%3A30.6296658-06%3A00%0A2017-12-26T11%3A12%3A30.6452848-06%3A00%20Debug%3A%20x-ms-SHA256_Content%20%3A%201234567890%0A2017-12-26T11%3A12%3A30.6452848-06%3A00%20Debug%3A%20Authorization%20%3A%201234567890%0A2017-12-26T11%3A12%3A30.6452848-06%3A00%20Debug%3A%20X-Request-ID%20%3A%201234567890%0A2017-12-26T11%3A12%3A30.7702985-06%3A00%20Error%3A%20Failed%20to%20connect%2C%20exception%20%3A%20System.Net.WebException%3A%20The%20underlying%20connection%20was%20closed%3A%20An%20unexpected%20error%20occurred%20on%20a%20receive.%20---%26gt%3B%20System.ComponentModel.Win32Exception%3A%20The%20client%20and%20server%20cannot%20communicate%2C%20because%20they%20do%20not%20possess%20a%20common%20algorithm%0A%20%20%20at%20System.Net.SSPIWrapper.AcquireCredentialsHandle(SSPIInterface%20SecModule%2C%20String%20package%2C%20CredentialUse%20intent%2C%20SecureCredential%20scc)%0A%20%20%20at%20System.Net.Security.SecureChannel.AcquireCredentialsHandle(CredentialUse%20credUsage%2C%20SecureCredential%26amp%3B%20secureCredential)%0A%20%20%20at%20System.Net.Security.SecureChannel.AcquireClientCredentials(Byte%5B%5D%26amp%3B%20thumbPrint)%0A%20%20%20at%20System.Net.Security.SecureChannel.GenerateToken(Byte%5B%5D%20input%2C%20Int32%20offset%2C%20Int32%20count%2C%20Byte%5B%5D%26amp%3B%20output)%0A%20%20%20at%20System.Net.Security.SecureChannel.NextMessage(Byte%5B%5D%20incoming%2C%20Int32%20offset%2C%20Int32%20count)%0A%20%20%20at%20System.Net.Security.SslState.StartSendBlob(Byte%5B%5D%20incoming%2C%20Int32%20count%2C%20AsyncProtocolRequest%20asyncRequest)%0A%20%20%20at%20System.Net.Security.SslState.ForceAuthentication(Boolean%20receiveFirst%2C%20Byte%5B%5D%20buffer%2C%20AsyncProtocolRequest%20asyncRequest)%0A%20%20%20at%20System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult%20lazyResult)%0A%20%20%20at%20System.Threading.ExecutionContext.RunInternal(ExecutionContext%20executionContext%2C%20ContextCallback%20callback%2C%20Object%20state%2C%20Boolean%20preserveSyncCtx)%0A%20%20%20at%20System.Threading.ExecutionContext.Run(ExecutionContext%20executionContext%2C%20ContextCallback%20callback%2C%20Object%20state%2C%20Boolean%20preserveSyncCtx)%0A%20%20%20at%20System.Threading.ExecutionContext.Run(ExecutionContext%20executionContext%2C%20ContextCallback%20callback%2C%20Object%20state)%0A%20%20%20at%20System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult%20result)%0A%20%20%20at%20System.Net.TlsStream.Write(Byte%5B%5D%20buffer%2C%20Int32%20offset%2C%20Int32%20size)%0A%20%20%20at%20System.Net.ConnectStream.WriteHeaders(Boolean%20async)%0A%20%20%20---%20End%20of%20inner%20exception%20stack%20trace%20---%0A%20%20%20at%20System.Net.HttpWebRequest.GetResponse()%0A%20%20%20at%20Microsoft.MOMv3.Setup.MOMv3ManagedCAs.ValidateOpInsightsConnection(Session%20session)%0A2017-12-26T11%3A12%3A30.7702985-06%3A00%20Debug%3A%20%0A%0A%20***%20Trace%20Ended%20***%0A%0A%0A%3C%2FPRE%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-139950%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAgents%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%20Log%20Analytics%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-472532%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Monitoring%20Agent%20Setup%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-472532%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F104968%22%20target%3D%22_blank%22%3E%40Carlos%20Rapa%3C%2FA%3E%26nbsp%3B%3C%2FP%3ECarlos%2C%20if%20you%20haven't%20already%20figured%20this%20out%2C%20double%20check%20your%20internet%20connection.%20The%20agent%20requires%20internet%20connection%20to%20connect%20to%20the%20Azure%20portal%2C%20so%20you%20need%20to%20configure%20the%20Proxy%20settings.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-140051%22%20slang%3D%22en-US%22%3ERE%3A%20Microsoft%20Monitoring%20Agent%20Setup%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-140051%22%20slang%3D%22en-US%22%3EIll%20answer%20my%20own%20here....%20after%20messing%20with%20it%20for%20a%20day....%20If%20you%20do%0Anot%20check%20the%20Connect%20the%20agent%20to%20Azure%20Log%20Analytics%20(OMS)%20on%20the%0Ainitial%20install%20then%20go%20to%20the%20control%20panel%20after%20and%20set%20it%20up%0Aeverything%20works%20out.%3C%2FLINGO-BODY%3E
Carlos Rapa
New Contributor

I am getting an error while trying to install the agent on two servers... I have one working just fine.

 

Invalid Azure Log Analytics Configuration

Unknown error was encountered during setup.  Please check log file: (%temp%\MonitoringAgent.log).

Capture.JPG

Any suggestions?

Here is the log file I inserted 1234567890 into spots tied to my account...

2017-12-26T11:12:30.6140400-06:00	Debug:	

 *** Trace Started ***


2017-12-26T11:12:30.6296658-06:00	Debug:	Workspace ID 1234567890
2017-12-26T11:12:30.6296658-06:00	Debug:	Azure Cloud Type 0 
2017-12-26T11:12:30.6296658-06:00	Debug:	Proxy Url  
2017-12-26T11:12:30.6296658-06:00	Debug:	Proxy User Name  :
2017-12-26T11:12:30.6296658-06:00	Debug:	Current Connector Version August, 2014:
2017-12-26T11:12:30.6296658-06:00	Debug:	Is Certificate Pinning Disabled :
2017-12-26T11:12:30.6296658-06:00	Debug:	Logging url https://1234567890.oms.opinsights.azure.com/ValidationService.Svc/ValidateWorkspaceKey?WorkspaceId=1234567890 
2017-12-26T11:12:30.6452848-06:00	Debug:	x-ms-version : August, 2014
2017-12-26T11:12:30.6452848-06:00	Debug:	x-ms-Date : 2017-12-26T11:12:30.6296658-06:00
2017-12-26T11:12:30.6452848-06:00	Debug:	x-ms-SHA256_Content : 1234567890
2017-12-26T11:12:30.6452848-06:00	Debug:	Authorization : 1234567890
2017-12-26T11:12:30.6452848-06:00	Debug:	X-Request-ID : 1234567890
2017-12-26T11:12:30.7702985-06:00	Error:	Failed to connect, exception : System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.ComponentModel.Win32Exception: The client and server cannot communicate, because they do not possess a common algorithm
   at System.Net.SSPIWrapper.AcquireCredentialsHandle(SSPIInterface SecModule, String package, CredentialUse intent, SecureCredential scc)
   at System.Net.Security.SecureChannel.AcquireCredentialsHandle(CredentialUse credUsage, SecureCredential& secureCredential)
   at System.Net.Security.SecureChannel.AcquireClientCredentials(Byte[]& thumbPrint)
   at System.Net.Security.SecureChannel.GenerateToken(Byte[] input, Int32 offset, Int32 count, Byte[]& output)
   at System.Net.Security.SecureChannel.NextMessage(Byte[] incoming, Int32 offset, Int32 count)
   at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result)
   at System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size)
   at System.Net.ConnectStream.WriteHeaders(Boolean async)
   --- End of inner exception stack trace ---
   at System.Net.HttpWebRequest.GetResponse()
   at Microsoft.MOMv3.Setup.MOMv3ManagedCAs.ValidateOpInsightsConnection(Session session)
2017-12-26T11:12:30.7702985-06:00	Debug:	

 *** Trace Ended ***


2 Replies
Ill answer my own here.... after messing with it for a day.... If you do not check the Connect the agent to Azure Log Analytics (OMS) on the initial install then go to the control panel after and set it up everything works out.

@Carlos Rapa 

Carlos, if you haven't already figured this out, double check your internet connection. The agent requires internet connection to connect to the Azure portal, so you need to configure the Proxy settings.