SOLVED
Home

Failed to resolve entity 'AzureDiagnostics'

%3CLINGO-SUB%20id%3D%22lingo-sub-190342%22%20slang%3D%22en-US%22%3EFailed%20to%20resolve%20entity%20'AzureDiagnostics'%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-190342%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20I%20run%20query%26nbsp%3B%3C%2FP%3E%3CDIV%3E%3CDIV%3E%3CSPAN%3EAzureDiagnostics%3C%2FSPAN%3E%3CSPAN%3E%7C%20%3C%2FSPAN%3E%3CSPAN%3Ewhere%3C%2FSPAN%3E%3CSPAN%3E%20ResourceProvider%20%3D%3D%20%3C%2FSPAN%3E%3CSPAN%3E%22MICROSOFT.AUTOMATION%22%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EIt%20shows%20%22Failed%20to%20resolve%20entity%20'AzureDiagnostics'%22%3CBR%20%2F%3E%3CBR%20%2F%3EPlease%20help%20me!%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EThanks%20in%20advance.%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-190342%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20Log%20Analytics%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-190366%22%20slang%3D%22en-US%22%3ERe%3A%20Failed%20to%20resolve%20entity%20'AzureDiagnostics'%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-190366%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%0A%3CP%3EBefore%20actually%20AzureDiagnostics%20table%20to%20appear%20in%20Log%20Analytics%20you%20need%20to%20forward%20such%20logs%20from%20one%20of%20the%20Azure%20Services%20that%20have%20such.%20Just%20for%20reference%20here%20is%20all%20the%20services%20that%20support%20such%20logs%3A%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fmonitoring-and-diagnostics%2Fmonitoring-diagnostic-logs-schema%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fmonitoring-and-diagnostics%2Fmonitoring-diagnostic-logs-schema%3C%2FA%3E%3C%2FP%3E%0A%3CP%3EFor%20some%20services%20you%20can%20forward%20the%20logs%20via%20Azure%20Portal%20for%20others%20you%20will%20have%20to%20use%20PowerShell%2C%20CLI%20or%20ARM.%20Specifically%20for%20Azure%20Automation%20see%20here%20how%20these%20are%20forwarded%20to%20Log%20Analytics%3A%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fautomation%2Fautomation-manage-send-joblogs-log-analytics%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fautomation%2Fautomation-manage-send-joblogs-log-analytics%3C%2FA%3E%3C%2FP%3E%0A%3CP%3EAfter%20configuring%20that%20setting%20and%20you%20have%20a%20new%20job%20started%2Frunning%20you%20will%20start%20to%20see%20the%20logs%20in%20Log%20Analytics.%3C%2FP%3E%3C%2FLINGO-BODY%3E
The Nguyen
Occasional Visitor

When I run query 

AzureDiagnostics| where ResourceProvider == "MICROSOFT.AUTOMATION"
 
It shows "Failed to resolve entity 'AzureDiagnostics'"

Please help me!
Thanks in advance.
1 Reply
Solution

Hi,

Before actually AzureDiagnostics table to appear in Log Analytics you need to forward such logs from one of the Azure Services that have such. Just for reference here is all the services that support such logs:

https://docs.microsoft.com/en-us/azure/monitoring-and-diagnostics/monitoring-diagnostic-logs-schema

For some services you can forward the logs via Azure Portal for others you will have to use PowerShell, CLI or ARM. Specifically for Azure Automation see here how these are forwarded to Log Analytics:

https://docs.microsoft.com/en-us/azure/automation/automation-manage-send-joblogs-log-analytics

After configuring that setting and you have a new job started/running you will start to see the logs in Log Analytics.