Home

Unable to Enter Password in Outlook Password Prompt After Federation - ADFS Related?

%3CLINGO-SUB%20id%3D%22lingo-sub-644222%22%20slang%3D%22en-US%22%3EUnable%20to%20Enter%20Password%20in%20Outlook%20Password%20Prompt%20After%20Federation%20-%20ADFS%20Related%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-644222%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20configured%20ADFS%203.0%20with%20a%20proxy%20in%20a%20DMZ.%26nbsp%3B%20It%20has%20a%20newly%20installed%20and%20configured%20certificate.%26nbsp%3B%20All%20of%20the%20tests%20return%20happy%20results.%26nbsp%3B%20Everything%20appears%20to%20be%20as%20it%20is%20supposed%20to.%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20we%20were%20fully%20satisfied%20that%20everything%20was%20working%20as%20desired%20we%20executed%20the%20necessary%20commands%20to%20federate%20the%20two%20domains%20and%20then%20updated%20ADConnect%20with%20the%20new%20sign-in%20option.%26nbsp%3B%20Once%20again%2C%20everything%20appears%20happy%20and%20functioning%20as%20required.%26nbsp%3B%3C%2FP%3E%3CP%3ETesting%20with%20a%20client%20machine%20also%20returned%20the%20results%20expected.%26nbsp%3B%20The%20client%20was%20successfully%20able%20to%20connect%20internally%20and%20externally%20to%20the%20desired%20Office%20365%20resources%20with%20the%20expected%20prompts%20and%20no%20errors%20presented.%26nbsp%3B%20Most%20of%20the%20users%20experienced%20similar%20results.%3C%2FP%3E%3CP%3EA%20small%20number%20of%20users%20encountered%20something%20else%20and%20I'm%20trying%20to%20figure%20out%20where%20to%20look%20to%20diagnose%20what's%20happening.%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20using%20the%20Outlook%20desktop%20client%20the%20%22Connected%20to%3A%22%20at%20the%20bottom%20never%20changes%20and%20the%20client%20never%20connects%20to%20Exchange.%3C%2FP%3E%3CP%3EWhen%20the%20user%20clicks%20on%20the%20%22Connected%20to%3A%22%20he%20is%20presented%20with%20a%20login%20prompt%2C%20enters%20his%20UPN%20and%20password%20and%20is%20again%20presented%20with%20the%20login%20prompt.%26nbsp%3B%20His%20UPN%20and%20password%20are%20correct.%3C%2FP%3E%3CP%3EWhen%20we%20attempt%20to%20login%20with%20the%20UPN%20and%20password%20through%20the%20Office%20365%20portal%20it%20directs%20back%20to%20the%20ADFS%20portal%2C%20as%20desired%2C%20but%20will%20not%20populate%20the%20password.%26nbsp%3B%20What%20I%20mean%20by%20that%20is%20the%20user%20types%20in%20his%20password%20and%20it%20is%20immediately%20removed%20from%20the%20space%20each%20time.%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20chalking%20this%20up%20to%20an%20issue%20with%20the%20client%20and%20not%20the%20ADFS%20infrastructure%20as%20the%20majority%20of%20the%20user%20population%20appeared%20to%20be%20working%20just%20fine.%3C%2FP%3E%3CP%3EWe've%20rolled%20back%2C%20returned%20to%20%22Managed%22%2C%20to%20allow%20the%20impacted%20users%20to%20continue%20to%20work.%3C%2FP%3E%3CP%3EAm%20I%20reading%20this%20correctly%3F%26nbsp%3B%20Is%20it%20a%20client%20issue%3F%26nbsp%3B%20Where%20should%20I%20be%20looking%20to%20troubleshoot%3F%26nbsp%3B%20The%20ADFS%20logs%20have%20not%20shown%20anything%20related%20to%20these%20clients%20that%20we%20can%20see.%26nbsp%3B%20Any%20assistance%20you%20might%20be%20able%20to%20provide%20would%20be%20appreciated.%26nbsp%3B%20Thanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-644222%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-644980%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Enter%20Password%20in%20Outlook%20Password%20Prompt%20After%20Federation%20-%20ADFS%20Related%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-644980%22%20slang%3D%22en-US%22%3E%3CP%3EFirst%20of%20all%2C%20make%20sure%20that%20all%20the%20relevant%20events%20are%20being%20logged%20as%20older%20versions%20of%20AD%20FS%20have%20them%20off%20by%20default%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fidentity%2Fad-fs%2Ftroubleshooting%2Fad-fs-tshoot-logging%23security-auditing%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fidentity%2Fad-fs%2Ftroubleshooting%2Fad-fs-tshoot-logging%23security-auditing%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20that%20doesn't%20help%20you%20locate%20the%20relevant%20events%2C%20you%20can%20also%20enable%20debug%20tracing%20(covered%20in%20the%20above%20article).%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ENow%2C%20judging%20by%20the%20symptoms%2C%20the%20user%20seems%20to%20be%20authenticating%20OK%20(otherwise%20you%20would%20see%20an%20error%20stating%20password%20is%20incorrect)%2C%20so%20the%20issue%20is%20most%20likely%20related%20to%20the%20claims%20issuance%20part%20of%20the%20process.%20It%20might%20be%20as%20simple%20as%20incorrectly%20configured%20attribute%20on%20the%20user%20object%2C%20but%20you%20should%20also%20check%20all%20your%20claims%20rules%2C%20including%20any%20rules%20that%20enforce%20additional%20authentication.%20You%20can%20rule%20out%20some%20of%20the%20user-related%20issues%20by%20checking%20the%20idp-initiated%20flow%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fidentity%2Fad-fs%2Ftroubleshooting%2Fad-fs-tshoot-initiatedsignon%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fidentity%2Fad-fs%2Ftroubleshooting%2Fad-fs-tshoot-initiatedsignon%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20above%20test%20will%20also%20tell%20you%20if%20the%20issue%20is%20specific%20to%20the%20O365%20RPT%2C%20in%20which%20case%20you%20can%20focus%20on%20the%20O365-specific%20attributes%20(objectID%20and%20UPN%20most%20importantly)%20and%20claims%20rules.%20And%20you%20can%20always%20capture%20a%20Fiddler%20trace%20as%20well%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fidentity%2Fad-fs%2Ftroubleshooting%2Fad-fs-tshoot-fiddler-ws-fed%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fidentity%2Fad-fs%2Ftroubleshooting%2Fad-fs-tshoot-fiddler-ws-fed%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-645022%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Enter%20Password%20in%20Outlook%20Password%20Prompt%20After%20Federation%20-%20ADFS%20Related%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-645022%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%20.%26nbsp%3B%20Good%20places%20to%20start.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Mitch Sprague
Occasional Contributor

We have configured ADFS 3.0 with a proxy in a DMZ.  It has a newly installed and configured certificate.  All of the tests return happy results.  Everything appears to be as it is supposed to. 

When we were fully satisfied that everything was working as desired we executed the necessary commands to federate the two domains and then updated ADConnect with the new sign-in option.  Once again, everything appears happy and functioning as required. 

Testing with a client machine also returned the results expected.  The client was successfully able to connect internally and externally to the desired Office 365 resources with the expected prompts and no errors presented.  Most of the users experienced similar results.

A small number of users encountered something else and I'm trying to figure out where to look to diagnose what's happening. 

When using the Outlook desktop client the "Connected to:" at the bottom never changes and the client never connects to Exchange.

When the user clicks on the "Connected to:" he is presented with a login prompt, enters his UPN and password and is again presented with the login prompt.  His UPN and password are correct.

When we attempt to login with the UPN and password through the Office 365 portal it directs back to the ADFS portal, as desired, but will not populate the password.  What I mean by that is the user types in his password and it is immediately removed from the space each time. 

I'm chalking this up to an issue with the client and not the ADFS infrastructure as the majority of the user population appeared to be working just fine.

We've rolled back, returned to "Managed", to allow the impacted users to continue to work.

Am I reading this correctly?  Is it a client issue?  Where should I be looking to troubleshoot?  The ADFS logs have not shown anything related to these clients that we can see.  Any assistance you might be able to provide would be appreciated.  Thanks!

 

2 Replies

First of all, make sure that all the relevant events are being logged as older versions of AD FS have them off by default: https://docs.microsoft.com/en-us/windows-server/identity/ad-fs/troubleshooting/ad-fs-tshoot-logging#...

 

If that doesn't help you locate the relevant events, you can also enable debug tracing (covered in the above article).

 

Now, judging by the symptoms, the user seems to be authenticating OK (otherwise you would see an error stating password is incorrect), so the issue is most likely related to the claims issuance part of the process. It might be as simple as incorrectly configured attribute on the user object, but you should also check all your claims rules, including any rules that enforce additional authentication. You can rule out some of the user-related issues by checking the idp-initiated flow: https://docs.microsoft.com/en-us/windows-server/identity/ad-fs/troubleshooting/ad-fs-tshoot-initiate...

 

The above test will also tell you if the issue is specific to the O365 RPT, in which case you can focus on the O365-specific attributes (objectID and UPN most importantly) and claims rules. And you can always capture a Fiddler trace as well: https://docs.microsoft.com/en-us/windows-server/identity/ad-fs/troubleshooting/ad-fs-tshoot-fiddler-...

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies